Storage Boards Cleanup
To make it easier to find information about HPE Storage products and solutions, we are doing spring cleaning. This includes consolidation of some older boards, and a simpler structure that more accurately reflects how people use HPE Storage.
Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

Ultrium 3000 LTFS in Windows not working

m01
Occasional Contributor

Ultrium 3000 LTFS in Windows not working

I cannot get LTFS in Windows to work correctly even though Library and Tape Tools works fine.  I get these errors when formatting in the LTFS wizard:

 

LTFS15000I Starting mkltfs, HP StoreOpen Standalone version 2.2.0, log level 2
LTFS15041I Launched by "mkltfs -f -d TAPE0"
LTFS15042I This binary is built for Windows
LTFS15043I GCC version is 4.6.3
LTFS17087I Kernel version: Windows
LTFS15003I Formatting device 'TAPE0'
LTFS15004I LTFS volume blocksize: 524288
LTFS15005I Index partition placement policy: None

LTFS17085I Plugin: Loading "ltotape_win" driver
LTFS20013I Drive type is HP LTO5, serial number is HU1032BR7D
LTFS20023E Backend SCSI subsystem error from DeviceIOControl (0x57)
LTFS12034E Cannot get maximum device blocksize: backend call failed (-1)
LTFS17160I Maximum device block size is -1
LTFS20023E Backend SCSI subsystem error from DeviceIOControl (0x57)
LTFS12021E Cannot load the medium: failed to get device parameters (-1)
LTFS11093E Cannot format: failed to load the medium (-1)
LTFS20076I Triggering drive diagnostic dump
LTFS20096I Diagnostic dump complete
LTFS20023E Backend SCSI subsystem error from DeviceIOControl (0x57)
LTFS20072E Failed to read mode data (-1)
LTFS20076I Triggering drive diagnostic dump
LTFS20096I Diagnostic dump complete
LTFS17154E Cannot set WRITE MODE: Mode Sense for Device Configuration Extension failed (-1)
LTFS15023I Formatting failed

 

If I try to map an already-formatted LTFS tape, it will create the drive mapping, but then I get "The parameter is incorrect" errors when trying to use the drive letter.

 

The drive and LTFS work fine in CentOS on the same computer.

 

Why would only the LTFS tools on Windows be nonfunctional?

2 REPLIES
Kirill Bogdanov
Occasional Advisor

Re: Ultrium 3000 LTFS in Windows not working

Did you try to set block size to 64K or less?

VaDa
Occasional Visitor

Re: Ultrium 3000 LTFS in Windows not working

Please try updating the latest driver for the storage controller connecting the tape drive