Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

Ultrium 448 Autoloader- not finding drivers for the drive selector

Sudhindra_2
Occasional Visitor

Ultrium 448 Autoloader- not finding drivers for the drive selector

The autoloader is connected to a DL380G4. the tape drive is getting detected with proper drivers in the device manager of windows 2003. But the drive selector is showing up under unknown device. not received any driver cd. there are no drivers on the HP website. tried the generic driver file hptapedrvrs.exe for the 1/8 autoloader which installed the drivers for the tape drive and not for the drive selector.Backup Exec also fails to install the drivers for the drive selector.
Please advice
16 REPLIES
David Ruska
Honored Contributor

Re: Ultrium 448 Autoloader- not finding drivers for the drive selector

Sudhindra,

Which version of backup exec are you using?

The driver for the autoloader (not drive) is typically provided by the backup application vendor.

I believe the first version of backup exec that supports the 1/8 448 autoloader is 10.0.

The journey IS the reward.
Sudhindra_2
Occasional Visitor

Re: Ultrium 448 Autoloader- not finding drivers for the drive selector

Using Backup Exec 10 and its not recognising the drive selector. HP website does not list any drivers for this Autoloader in the download section. usually we are able to find the drivers for all the tape drives when go to the drivers and software downloads link for that particular product.The Autoloader is just a tape drive as of now without the drivers.
Marino Meloni_1
Honored Contributor

Re: Ultrium 448 Autoloader- not finding drivers for the drive selector

It is correct to see the media changer as unknown media changer under windows device manager
the Autoloader with LTO 448 is supported by Bexec vers. 10.0
http://seer.support.veritas.com/docs/274348.htm

see this link for more info
http://seer.support.veritas.com/docs/278111.htm

Download here drivers package for Veritas Bexec

http://seer.support.veritas.com/docs/277619.htm

marino
Sudhindra_2
Occasional Visitor

Re: Ultrium 448 Autoloader- not finding drivers for the drive selector

Hello marino, thanks for those links. i downloaded the 25 MB driver file from the veritas website and tried it. no luck. the autoloader is still not recognised. my friend who has purchased this autoloader is now planning to return the drive to HP.
There is another drive in my friends office and that also has the same issue.that makes it 2 autoloaders not being recognised on different servers.

HP has not provided the driver cd and there are no drivers for this on the HP website. i am wondering how come HP is selling this product in the market without drivers and depending on Veritas software to recognise the autoloader. I am of the opinion that any OEM's should provide their own drivers.
Marino Meloni_1
Honored Contributor

Re: Ultrium 448 Autoloader- not finding drivers for the drive selector

There is no drives for the medium changer because the default one is who is embedded in the OS is valid for the few action Windows support on it.
Windows do not support libraries, and That is why you do not need a specific driver for the changers.
In order to use the autoloaders and the library in random mode, you need a Backup SW, and this SW provvide the drivers that will be able to manage the SCSI commands sent to the device.
Now if the device is discovered in the device manager with "unknown medium changer" this is ok, it is recognized by the os and should work. If the device is then not recognized/managed by Veritas, this may be due to the enquiry string not correctly recorded in the Bexec list, (on the web it is) and you may try to contact Veritas to see why it is not in this list

marino

David Ruska
Honored Contributor

Re: Ultrium 448 Autoloader- not finding drivers for the drive selector

Sudhindra,

You stated:
> The autoloader is connected to a DL380G4. The tape drive is getting detected with proper drivers in the device manager of windows 2003. But the drive selector is showing up under unknown device. not received any driv

And:
> I downloaded the 25 MB driver file from the veritas website and tried it. no luck. the autoloader is still not recognised.

Is the autoloader robotic (what you refer to as the drive selector?) device appearing on your system? It should appear with an ID string of "HP 1x8 autoloader", and the drive should appear as "HP Ultrium 2-SCSI".

In windows device manager, it will only say "Unknown Medium Changer device", but you can identify it by looking under properties and verifying it has the same hardware path as the drive, but at LUN 1 (e.g. "location: Bus Number 0, Target ID 5, LUN 1).

Perhaps the best way to verify your HBA is seeing the robotic controller is to install HP Library & Tape Tools (www.hp.com/support/tapetools), as it will show all the inquiry strings and associate the robotic controller and drive together.

What HBA are you using to connect this device?

The DL380G4 can have a smart array 6i controller installed. This card will NOT support the 1/8 448 autoloader because it requires SCSI LUN addressing to communicate to the robotic controller. You can look in the EBS compatability matrix to see which HBAs are supported (www.hp.com/go/ebs and then click on the compatability matrix link). You need an HBA that supports LUN addressing (e.g. multiple LUNs per ID).

The version of B.E. 10 mentioned (10.0.5484) is the tested and correct version to use with these autoloaders (also detailed in the above matrix).

You also stated:
> my friend who has purchased this autoloader is now planning to return the drive to HP. There is another drive in my friends office and that also has the same issue.that makes it 2 autoloaders not being recognised on different servers.

Please provide the details separately of those system configurations and we will identify what is wrong.
The journey IS the reward.
Sudhindra_2
Occasional Visitor

Re: Ultrium 448 Autoloader- not finding drivers for the drive selector

thanks,
for these inputs.will inform about the progress.
David Ruska
Honored Contributor

Re: Ultrium 448 Autoloader- not finding drivers for the drive selector

Thank you Sudhindra.

If you do resolve the problems, please let us know where the issues occured. For example, is our product documentation incomplete or confusing?

We would like to eliminate similar problems others could have with these products.

HP Engineering
The journey IS the reward.
David Ruska
Honored Contributor

Re: Ultrium 448 Autoloader- not finding drivers for the drive selector

I had stated earlier:

> The version of B.E. 10 mentioned (10.0.5484) is the tested and correct version to use with these autoloaders (also detailed in the above matrix).

From another forum thread (http://forums1.itrc.hp.com/service/forums/bizsupport/questionanswer.do?threadId=945677),

it mentions the need of version 10.0.5520 to obtain the proper drivers for the new 1x8 autoloaders. I will attempt to verify that.
The journey IS the reward.
PaulD_2
Occasional Visitor

Re: Ultrium 448 Autoloader- not finding drivers for the drive selector

hi all, i have exactly the same issue with
HP StorageWorks 1/8 Ultrium 448 Tape Autoloader.

My Win2003 system recognizes Drive and Loader.
Veritas 10.0.5520 only has its own drivers for Drive and does not have for Loader.

As a result Veritas sees only Drive and does not see Loader.

Where/How to find drivers for Loader?

Also i have HP StorageWorks 1/8 Ultrium 460, HP site provides drivers for this loader and somehow does not provide for 448
PaulD_2
Occasional Visitor

Re: Ultrium 448 Autoloader- not finding drivers for the drive selector

Gosh, I found solution.
My Loader had firmware v1.2, after I updated it to v1.4 Veritas found Loader.

Problem is solved for me.

David Ruska
Honored Contributor

Re: Ultrium 448 Autoloader- not finding drivers for the drive selector

Paul,

The 1.40 firmware shouldn't be required for the 448 to be used with BUE. Here's the release details: http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=PSD_CN0791W

Had you installed the BUE drivers for 5520 referenced here?
http://seer.support.veritas.com/docs/277477.htm

It looks like release 46 added support for the new 1x8 448 and 960 autoloaders, and the current release is now 47.
The journey IS the reward.
PaulD_2
Occasional Visitor

Re: Ultrium 448 Autoloader- not finding drivers for the drive selector

I tried Release (47) drivers on v1.2 firware with no luck :(

then i updated firware, reinstalled drivers and then rebooted server, after this Veritas found my Loader.
David Ruska
Honored Contributor

Re: Ultrium 448 Autoloader- not finding drivers for the drive selector


Thanks Paul. After you had installed the release 47 drivers, had you rebooted?

I wonder if the reboot after the firmware update was actually what triggered the device to be properly found. The 1.40 firmware changes only affected service-only tests.
The journey IS the reward.
PaulD_2
Occasional Visitor

Re: Ultrium 448 Autoloader- not finding drivers for the drive selector

David, you right. not new firmware helped me.

In order to see 448 Loader, Veritas has to install its own Loader driver because HP does not provide :( native drivers.

I dug deeper and found name of this driver. It is BNCHMRK2.VSD. Somehow with old firmware driver installation procedure did not copy this file to system32\drivers folder and this was the cause of my problem, I discovered this from my System event log.

i.e. finally
1. BNCHMRK2.VSD must be in system32\drivers folder
2. registry key must exists
HKLM\SYSTEM\CurrentControlSet\Services\BNCHMRK2 with valid ImagePath value
3. start>run>msinfo32.exe>software environment>system drivers
should show for BNCHMRK2 "Started=Yes"

then Veritas 9.1/10 sees 448 Loader.

hurraaa!
David Ruska
Honored Contributor

Re: Ultrium 448 Autoloader- not finding drivers for the drive selector

Paul,

Thanks for clarifying that.

I verified with our ISV team that the 1.20 firmware is the initial version integrated with BUE 10.0. The 1.40 firmware allows the autoloader to recognize the LTO1 HH drive in the new 1/8 232 autoloader. Since we use a common firmware image for the 1/8 232, 448, and 960 loaders (with the "1x8 autoloader" inquiry string), the firmware for the 1/8 448 and 960 have therefore been rolled to 1.40.

Note, the 1.20 firmware will not be put on the web, since we don't want an 1/8 232 autoloader accidentially downreved to 1.20 (which won't operate correctly).
The journey IS the reward.