Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

Ultrium 960-Backup suddenly took longer than usual

James JJJ
Occasional Visitor

Ultrium 960-Backup suddenly took longer than usual

Hi all,

I am experiencing a weird problem on my Ultrium 960, connected to its own HBA card on Win2k3.

The backup job on one fine day suddenly took 15-16 hrs to complete. Before this, my backup of 350GB took 9 hrs at a throughput of 800-900MB/min.

I have zoomed it down to the E drive in the same server the Ultrium is attached. When i did a backup test on E drive only, throughput was at only 20-30MB/min. I cant think for the life of me, why the backup slows down on this E drive. The server was rebooted with the Ultrium and still problem exists. Backing up remote servers is fine. The E drive contains the user profiles and home drives.

I have checked for any services that is causing the slowness but all are ok.A new tape was used as well and the HP LTT tools indicate my tape library is working fine, together with the media.

Are there any checks, test or solution? Anyone encountered this before? Please help.

Regards,
James "Distressed"
4 REPLIES
Luk Vandenbussche
Honored Contributor

Re: Ultrium 960-Backup suddenly took longer than usual

Hi James,

Are there some configuration changes on your E drive?

Are there perhaps more open files then before.

Try a test with some subfolders on the E drive to see if the problem is folder specific.
Rob Leadbeater
Honored Contributor

Re: Ultrium 960-Backup suddenly took longer than usual

Hi James,

I'll guess that one of your users has created *lots* of small files somewhere in their home directory.

This probably won't have increased the diskspace that much, but it usually takes a lot longer to backup many small files...

Hope this helps,

Regards,

Rob
James JJJ
Occasional Visitor

Re: Ultrium 960-Backup suddenly took longer than usual

Hi Luk & Rob,

Thanks for your inputs & suggestions.

I tested a backup on some sub folders in E drive and it took a long time as well. The sub folders i chose at random.Does it indicate i am having problems with them?

Rob, what do you mean by small files? I thought it wouldnt matter how much space it requires. Can you explain further why it slows down the backup? How do i identify these small files?
Rob Leadbeater
Honored Contributor

Re: Ultrium 960-Backup suddenly took longer than usual

Hi James,

It might do yes...

By small files I generally mean files that are less than the block size in use on the disk. Very few, if any, file systems perform well when dealing with lots of small files, particularly when in one directory.

You can see an example of this from Windows, if you try and browse into a folder that has say 10,000+ files in it. It can take a long time to enumerate those files.

A similar thing happens when backing up, as the backup software has to read the contents of the directory. It also has to maintain the index of what files are where, hence why it can significantly increase the size of the backup.

Hope this helps,

Regards,

Rob