Storage Boards Cleanup
To make it easier to find information about HPE Storage products and solutions, we are doing spring cleaning. This includes consolidation of some older boards, and a simpler structure that more accurately reflects how people use HPE Storage.
Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

Ultrium Surestore E Library drive not releasing medium

avsrini
Trusted Contributor

Ultrium Surestore E Library drive not releasing medium

Hai all
I have a problem in ultrium E tape library. We use
omniback to take backup to this library which is
connected thru fibre channe. There are 2 drives in the library and 40 slots. Yesterday while backup was triggered by omniback, the drive 1 has given the
following error

Can not load exchanger medium ([2] no such file or dir)

but the drive 2 was working fine and backup was completed on drive 2. could anybody tell me what may the problem.

the display on the library shows.
Drive 1
Be on top.
6 REPLIES
Michael Tully
Honored Contributor

Re: Ultrium Surestore E Library drive not releasing medium

Hi,

You will certainly find that this problem
comes from two areas. The bridge that
converts the FC to SCSI and vice-versa
and the library unit itself will need a
firmware upgrade. Also look at the firmware
on the drives as well.

Other things to look at:
Tape drive has not got the locking control
arm on. The drive on the display says
something other than empty or available.
If the display has anything like this, the
tape will not load.

HTH
-Michael
Anyone for a Mutiny ?
David Ruska
Honored Contributor

Re: Ultrium Surestore E Library drive not releasing medium


Srinivasan,

If you are still having problems, we would like to offer some advice.

It appears you might not have the device driver pointing to the proper device.

How to check your device driver paths:

1) Load only drive 1 (manually from the library front panel) with blank media. Verify that it is loaded.

2) Determine the device path information from Omniback for drive 1 (for example /dev/rmt/c6t0d1BESTnb).

3) Perform the following command (substituting your device path):

mt -f /dev/rmt/c6t0d1BESTnb status

4) If this is the correct drive, the response should be:

Drive: HP Ultrium 1-SCSI
Format:
Status: [xxxxxxxxxxx(data written to tape)] BOT online compression immediate report mode
File: [0]
Block: [0]

5) If the device driver is incorrect then under the Status it will be [0].

Had backups been working sucessfully until now?
If so, did anything change in the configuration? Did the system or a bridge get rebooted?
The journey IS the reward.
avsrini
Trusted Contributor

Re: Ultrium Surestore E Library drive not releasing medium

Dear David
Thanks for the suggestion.
I have tried this before and the output was same
as you quoted. I contacted with HP and
got the robotic arm changed, we suspected
this might be the problem. now we are observing the library.

i'll keep you all informed if this gets resolved.

thanx
srini
Be on top.
Curtis Ballard
Honored Contributor

Re: Ultrium Surestore E Library drive not releasing medium

Replacing the arm shouldn't do you any good. Your support person shouldn't have done that. This error means that the device file being addressed is not talking to a drive which means that either the drive is not responding, there is a configuration problem, or there is a connection problem. If you were previously able to address a drive at that location a connection problem is by far the most likely cause.

The front panel will give you some indication about the drives. You should see a box for both drive one and drive two all the time. There should be a smaller box inside there that is empty if the drive is empty and shows a tape if the drive is full. If the large box for drive 2 is present but there isn't any smaller box inside it then the drive is not functional.
Alexander M. Ermes
Honored Contributor

Re: Ultrium Surestore E Library drive not releasing medium

Hi there.
This is a general problem of these libraries not depending on the drive type.
We have a Surestore 4/40 with DLT drives.
We have this problem from time to time.
Explanation from HP :
the sliding rails for the picker must give contact to the electronics. In the extreme corners ( last and first tapes in the drawers ) these rails collect dust and debris, so that the contact cannot be kept properly.
Until now they have replaced the complete picker unit, from now on the techie only has to clean these rails.
This is just my 2ct.
Rgds
Alexander M. Ermes
.. and all these memories are going to vanish like tears in the rain! final words from Rutger Hauer in "Blade Runner"
Curtis Ballard
Honored Contributor

Re: Ultrium Surestore E Library drive not releasing medium

The problem of bad connections inthe corners mentioned in another posting can happen but is incredibly rare and can not cause the error mentioned in the initial question. Unfortunately because the problem of poor connections in the corners has occurred a couple of times it is now blamed for everything.

Please post again if another problem occurs.