Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

autoloader can't auto-switch the media

Mark Ma_4
Occasional Advisor

autoloader can't auto-switch the media

anybody could give me some suggestion ?

my english is not very good .sorry for any complicated words.

I am using DP5 realize ORACLE online backup with 200G ultrium tape in autoloader .The daily session is working fine.

while,the problem is ,everytime ,when a media in backup pool been write to the end(almost 330G in usage display) , the DP5.1
report error
message,and then quit the job.it wont auto-switch the media in the same pool,while the other media in the pool is fine.

[Critical] From: BMA@smcc03a "driver1" Time: 04/12/04 15:25:05
[90:154] Partial write of a block.
[Critical] From: OB2BAR@smcc03a "indra" Time: 04/12/04 15:25:05
Received ABORT request from SM => aborting.

RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03009: failure of backup command on dev_0 channel at 04/12/2004 15:25:14
ORA-19502: write error on file "Indra-DB-Daily-90days-Backup<523293629:1>.dbf", blockno 1195009 (blocksize=1024)
ORA-27030: skgfwrt: sbtwrite2 returned error
ORA-19511: Error received from media manager layer, error text:
Vendor specific error: OB2_WriteObjData() failed! ERR(-2)

RMAN> **end-of-file**


i have change medias so many times . and last week , HP engineer said autoloader's driver maybe have some problem .then
autoloader's driver has been changed . while the problem still appear.

In DP5.1 ,i am using /dev/rmt/1mn as the driver,and autochanger is /dev/rac/c8t0d0. all the driver and autochanger has been
pass the testing stage in OS Driver configuration manual.it seems that when a media write to the end ,DP5.1 haven't
acknowlege it and havn't autochange the media in the pool.

some testing stage about the driver like this :

# mc -p /dev/picker -r DS
DT_slot_1 FULL
ST_slot_1 FULL
ST_slot_2 EMPTY
ST_slot_3 EMPTY
ST_slot_4 FULL
ST_slot_5 FULL
ST_slot_6 FULL
ST_slot_7 FULL
ST_slot_8 FULL

# /opt/omni/lbin/uma -ioctl /dev/picker
*** PROGRAM: UMA VERSION: HP OpenView Storage Data Protector A.05.10

*** (c) Copyright Hewlett-Packard Company 2003
*** License is restricted for use with licensed
*** HP OpenView Storage Data Protector product/dev/picker> inq
SCSI Inquiry:
Type: 8
Vendor ID: "HP "
Product ID: "ThinStor AutoLdr"
F/W Revision: "H33r"
/dev/picker> stat
Element Status (T=Transport, X=Im/Export, D=Drive, S=Storage):
86 T1 Empty "" ""

82 D1 Full "" "" from S2

1 S1 Full "" ""
2 S2 Empty "" ""
3 S3 Empty "" ""
4 S4 Full "" ""
5 S5 Full "" ""
6 S6 Full "" ""
7 S7 Full "" ""
8 S8 Full "" ""

the SCSI adapter is c8xx---SCSI C1010 Ultra160 Wide LVD ,which direct connect to autoloader . i am using SCTL OS driver for
autoloader. i am not sure if c8xx must use tape2 driver? in the manual ,only talk about driver configuration which direct
connnect to c7xx interface card.

# ioscan -fH0/9/0/0
Class I H/W Path Driver S/W State H/W Type Description
=====================================================================
ext_bus 8 0/9/0/0 c8xx CLAIMED INTERFACE SCSI C1010 Ultra160 Wide LVD
target 8 0/9/0/0.0 tgt CLAIMED DEVICE
autoch 0 0/9/0/0.0.0 schgr CLAIMED DEVICE HP ThinStor AutoLdr
target 9 0/9/0/0.5 tgt CLAIMED DEVICE
tape 1 0/9/0/0.5.0 stape CLAIMED DEVICE HP Ultrium 1-SCSI
target 10 0/9/0/0.7 tgt CLAIMED DEVICE
ctl 6 0/9/0/0.7.0 sctl CLAIMED DEVICE Initiator
**
ext_bus 8 0/9/0/0 c8xx CLAIMED INTERFACE SCSI C1010 Ultra160 Wide LVD
target 8 0/9/0/0.0 tgt CLAIMED DEVICE
autoch 0 0/9/0/0.0.0 schgr CLAIMED DEVICE HP ThinStor AutoLdr
/dev/rac/c8t0d0
target 9 0/9/0/0.5 tgt CLAIMED DEVICE
tape 1 0/9/0/0.5.0 stape CLAIMED DEVICE HP Ultrium 1-SCSI
/dev/rmt/1m /dev/rmt/1mn /dev/rmt/c8t5d0BEST /dev/rmt/c8t5d0BESTn
/dev/rmt/1mb /dev/rmt/1mnb /dev/rmt/c8t5d0BESTb /dev/rmt/c8t5d0BESTnb
target 10 0/9/0/0.7 tgt CLAIMED DEVICE
ctl 6 0/9/0/0.7.0 sctl CLAIMED DEVICE Initiator

# ioscan -fnCautoch
Class I H/W Path Driver S/W State H/W Type Description
=====================================================================
autoch 0 0/9/0/0.0.0 schgr CLAIMED DEVICE HP ThinStor AutoLdr
/dev/rac/c8t0d0

# ioscan -fnCtape
Class I H/W Path Driver S/W State H/W Type Description
=====================================================================
tape 0 0/0/1/0.1.0 stape CLAIMED DEVICE HP C5683A
/dev/rmt/0m /dev/rmt/c0t1d0BEST /dev/rmt/c0t1d0DDS
/dev/rmt/0mb /dev/rmt/c0t1d0BESTb /dev/rmt/c0t1d0DDSb
/dev/rmt/0mn /dev/rmt/c0t1d0BESTn /dev/rmt/c0t1d0DDSn
/dev/rmt/0mnb /dev/rmt/c0t1d0BESTnb /dev/rmt/c0t1d0DDSnb
tape 1 0/9/0/0.5.0 stape CLAIMED DEVICE HP Ultrium 1-SCSI
/dev/rmt/1m /dev/rmt/1mnb /dev/rmt/c8t5d0BESTn
/dev/rmt/1mb /dev/rmt/c8t5d0BEST /dev/rmt/c8t5d0BESTnb
/dev/rmt/1mn /dev/rmt/c8t5d0BESTb



attached other debug log from DP5.1's eventlog and Oracle sbtio.log.

anybody could give me some suggestion ? milion thanks .


Mark


1 REPLY
Mark Ma_4
Occasional Advisor

Re: autoloader can't auto-switch the media

i am back again.

there r new autoloader firmware issue :

"The drive now responds correctly when End of Tape (EOT) is reached to prevent any issues if write commands continue to be sent from the host. "

i am not sure if its the reason to my problem.

my autoloader version info list below.

Product ID : Ultrium 1-SCSI
Drive Technology : LTO
Mech. Serial Number : HU73H00575
Firmware Rev : E30P/OEM18

Product ID : ThinStor AutoLdr
Model Name : Tape Autoloader 1/8
* Internal Serial Number : MXH3J02375
Drive Technology : LTO
Firmware Rev : H33r

which the newest version is E33P and H43r.

any other suggestion ?

thanks

Mark