Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

library reporting that it has been reserved by a different host/initiator

Fiona Melody
Occasional Advisor

library reporting that it has been reserved by a different host/initiator

Hi

Would really appreciate any help; currently have an MSL6060, 4 drive 60 slots attached via SAN to 2 HP 11.31 hosts. Both hosts have been able to see all 4 drives until last Thursday. Since then hardware still shown as claimed via ioscan, but if I try the lt&t diagnostics it shows only drive 2, for drives 1,3 & 4 it says
"The library reports that it has been reserved by a different host/initiator. Please unreserve the library before attempting any further diagnosis."

Can use mc to move media between the drives & slots but our backup software (NetBackup) still sees these 3 drives as ‘pending’ and I cannot reset them. Have tried rebooting the tape library, backup server etc, unfortunately not able to reboot the unix hosts as production – still no change.

Does anybody know how to identify what has reserved the drives?

Thanks for any help!

Regards

Fiona
4 REPLIES
Srikanth.D
Occasional Advisor

Re: library reporting that it has been reserved by a different host/initiator

Have any configurational changes been made after Thursday, either in Host OS or in Backup Application ?
Fiona Melody
Occasional Advisor

Re: library reporting that it has been reserved by a different host/initiator

no changes made that anybody's admitting to - I believe them as well!
Brian_Murdoch
Honored Contributor

Re: library reporting that it has been reserved by a different host/initiator

Hi Fiona,

Things like this used to happen when a new host was added to the SAN and it had the Removable Storage Service enabled (Windows based systems). This could "see" the MSL library over the SAN and kept polling it.

Make sure that you don't have the service enabled on systems that don't need it.

This may not be your problem but it can easily be eliminated.

Regards,

Brian
Fiona Melody
Occasional Advisor

Re: library reporting that it has been reserved by a different host/initiator

hi

Thanks to everyone who looked at this - the issue now appears to be resolved, previously I had rebooted the tapeloader by remote management console - discovered this does not reboot the NSR cards, I've now rebooted both cards and it appears to have remapped the zones - in future I'll make sure to either power cycle the autoloader or reboot both the cards and the autoloader separately.