Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

multiple servers not seeing library and drives

pensfan
Occasional Advisor

multiple servers not seeing library and drives

We have an MSL 8096 with 3 drives and with 3 servers connected directly to those drives. Only the server that is connected to the master drive in the library can see the library and drive, the other servers only see a tape drive. Backup exec sees the library and also only 1 drive. What could we be missing.

3 REPLIES
Marino Meloni_1
Honored Contributor

Re: multiple servers not seeing library and drives

this is correct, The library is seen through a LUN on the first drive. So if a host cannot see the drive one,(or the drive configured to do the passthough of the scsi signal for the library) this host will not see the library, but only a tape.

Up to you to configure your backup application in order to manage all the drives . Usualy it is enough that one host can manage the robotic controller, so after reconfiguring your Backup application, it should work

pensfan
Occasional Advisor

Re: multiple servers not seeing library and drives

we are using backup exec, it sees the library and the host drive, but gives me unknown device for the other 2 drives, i am only able to use 1 drive to backup all the servers. I am assuming that we have something cabled wrong. Is there a diagram somewhere that shows the proper cabling
Marino Meloni_1
Honored Contributor

Re: multiple servers not seeing library and drives

I understand that you have a msl8096 with 3 drives,
the first drive is SCSI connected to the first host and can see the drive and the library
the second drive is SCSI connected to the second host and see only the second tape drive
the third drive is SCSI connected to the third host and see only the third tape drive

this is what you said in the first post. This is correct

Now you tell me that backup exec can see only the devices connected on the first host, and is not able to manage the drives connected to the other hosts?
If this is your problem, then I think you should check with BackupExec how it can mange non local drives, there are backup application that use media agents, so you can use remote drives, or library to backup your data, I do not know how Backuexec manage these remote drives.

From a HW point of view, the connection to the host > Library is the same for each hosts: HBA > Cable > Drive > Terminator this should be repeated for the three hosts.
You can also run LTT on each host to check the installation and connectivity