取消
顯示結果 
搜尋替代 
您的意思是: 

安装ssh软件

安装ssh软件

大家好:

我想在我的机器上安装ssh软件,其过程碰到了一些问题,至今未解决,请大家帮助我!

环境:tru64 4.0f

ssh版本:openssh-3.8p1.tar

本打算从这里下载的,但下不了,如果谁有能不能共享一份上来?mmain@163.com谢谢你们!http://h30097.www3.hp.com/unix/ssh/register.html



附件是我安装的日志,请大家查看并且帮助我!
4 回覆

安装ssh软件

你的系統有先安裝zlib 1.14和openssl 0.96以上的版本嗎 ? openssl建議是上到0.98以後.



另外在config的時候, 可參考以下command, 視你的實際需要再進行調整.



./configure --with-zlib=ZLIBPATH --with-ssl-dir=PATH



要看configure的option列表, 用./configure --help



如果只是單純要用ssh-client,

http://www-uxsup.csx.cam.ac.uk/pub/misc/CD/current/OSF1/



這裡有pre-compile好的binary檔

安装ssh软件

可否提供一个安装log呢?

我安装了还是没有成功!谢谢你们!

安装ssh软件

整個安裝過程步驟有點多, 以下就打英文了, 各package詳細說明請自行參考man page or INSTALL/README



zlib v1.1.4 or higher ( get it from http://www.zlib.net )

openssl 0.96 or higher ( get it from http://www.openssl.org )

prngd ( Due to tru64 didn't provide /dev/urandom either /dev/random, yuo need prngd

to insteal edg to generate random numbers for secure key, you can get it from

http://ftp.aet.TU-Cottbus.DE/personen/jaenicke/postfix_tls/prngd.html)

openssh-3.8p1 or higher ( get it from http://www.openssh.org )



In this case, I use following version software, test ok with my 4.0D OS.



zlib-1.2.3

prngd-0.9.29

openssl-0.9.6m

openssh-3.8p1





.: START :.

1. extract all the tarballs

2. start install process

## install zlib

cd /tmp/zlib-1.2.3;./configure --prefix=/usr/local/zlib;make;make test;make install



## install prngd

cd /usr/local/prngd-0.9.29;make;cp contrib/prngd.conf.osf1 /etc/prngd.conf;

* Must bring up prngd before install openssl, otherwise install openssl will failed

-- Bring up prngd

echo 12345678 > /etc/prngd-seed

cd /usr/local/prngd-0.9.29/;./prngd /var/run/egd-pool

`ps -ef|grep prngd` to verify.



* To stop prndg, use `./prngd --kill /var/run/egd-pool`



## install openssl

cd /tmp/openssl-0.9.6m;./config --prefix=/usr/local --openssldir=/usr/local/openssl;make;make test;make install



## install openssh

cd /tmp/cd openssh-3.8p1;./configure --prefix=/usr/local/openssh --with-zlib=/usr/local/zlib --with-ssl-dir=/usr/local --with-md5-passwords --without-

shadow --without-osfsia;make;make install



* Note: In configure phase must add --without-osfsia, otherwise in make phase will fail



3. Bring up the sshd daemon

# groupadd sshd;useradd -g sshd sshd

cd /usr/local/openssh/sbin;./sshd

ps -ef|grep sshd to verify



-- install process end --



you can start your ssh client to connect the host.



安装ssh软件

從你的LOG看, 要素之一的zlib package沒有安裝, 或找不到, 沒有辦法繼續config.