取消
顯示結果 
搜尋替代 
您的意思是: 

Tru64 semaphore

Tru64 semaphore

1. 請教各位高手,下 ipcs -a在最後一段會看到semaphore的資訊,如果msg_tql是預設值40,在這裏是不是最多就只會看到40筆記錄,超過就會出現 semaphore busy的訊息?



2. 如果在這台主機有安裝Oracle 9i Database,平常約有80~100個connection連上來,msg_tql要設多少才夠?



謝謝
7 回覆

Tru64 semaphore

ncreasing the value of the msg_tql attribute may improve the performance of applications that benefit from increasing the number of outstanding messages to a value that is larger than the default value. However, increasing the value of this attribute will consume memory.

You may want to increase the value of the msg_tql attribute if your applications can benefit from increasing the maximum number of outstanding messages to a value than is larger than 40.

Tru64 semaphore

全名叫做

Maximum Number of Messages on a System V Queue

這個值應該跟oracle connection 無關

Tru64 semaphore

可以試試sqlplus 連進去oracle

在執行ipcs -a

發現並沒有新增加的Semaphores 數量

Tru64 semaphore

The process will be unable to send a message if doing so would make the total number of message headers currently in the system greater than the limit specified by msg-tql. If the limit is reached, the process sleeps, waiting for a message header to be freed.



IPC attributes in the sysconfigtab file related to semaphore are following:



sem-mni (number of semaphore identifiers)

sem-msl (number of semaphores per ID)

sem-opm (maximum number of operations per semop call)

sem-ume (maximum number of undo entries per process)

sem-vmx (semaphore maximum value)

sem-aem (adjust on exit maximum value)



for your reference.



if you would like to know current amount of msg_tql, try following,



echo "p cur_msghdrs" | kdbx -k /vmunix | tail -1

Tru64 semaphore



Thanks for your help,



But i try that command,it's output is following

:



#echo "p cur_msghdrs" | kdbx -k /vmunix | tail -1

0

#echo "p cur_msghdrs" | kdbx -k /vmunix

dbx version 5.1

Type 'help' for help.



stopped at Source not available

warning: Files compiled -g3: parameter values probably wrong

0



Is it correct?



thanks you.

Tru64 semaphore

應該是正常的,我的機器output 也是一樣

Tru64 semaphore

Hi all,



The variable "msg_tql" is belong to the "Message Queues" not

to "Semaphores" as the case title requested.



From the value of "cur_msghdrs" is equal to 0 that

indicated no Message_Q used on this system. If it's not enough and

needs to increase the value of msg_tql (default is 40)it

should be gotten the maximun "40" from the command:

# echo "p cur_msghdrs" | kdbx -k /vmunix



Best regards,

Richard.