TruCluster
Showing results for 
Search instead for 
Do you mean 

ASE/4.0G: cluster communication problem

Frequent Advisor

ASE/4.0G: cluster communication problem

Dear Friends,

yesterday, i try to invoked asemgr, but it hangs, all my services on ASE hang even the service which located on the other member i cann't access the mounted point of it. when i check my logs i found these lines in the day before yesterday daemond log file, as folloing:

Apr 9 01:01:12 kuora3 os_mibs[879]: os_mibs WARNING esnmp_lib.c line 1366: o_oid; Null oid or oid->elements, or, oid->nelem == 0

then


Apr 9 01:01:12 kuora3 last message repeated 5 times

Apr 9 17:38:22 kuora3 ASE: local AseMgr Error: can't find director in portmap,
retrying...

then
Apr 9 18:42:47 kuora3 ASE: local AseMgr Error: can't connect to the director, giving up.
Apr 9 18:42:47 kuora3 cnxmibd[354]: cnxmibd **ERROR cnxmib_mthd.c line 942: beginEvent() can't connect
Apr 9 18:43:33 kuora3 cnxmibd[354]: local AseMgr Error: can't find director in
portmap, retrying...
Apr 9 18:43:53 kuora3 cnxmibd[354]: local AseMgr Error: can't find director in
portmap, retrying...

then, ASE shutdown my database properly!

please, what is causing this problem?
and, how can i save myself from this problem later?
because when i rebooted the system, everything return as it is good!!

Best Regards,
Amr


Try To Be Smart
4 REPLIES
Honored Contributor

Re: ASE/4.0G: cluster communication problem


For urgent support situtations I kindly suggests you urgently consider using your official support channels.
This is an informal, best effort, peer-help, forum and can not be relied upon for production support.
We will all try to help best we can, but we may be wrong or late or both. Is that good enough for your customer?

Regards,
Hein.
Valued Contributor

Re: ASE/4.0G: cluster communication problem

I'm trying to remember in ASE... it seems that if there is a network partition, that the director dies. The agents should talk to each other and decide where to start a new director. The fact that a director didn't get started makes me think there was a network problem of some sort. My ASE brain is very dusty so don't hold me to this. ;)

Greg
Honored Contributor

Re: ASE/4.0G: cluster communication problem

Greg,
that's correct. It seems a typical setup issue - please open a call within the HP support center (its urgent, isn't it?) or hopefully you find a guy analysing both cluster members checking the whole configuration.
Help() { FirstReadManual(urgently); Go_to_it;; }
Frequent Advisor

Re: ASE/4.0G: cluster communication problem

dear friends,

thank you very much for tring help me, looks like the solution is upgrade patch kit to the latest patch kit 4, it will solve the problem as it mentioned in the patch kit 4 release note, patch ID TCR106-047A.

Amr
Try To Be Smart
//Add this to "OnDomLoad" event