TruCluster
cancel
Showing results for 
Search instead for 
Did you mean: 

TruCluster 5.1 restore from backup

Jatin_3
Occasional Visitor

TruCluster 5.1 restore from backup

Hi,

We are running a 2 node TruCluster 5.1 configuration on DS10. We recently upgraded it to Tru64 5.1B. We were trying out our revert back process to 5.1.

We had the backup of our 5.1 system. This included vdump of cluster_root, cluster_usr, cluster_var, boot partitions of both nodes and the standalone root,usr & var.

This is the process we followed to revert back to 5.1
1) Boot from 5.1 CDROM
2) create the relevant advfs filesets for all the above filesystems and mount them
3) Restore them from the tape.
4) We then boot from the member 1 boot disk. We expect it to boot as cluster member1. Instead the booting fails at the following point.

CNX QDISK: Successfully claimed quorum disk, adding 1 vote.
CNX MGR: quorum (re)gained, (re)starting cluster operations.
Joining versw kch set.
Waiting for cluster mount to complete
WARNING: cfs_perform_glroot_mount: cfs_mountroot_local failed to mount the cluster root fs with error = 22

Can anyone advise whether we are doing a correct process or are we missing something?
5 REPLIES
Michael Schulte zur Sur
Honored Contributor

Re: TruCluster 5.1 restore from backup

Hi,

have you deleted the old stuff before restoring? error 22 say invalid argument, but I couldnt find anything other to that problem.

greetings,

Michael


Jatin_3
Occasional Visitor

Re: TruCluster 5.1 restore from backup

Hi Michael,

Thanx a lot for an instant reply.
All we have done before restoring is,

1) Boot from the CD.
2) Create the domains for i.e. cluster_root(dsk1b), cluster_usr(dsk1g), cluster_var(dsk1h), both the boot partitions i.e. dsk4a and dsk5a, using mkfdmn command.
3) then restore all the domains using vrestore command.

With mkfdmn command all the existing data on those domain is deleted.
Only thing is that We have not recreated the disklabel for the the system disk (i.e. dsk1 in our case).

Sorry, but I didn't get , what do you mean when you say by deleting old stuff?

Please clarify.
Waiting for your reply.

Thanx again Michael,
Ketan.
Michael Schulte zur Sur
Honored Contributor

Re: TruCluster 5.1 restore from backup

Hi,

I overlooked it in your first mail, that you recrated the filesets, which means you deleted the old 5.1B stuff. Do you have an installation disk, you can boot from and try to mount the cluster filesets maunally?

greetings,

Michael
Jatin_3
Occasional Visitor

Re: TruCluster 5.1 restore from backup

Michael,

It seems this error might be due to faulty 5.1 backups.

We deleted all the old stuff and tried out the above process with fresh 5.1B backups and the cluster booted fine as a 5.1B node.

We are going to recreate the system as 5.1 by doing a full installation and then take fresh 5.1 system backup and try out the above process.

We will update you as soon as we have some results.

Thanks once again for your assistance.

Regards,
Jatin
Michael Schulte zur Sur
Honored Contributor

Re: TruCluster 5.1 restore from backup

Hi,

sorry to hear that and that I wasnt able to give more advice. Have you tested the backup with vrestore -tv or why do you think, it was bad?

greetings,

Michael