Showing results for 
Search instead for 
Do you mean 

TruCluster problem

Regular Advisor

TruCluster problem

Node1 and Node2 are two-nodes cluster(Tru64 5.1B). They are communcating with memory channel. Oracle RAC is running on this cluster. Because we encountered some RAC issue, we are checking the ICS definition in /etc/rc.config:

ON Node1:
IFCONFIG_0="10.xx.xx.04 netmask filter"
export IFCONFIG_0
IFCONFIG_1="192.xx.0.1 netmask filter"
export IFCONFIG_1

ON Node2:
IFCONFIG_0="10.xx.xx.05 netmask"
export IFCONFIG_0

It lost the IP "192.xx.0.2" defined into /etc/rc.config on Node2. However, this config works more than 4 months. How did Node2 communicate with Node1 without ics0? Why does it work?



Esteemed Contributor

Re: TruCluster problem

The cluster alias is quite smart and may be routing traffic over the interface that does work.

ICS mainly uses low level protocols on MC that don't require IP to be defined. IP over the cluster interconnect is required for some of the maintenance stuff.

I guess clu_check_config is complaining about this configuration?

Alternatively you could have set up IP over MC using another method. Is IP really missing from MC0 (when you do a "ifconfig ics0")?
Regular Advisor

Re: TruCluster problem

There is no configuation via "ifconfig ics0" on Node2 now.
Esteemed Contributor

Re: TruCluster problem

You better get this corrected.

How is RAC configured? Are you using RDG or UDP?

You might be running RAC over the public interface, which not be optimal considering that you have memory channel.

"netstat -rn" may help you to see how traffic is routed.
Honored Contributor

Re: TruCluster problem

private network addresses for normal network adapters require special configuration (see man pages for cluamgr).

Next, the first network adapter within rc.config must be your ics0 connection or some cluster scripts will not work properly.

The filter options are wrong.

Please read the manuals, write down the configuration and then install and configure the software!

Help() { FirstReadManual(urgently); Go_to_it;; }
//Add this to "OnDomLoad" event