Showing results for 
Search instead for 
Do you mean 

trucluster loadsharing problem

SOLVED
Go to Solution
Trusted Contributor

trucluster loadsharing problem

hello
actually i am facing problem with trucluster 5.1B-4 with oracle 9i.
i configured cluster in shared mode "using cluster-wide filesystem and member's boot disks" using memory channel.
the problem in load sharing. when oracle client need connects to the alias IP the cluster redirect this session to node1 then when redirect to node2 the client failed with error cannot find host.
when adding node2 ip and name in microsoft windows hosts file,load-share working fine.

UNIX hosts file:
127.0.0.1 localhost
10.0.0.12 node2.xxx.gov.uk node2 node2.
10.0.0.10 cluster.xxx.gov.uk cluster
192.168.0.2 node2-ics0
192.168.0.1 node1-ics0
10.0.0.11 node1.xxx.gov.uk node1 node1.

i tryed to configure unix as DNS server. domain is xxx.gov.uk and nameserver is 10.0.0.10, then adding to named.conf both nodes ip and name. so bind worked fine.
but still the oracle problem happened. but when adding 10.0.0.10 in microsoft windows DNS, it worked.
my problem is i have more than 500 clients. it will be diffecult to configure them all as a DNS clients.
and also customer is not satisfied with this solution.

can somebody help?
thanks
4 REPLIES
Honored Contributor

Re: trucluster loadsharing problem

Hi,

Can you explain more clearly what you mean when you say "...when oracle client need connects to the alias IP the cluster redirect this session to node1 then when redirect to node2 the client failed with error cannot find host..."

Exactly how are you connecting ? What is the client ?

> also customer is not satisfied with this solution

I also suspect the customer wouldn't be too happy that you put .gov.uk in a public forum...

Cheers,

Rob
Frequent Advisor

Re: trucluster loadsharing problem

Hi Rob

i am working with kemo, and i discussed with you this upgrade project before...

at the following link:

http://forums13.itrc.hp.com/service/forums/questionanswer.do?threadId=1318448

we successfully made the new cluster on tru64 5.1B-4, and install oracle 9.2.0.1 on the cluster , and import our data successfully..

when we connect telnet to the cluster ip , it divide the sessions between the 2 servers equally..

but now the problem in the connection of oracle , the customer uses a small program written in C to connect to the database using oracle client 9.2.0.1 in the tnsnames.ora file the customer have the cluster ip address...and the database SID ...

these was working with the old cluster...

but now after the new cluster, when we try to connect from the client PC , it goes to node1 only without errors and when the connections came to node2 it gives error...

we suggest to the customer to add the 2 nodes ip addresses in the tnsnames.ora and use load balance option..but the customer refused (have alot of clients)...


Honored Contributor

Re: trucluster loadsharing problem

Hi,

Is the Oracle listener running on both nodes ?

This note may help:

http://www.oracle-base.com/articles/9i/Oracle9iRACInstallationOnTru64.php

Cheers,

Rob
Honored Contributor

Re: trucluster loadsharing problem

Hello Kemo...
what about when u moving the packagae to other node are you facing the same problem when cluster is running in node2.
And are you facing the problem only when connecting with windows server what if u connecting trough other UNIX server.

How many DBs you running is it only1 or more than one.

BR,
Kapil+

I am in this small bowl, I wane see the real world......
//Add this to "OnDomLoad" event