UCMDB and UD Practitioners Forum (Previously CMS)
Showing results for 
Search instead for 
Do you mean 

HP uCMDB 9.05 Pattern Based Model Loading Issue

SOLVED
Go to Solution
Valued Contributor

HP uCMDB 9.05 Pattern Based Model Loading Issue

[ Edited ]

Hi

 

Could anyone advice how to rectify our issue in one particluar Pattern based Model which is created to Capture an Entire Line Of Service of our client as Business Service ,We have huge number of  IT Services beneath it and then we have Busisness Application below it and next comes the Huge number infra elements ,no matter what this particular model when we select from Modelling Studio to peform updates or changes it wouldnt Open ,Questions are Below

 

1. How exactly the Pattern Based Model works .

 

2. How any Patter Based Populates its underneath elements when loaded in Modelling Studio

 

3.Is there any Infrastructure settings tweaking should be performed from our side

 

Thanks In advance

2 REPLIES
HPE Expert

Re: HP uCMDB 9.05 Pattern Based Model Loading Issue

Hi,

Here is some basics. Pattern Base Models (PBM) creates specific type of enrichment that will connect result set of TQL used for creation of PBM to Model CI. By the default the enrichment scheduled to run twice a day.

You can see full list of such enrichment in JMX console -> Business View Enrichment Services -> retrieveAllEnrichmentNames. You could count result set of specific enrichment retrieveEnrichmentResultCount method.

 

UCMDB has limitation on amount of CIs that could be shown in UI at the same time. AFAIK, the limit is 900 CIs. You could think about this limit as paging of results returned by Google when you search for something. 

 

As general recommendation, I'd suggest to not create models that will include millions of CIs. 

Regards
-Dmitry Gomel, PMP
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Click the Like button at the bottom to say 'Thanks'.
Valued Contributor

Re: HP uCMDB 9.05 Pattern Based Model Loading Issue

Thanks Dima :)
//Add this to "OnDomLoad" event