UCMDB and UD Practitioners Forum (Previously CMS)
Showing results for 
Search instead for 
Do you mean 

Job Template is not working

SOLVED
Go to Solution
Trusted Contributor

Job Template is not working

HI,

 

I am working on UD 10.01

 

I have created zones of 5 to 6 IP ranges(total IPs 1000+) . Also applide  the tamplate containing  Host resources by shell , Host Resources by WIM  & IP ranges by ICMP job.

 

If I applied the template to the zone , It  discovers a single IP of DATA Flow Probe.   So created CI is 1 only.

 

 

So again I applied default job "Infrastructure" and acrtivated the same but this time it worked and discoved almost 800 ips with basic parameters.

 

I wonder , why this tamplate is not working with this zone but I tried the same tamplate for other single IP range of 30IPs. It worked and showed all Infrastructure  details/software/processes etc..

 

It is really strange and unable to figure out what is the issue.

 

Please help me as I am new to UD.

 

Thanks.

 

 

with regards,

Nick

 

 

 

 

 

 

6 REPLIES
HPE Expert

Re: Job Template is not working

Templates is not what you need to run basic discovery. Infrastructure activity should cover your basic discovery needs.

Please be aware that UCMDB has following logicical flow in discovery:

IP -> Host Connection -> Host Resources -> all others discovery jobs.

Hope this helps.

Regards
-Dmitry Gomel, PMP
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Click the Like button at the bottom to say 'Thanks'.
Trusted Contributor

Re: Job Template is not working

Hi,

 

Thanks for the response.

 

 

I want to discover basic resources like ip,os, os user,interface, CPU, memory, Installed software, Running Software, etc.

 

This is possible through Host resource by Shell and Host resources by WMI job .

 

To apply these jobs on zones I had created template to activate the job on one zone  at a time. But same is not working.

 

 

The default infrastructure  job uses "Network connection by shell' adapter to discover the parameters anerd it doesnot even show CPU parameter and other softerware details(installed /running, processes)

 

 

Please suggest best possible way to discover all host resources and software parameters but want to activate one zone at a time.  Please tell me in which cases  the template can be used??

 

 

with regards,

Nick

 

 

 

HPE Expert

Re: Job Template is not working

What is a protocol you're planing to use for the discovery?

Regards
-Dmitry Gomel, PMP
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Click the Like button at the bottom to say 'Thanks'.
Trusted Contributor

Re: Job Template is not working

HI,

 

Discovery is configured thrugh WMI and SSH only.

 

 

Thanks,

 

 

with regards,

Nick

HPE Expert

Re: Job Template is not working

Dear Nick,

Please check attached screenshots. It contains jobs that should provide you with the data you're expecting to be discovered.

Teh general Flow is to create the template and then use the template for creation of new activity. During creation of activity you'll be able to set job parameters like "Discover CPUs".

Hope this helps.

Regards
-Dmitry Gomel, PMP
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Click the Like button at the bottom to say 'Thanks'.
Trusted Contributor

Re: Job Template is not working

Hi Dima,

 

Thanks for the solution.  It really helped me to troubleshoot exact problem.

 

The issue is reoslved now. As I was missing one connection job from template so it was not working as expected.

 

 

with regards,

Nick

//Add this to "OnDomLoad" event