UCMDB and UD Practitioners Forum (Previously CMS)
Showing results for 
Search instead for 
Do you mean 

Perform jmx commands from the commandline

SOLVED
Go to Solution
Frequent Advisor

Perform jmx commands from the commandline

Hi,

I am trying to perform jmx command, deleting a ci from the ucmdb.
I've found an examples here:
http://stackoverflow.com/questions/1751130/calling-jmx-mbean-method-from-a-shell-script

But when run this action:
java -jar cmdline-jmxclient-0.10.3.jar sysadmin:mypwd myucmdbhost.lab.loc:3830 "UCMDB:Service=Model Services" removeCMDBObject=1,ac94b8debc6c0eb4eefc3b7e39e4e0de

I get this error:
Exception in thread "main" java.io.IOException: Failed to retrieve RMIServer stub: javax.naming.CommunicationException [Root exception is java.rmi.ConnectIOException: non-JRMP server at remote endpoint]

In other examples i found that the port 29601 was used but there is no listener on the ucmdb server on that port, we have changed the ucmdb port
from 8080 to 3830 thats why i use that. There is no firewall between or running on any of the server, connection is no issue on that port.

I hope someone has this working and can help me?
I use ucmdb 10.11.

Gr,
Ronald

2 REPLIES
Trusted Contributor

Re: Perform jmx commands from the commandline

Did you start the UCMDB server with JMX-RMI support?

Check your settings in the wrapper.conf file located in the bin directory on your UCMDB server:

#Uncomment the following lines to enable monitoring and management using JMX technology.
wrapper.java.additional.14=-Dcom.sun.management.jmxremote
#wrapper.java.additional.15=-Dcom.sun.management.jmxremote.port=29601
#wrapper.java.additional.16=-Dcom.sun.management.jmxremote.authenticate=false
#wrapper.java.additional.17=-Dcom.sun.management.jmxremote.ssl=false

You should uncomment the lines containing .14, .15 and possibly .16 (am not sure).

If you do that, restart your server and then you can try the command line client again.

 

Frequent Advisor

Re: Perform jmx commands from the commandline

Hi Rutger,

 

You're great! Now that port is running and its working like a charm..this offers great features for me..

 

Thanks!

 

Ronald

//Add this to "OnDomLoad" event