UCMDB and UD Practitioners Forum (Previously CMS)
Showing results for 
Search instead for 
Do you mean 

Question on API call getFilteredCIsByType

SOLVED
Go to Solution
Frequent Advisor

Question on API call getFilteredCIsByType

[ Edited ]

Hello peoples...

 

I am trying to send the following through the http://BSMServer.address.com/axis2/services/UcmdbService web service and getting "Internal error occurred" 

 

Here is the request that i am sending:

 

<soapenv:Envelope 
      xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
      xmlns:quer="http://schemas.hp.com/ucmdb/1/params/query" 
      xmlns:typ="http://schemas.hp.com/ucmdb/1/types" 
      xmlns:prop="http://schemas.hp.com/ucmdb/1/types/props">
    <soapenv:Header/>
    <soapenv:Body>
        <quer:getFilteredCIsByType>
            <quer:cmdbContext>
                <typ:callerApplication>API_Script</typ:callerApplication>
            </quer:cmdbContext>
            <quer:type>IpAddress</quer:type>
            <quer:conditions>
                <typ:strConditions>
                    <typ:strCondition>
                        <typ:condition>
                            <typ:name>name</typ:name>
                            <typ:value>123.45.67.89</typ:value>
                        </typ:condition>
                        <typ:strOperator>Equal</typ:strOperator>
                    </typ:strCondition>
                </typ:strConditions>
            </quer:conditions>
            <quer:conditionsLogicalOperator>AND</quer:conditionsLogicalOperator>
        </quer:getFilteredCIsByType>
    </soapenv:Body>
</soapenv:Envelope>

 I am trying to return an Ip Address CI with name:  123.45.67.89

 

 

 

P.S. This thread has been moved from Application Perf Mgmt (BAC / BSM) Support and News Forum to CMS and Discovery Support and News Forum. - Hp Forum Moderator

 

4 REPLIES
Frequent Advisor

Re: Question on BSM Open API getFilteredCIsByType

OR....  

 

if no one can help on this, can you at least point where to troubleshoot the OpenAPI calls?    

 

I ran a full search on all my log files, in DP and GW and none have API_SCRIPT anywhere in the files (which i am sending as the context).    

 

Do i need to put something on Debug?    

 

What?

 

 

thanks!

 

./d

HPE Expert

Re: Question on BSM Open API getFilteredCIsByType

Hi,

 

You might have better luck getting an answer for this by posting it to the UCMDB forum:

 

http://h30499.www3.hp.com/t5/uCMDB-Support-Customer-Forum/bd-p/ucmdb-support-customer-forum#.UqIk_LHn-Hs

 

 

Eric Shaffer

"HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution."
Frequent Advisor

Re: Question on BSM Open API getFilteredCIsByType

the CMDB web service is a valid part of RTSM (which is still part of BSM...no?)

Frequent Advisor

Re: Question on BSM Open API getFilteredCIsByType

Well, i was able to get past the issue i was having.    

 

Using SOAP-UI to connect to the web service, i have now figured out that you need to use jmx credentials for these commands (i got the impression from the docs that it was applicaiton (BSM/ucmdb) credentials with the API permission enabled in users and permissions.   This is not clear in the documentation.).   

 

Also, SOAP-UI has three types of authentication (in the AUT tab), use default JMX credentials of admin/admin, leave the domain field blank, and select NTLM/kerberos as the authentication method.  

 

This worked for me.   Hope it does for you too..  

//Add this to "OnDomLoad" event