UCMDB and UD Practitioners Forum (Previously CMS)
Showing results for 
Search instead for 
Do you mean 

UCMDB 8.05 CP7 - compatible JRE versions

SOLVED
Go to Solution
Occasional Advisor

UCMDB 8.05 CP7 - compatible JRE versions

[ Edited ]

We're getting the following error when clicking on View Manager in UCMDB 8.05 CP7:

Java Plug-in 1.6.0_20
Using JRE version 1.6.0_20-b02 Java HotSpot(TM) Client VM
User home directory = C:\Documents and Settings\e99999
----------------------------------------------------
c: clear console window
f: finalize objects on finalization queue
g: garbage collect
h: display this help message
l: dump classloader list
m: print memory usage
o: trigger logging
q: hide console
r: reload policy configuration
s: dump system and deployment properties
t: dump thread list
v: dump thread stack
x: clear classloader cache
0-5: set trace level to
----------------------------------------------------


load: class com/hp/ucmdb/ui/richcontainer/applet/UCMDBApplet.class not found.
java.lang.ClassNotFoundException: com.hp.ucmdb.ui.richcontainer.applet.UCMDBApplet.class
at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Exception: java.lang.ClassNotFoundException: com.hp.ucmdb.ui.richcontainer.applet.UCMDBApplet.class

 

 

P.S. This thread has been moved from Application Perf Mgmt (BAC / BSM) Support and News Forum to CMS and Discovery Support and News Forum. - Hp Forum Moderator

5 REPLIES
Valued Contributor

Re: UCMDB 8.05 CP7 - compatible JRE versions

Hi
did you have any errors after installing CP7?

after importing the package we came up with about 30 errors, all of which relate to:

[663] Action is not allowed, cannot update anything in class created by user but updated by factory

DDM isnt working for us, and i believe this is the issue - could also be yours?

We can open view manager no probs - ucmdb 8.05, CP7.

We are using JRE 1.6.0_11 which we have found to have the least issues with.

Thanks,
Rob.
Honored Contributor

Re: UCMDB 8.05 CP7 - compatible JRE versions

Hi Parasuram - which IE version do you use?
Can you try to delete the Java cache and re-load the applet (as the JRE version seems to be OK).

Rob - the messages you've referred to are unrelated to the UI behavior, they are rather related to the Class Model update, but my question would be - what do you mean under "DDM isn't working for us"? Any specific issues you encounter?

Regards,
Alex
Occasional Advisor

Re: UCMDB 8.05 CP7 - compatible JRE versions

Hi Rob,
Thank you for your response. We are running DDM OK. One mistake we'd made was skipping over 8.04 which was a major release.

Hi Alex,
Our IE version is 7.0.5730.13C0. We did clear the Java cache and retry... It didn't fix the issue. I am realizing that tools are very picky about the JRE version :(
Thank you!
Parasuram
Occasional Advisor

Re: UCMDB 8.05 CP7 - compatible JRE versions

Hi Alex,
We installed JRE 1.6.13 on a new box and it worked.
Thank you.
Parasuram
Occasional Advisor

Re: UCMDB 8.05 CP7 - compatible JRE versions

We installed JRE 1.6.13 on a new box and it worked.
//Add this to "OnDomLoad" event