UCMDB and UD Practitioners Forum (Previously CMS)
Showing results for 
Search instead for 
Do you mean 

UCMDB–SC Integration: TQL only returns CI ID

SOLVED
Go to Solution
Occasional Advisor

UCMDB–SC Integration: TQL only returns CI ID

[ Edited ]

Dear Experts,

Can anyone, please help me in understanding the following quotation from UCMDB–SC Integration Enhancement Guide.

“TQL only returns CI ID and no attributes - If your TQL file does not produce the required attributes you added, ensure your CMDB property key values are in the proper CMDBObject structure. This is typically the second or third CMDB”

I am trying to produce an XML file based on a custom TQL and in the produced XML I have only CI IDs and nothing else on the requested CIs.

Thank you in advance!

 

 

P.S. This thread has been moved from Application Perf Mgmt (BAC / BSM) Support and News Forum to CMS and Discovery Support and News Forum. - Hp forum moderator

3 REPLIES
Valued Contributor

Re: UCMDB–SC Integration: TQL only returns CI ID

Hello,

When you created the TQL, have you changed the layout settings of the nodes? If not, please go to your TQL, then edit the node properties for each node your want to see more attributes in the XML, then click on the "Advanced Layout Setting" word (it doesn't look like a button!!) near the Show Preview button. Finally, check the attributes you want to see in the XML.

Hope this answer your question.

Olivier Lauret
uCMDB and BAC Solution Architect
EOH Europe
http://www.eoh-europe.com
Occasional Advisor

Re: UCMDB–SC Integration: TQL only returns CI ID

Thank you, Olivier! This answers my question. You saved me a lot of time. Thread closed.
Occasional Advisor

Re: UCMDB–SC Integration: TQL only returns CI ID

Thread closed.
//Add this to "OnDomLoad" event