UCMDB and UD Practitioners Forum (Previously CMS)
Showing results for 
Search instead for 
Do you mean 

UCMDB-SM integration

UCMDB-SM integration

[ Edited ]

Hi,

      I integrated SM 9.20 and UCMDB 9.03 for data push. CIs from UCMDB are present in SM but my problem is when i click the 'Actual state' tab for a CI in SM i get a msg like this

 ***********************************************************************************************************************************

The Actual State data is not available at this time. Please contact your administrator.
Error calling method: doSoapRequest in class:com/hp/ov/sm/server/utility/SoapClient Exception (com.sun.xml.messaging.saaj.SOAPExceptionImpl: java.security.PrivilegedActionException: com.sun.xml.messaging.saaj.SOAPExceptionImpl: Message send failed)

 

*************************************************************************************************************************************

Looks like some problem with the integration and Web services. Can you help me out here ?

 

 

P.S. This thread has been moved from Application Perf Mgmt (BAC / BSM) Support and News Forum to CMS and Discovery Support and News Forum. - Hp Forum Moderator

4 REPLIES
Advisor

Re: UCMDB-SM integration

Hi, I think you solved the issue, otherwise you have to check your Active Integrations tab (the part of UCMDB) in the System Administration->Miscellaneous->System Information Record

You have to specify the WSDL of UCMDB web service.

Then you have to logout and login and try again.

Regards

Advisor

Re: UCMDB-SM integration

I'm facing the same issue. 

how to resolve it. can you please let me know?

 

Thanks

Sher

Trusted Contributor

Re: UCMDB-SM integration

 

Here are the few steps whcih you can do to test this,

  1. Try to open the ucmdb webservice url from the SM server

  2. The CI whcih you are looking for, check in ucmdb whether it exists or not.

  3. Are you able to open the viewinUcmdb  ?

 

If above things is working fine, then we need to check in sm.log what error it logs and then ucmdb api logs to check whether rquest has reached ucmdb or not.

Advisor

Re: UCMDB-SM integration

Here are the few steps whcih you can do to test this,

  1. Try to open the ucmdb webservice url from the SM server - It works. 

url - https://<server_name>:8443/axis2/services/ucmdbsmservice?wsdl

  2. The CI whcih you are looking for, check in ucmdb whether it exists or not. - Yes

  3. Are you able to open the viewinUcmdb  ? - YES, It opens up after entering credentials. 

 

If above things is working fine, then we need to check in sm.log what error it logs and then ucmdb api logs to check whether rquest has reached ucmdb or not.

 

Since, the error message is failed to send message. I suspect webservice request is not reaching ucmdb server. 

 

wondering what could be the issue?can different ucmdb id be the issue? how to check CIs ucmdb id in SM9.3

 

could you please assist.

 

Thank you,

Sher

//Add this to "OnDomLoad" event