UCMDB and UD Practitioners Forum (Previously CMS)
Showing results for 
Search instead for 
Do you mean 

UCMDB to SM relationship push is not working.

Frequent Advisor

UCMDB to SM relationship push is not working.

I'm trying to replicate an issue in my development environment and i deleted all the data in cirelationship table in SM and trying to push the relationship data from ucmdb.

 

But jobs are getting successful and no data is ther in servicemanager.

 

While i run the datapush in ucmdb and if i check/search sm i can see one record in the CM.relationship form and immediately its getting deleted. if i again search i can see some other record and ultimately after the data push is completed if i search SM i says no record found.

 

we have recently upgraded sm to 9.33 version. in prod and dev our CM.relationship forms are different. Please chek the attachment. Is that changed due to the upgrade of SM to 9.33?

 

How to solve this data push issue.

 

Also can anyone post the screenshot for cm.relationship form in SM9.33 to verify that i have the correct format in 9.33?

 

 

Regards,

KUT

6 REPLIES
Frequent Advisor

Re: UCMDB to SM relationship push is not working.

HI KUT,

 

have you installed uCMDB enhancement pack in SM. if not please upload uCMDB content pack in SM and then try again.

 

Follow these steps to view content release details: 1 Log in to your Service Manager server as a System Administrator. 2 Go to System Administration > Ongoing Maintenance > Content Release and select View Content Information. 3 Click Search to list all content releases.

 

Result should be

Contenetname : UCMDB_Enhancement

version:

appliation version:

 

Regards,

Prasad

Frequent Advisor

Re: UCMDB to SM relationship push is not working.

THanks for your reply.

 

I cannot see any content releases there in SM.

 

WHat is this content releases? how this will help pushing data from uCMDB to SM. All other data push is working fine except the relations.

 

Can you give me more details about this?

 

Regards,

Sreekanth

Frequent Advisor

Re: UCMDB to SM relationship push is not working.

Hi Sreekanth,

 

what is the version of SM and uCMDB you are using? I had the same issue but in my case, not even a single CI was pushed to SM. always the job used to get success. please go through the document attached.

 

 

Regards,

Prasad

Frequent Advisor

Re: UCMDB to SM relationship push is not working.

THanks for your reply.

 

Please find the attachment for the version details and advice what we need to do?

 

Also if we need to install the content pack in SM where should i download it? And how do i identify i'm using the correct Content pack? is there any name that you can provide?

 

Regards,

KUnj

Frequent Advisor

Re: UCMDB to SM relationship push is not working.

One more question.

 

AS we already upgraded the SM to 9.33 version whether this content pack also got installed?

 

 

What exactly the difference between the content pack and the major version upgrade. My understanding is that content packs are small packs and all content packs will add up to a version upgrade.

HPE Expert

Re: UCMDB to SM relationship push is not working.

I'd like to clarify situation around update strategy.

In general there is a separation between UCMDB code and Content Packs for discovery.

UCMDB code could be updated either by major/minor version upgrade (for instance 10.01 -> 10.10) or by installation of Cumulative Update Package, also known as CUP. CUPs includes changes coming from the customers, released as a package after QA process. According to internal procedure, CUPs not including new functionality and as result lowering probablility of new defects. Both Service Packs (minor versions) and CUPs are destributed via HP SSO portal -> http://support.openview.hp.com/selfsolve/patches .

 

Content Pack are also have major version (for instance CP12 -> CP13). The fixes are destributed as Update packages. Both CP versions and CP Updates are destributed via HP LN (for 10.X -> https://hpln.hp.com/group/universal-discovery and 9.X -> https://hpln.hp.com/group/discovery-and-dependency-mapping-inventory product lines).

Hope this helps.

Regards
-Dmitry Gomel, PMP
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Click the Like button at the bottom to say 'Thanks'.
//Add this to "OnDomLoad" event