UCMDB and UD Practitioners Forum (Previously CMS)
Showing results for 
Search instead for 
Do you mean 

getFilteredCIsByType method not working

SOLVED
Go to Solution
Frequent Advisor

getFilteredCIsByType method not working

Hi,

 

I am using HP UD 10.10

 

I want to filter out CIs which have their "last_modified_time" attribute value greater then a particular date.

For this I am using the "getFilteredCIsByType" web service method. The date condition is throwing the error. PFB the code.

<typ:dateConditions>
               <!--Zero or more repetitions:-->
               <typ:dateCondition>
                  <typ:condition>
                     <typ:name>last_modified_time</typ:name>
                     <!--Optional:-->
                     <typ:value>2014-05-30T04:56:35</typ:value>
                  </typ:condition>
                  <typ:dateOperator>&gt;</typ:dateOperator>
               </typ:dateCondition>
            </typ:dateConditions>

 PFB the error message.

 

<soapenv:Text xml:lang="en-US">No match found for value '">"' in enum class com.hp.schemas.ucmdb.types.DateCondition$DateOperator</soapenv:Text>

 

Please help...

Thanks in advance.

3 REPLIES
Trusted Contributor

Re: getFilteredCIsByType method not working

Instead of this:

 

<typ:dateOperator>&gt;</typ:dateOperator>

Use:

 

<typ:dateOperator>Greater</typ:dateOperator>

 

 

 

Trusted Contributor

Re: getFilteredCIsByType method not working

Hello,

 

Can you tell me if my suggestion helped resolve your problem?

Frequent Advisor

Re: getFilteredCIsByType method not working

Hello,

 

It resolved my issue. Thanks for the help.

 

//Add this to "OnDomLoad" event