UCMDB and UD Practitioners Forum (Previously CMS)
Showing results for 
Search instead for 
Do you mean 

uCMDB 8.04 High Availability (Backup Server Not Ready)

M13
Frequent Advisor

uCMDB 8.04 High Availability (Backup Server Not Ready)

[ Edited ]

Hi everyone,

I installed UCMDB 8.04 in High Availability mode on Windows 2008, and configured the software on both the primary and backup servers, but unfortunately the backup server is not ready yet.

All the services on the backup server started except for the "CMDB" service under HAC status.

We analyzed the log files of the backup server & we found that some TCP ports on the primary server need to be opened in order for the backup CMDB service to connect to the primary server. We opened the required ports, but despite these changes, CMDB on the backup server didn't run!

When we opened ALL the TCP Ports on the primary server, the CMDB service on the backup server started right away!

We then decided to trace the ports used by the backup server to connect to the primary server using the netstat command in the Command Prompt to know the specific ports required by UCMDB, each time we ran netstat on the primary server, we found that the ports used by the backup server change every single time, it seems UCMDB selects random ports dynamically!

Please advise regarding this critical issue, because it's not logical at all to open all the TCP ports on the primary server in order for UCMDB on the backup server to run properly.

Is there any configuration file on the backup server that could be reconfigured in order to set some static TCP ports on the primary server to be used by the backup server??

Looking forward to your suggestions,
Thanks in advance,
Ahmed

 

P.S. This thread has been moved from Application Perf Mgmt (BAC / BSM) Support and News Forum to CMS and Discovery Support and News Forum. -HP Forum Moderator

1 REPLY
HPE Expert

Re: uCMDB 8.04 High Availability (Backup Server Not Ready)

Having a firewall between primary and backup uCMDB servers is not a supported architecture for uCMDB HA. Some of the ports used are dynamic indeed, and I don't think that you can configure ALL the ports to be static. So you'd better re-consider your HA setup architecture rather than chasing the dynamic ports.
//Add this to "OnDomLoad" event