UCMDB and UD Practitioners Forum (Previously CMS)
Showing results for 
Search instead for 
Do you mean 

uCMDB to SM integration testing new field.

Frequent Advisor

uCMDB to SM integration testing new field.

I have a field company in cirelationshi table

 

for testing purpose i'm using that field in the external action definition

 

in the External action definition i have added the field company and caption as Company.

 

No in xslt (ucmdb) i have added a line under

 

  • ServiceManagerAdapter9-x/physical_relations.xslt

 

<Company><xsl:value-of select="@parentID"/></Company>

 

All other fields which was there before is populating as normal but the new line i added is not getting populated when i run the relationship integratin job.

 

is there anything else i need to do to puch the @parentID to company field in SM?

 

one more info the same parentID field is also mapped to another field in SM like this:

<ParentCI><xsl:value-of select="@parentID"/></ParentCI>

 

but i'm just testing whether my company field is getting data.

 

Please help.

2 REPLIES
Occasional Advisor

Re: uCMDB to SM integration testing new field.

Hello agian Kunjappy,

Can you post a screenshot of each of the configured items (the dbdict, external access & XSLT)? Also, run a display command against the RAD debugger in the SM client for the company field.

You can also try an alternative XSLT mapping for the @parentID attribute:
<xsl:for-each select="@parentID">
<ParentCI><xsl:value-of select="."/></ParentCI>
<Company><xsl:value-of select="."/></Company>
</xsl:for-each>
-----
Christian Lacsina, Engineer
Effectual Systems Group, Inc.
http://www.effectualsystems.com/
Respected Contributor

Re: uCMDB to SM integration testing new field.

double check the field is exposed with the correct case in your HP Service Manager extaccess record.

 

//Add this to "OnDomLoad" event