VM Explorer Practitioner Forum
Showing results for 
Search instead for 
Do you mean 

ESXI5.5 - New Version not working - Cannot download VMX

Occasional Visitor

ESXI5.5 - New Version not working - Cannot download VMX

Using ESXI 5.5
HPE VM Explorer® 6.3.001 (64-bit) free edition

Error-message:
"Error: Cannot download xxxx.vmx (VMXLib.Logic.Browser.ESXiBrowser: File [iSCSI] xxxx.vmx could not be downloaded)"

The datstore is normally accessible, even from the webinterface of HPE VM Eplorer

5 REPLIES
Frequent Advisor

Re: ESXI5.5 - New Version not working - Cannot download VMX

Hi

Are you able to browse datastore of ESXi host using web page from VM Explorer ? Like -

https://VCENTERSERVER:9443/vsphere-client

if yes, then I would suggest to open a support case and provide us debug report to check further details.

Regards

Ashok Goyat

Occasional Visitor

Re: ESXI5.5 - New Version not working - Cannot download VMX

I don't have the web-client installed, but only the windows-tool (vSphere Client v 5.5.0)

I just encountered another "problem":
I can normally browse (using hpe vm explorer) the data-stores, but if I try to access one of the files (show as text) I get the following error-message:

"...Exception: Error connecting to agent, Ein Verbindungsversuch ist fehlgeschlagen, da die Gegenstelle nach einer bestimmten Zeitspanne nicht richtig reagiert hat, oder die hergestellte Verbindung war fehlerhaft, da der verbundene Host nicht reagiert hat 192.168.0.160:62000..."

Frequent Advisor

Re: ESXI5.5 - New Version not working - Cannot download VMX

Hi,

VMX agent communicate at TCP port range 62000 – 65000 between ESXi hosts and VM Explorer server.  

From user manual, enabling Use HPE VM Explorer Agent on ESXi requires ports 22 (SSH), 443 (HTTPS) and 62000-65000.
Using VDDK requires port 902.

From error message it looks like the communication failed at port 62000. Please make sure these ports are open for communication. If this doesn't solve the issue then you may want to reinstall HPE VM Explorer agent, refer to user guide for installation instructions.

Regards

Ashok Goyat

Occasional Visitor

Re: ESXI5.5 - New Version not working - Cannot download VMX

well according to the FAQ I should use those commands:
esxcfg-firewall -o 62000:65000,tcp,in,VMX-Explorer
esxcfg-firewall -o 62000:65000,tcp,out,VMX-Explorer

but the esxcfg-firewall is not part of my ESXI(free) installation.

Question: did you change the way of communication between 6.2 and 6.3, as 6.2 and the versions before did work properly.
Only 6.3 has this issues.
Is there a way to operate 6.2 without the mandatory update to 6.3???

Occasional Visitor

Re: ESXI5.5 - New Version not working - Cannot download VMX

I added the following lines to /etc/vmware/firewall/service.xml 

<service id='0100'>
<id>VMX_IN</id>
<rule>
<direction>inbound</direction>
<protocol>tcp</protocol>
<porttype>dst</porttype>
<port>
<begin>62000</begin>
<end>65000</end>
</port>
</rule>
<enable>true</enable>
<required>false</required>
</service>

<service id='0101'>
<id>VMX_OUT</id>
<rule>
<direction>outbound</direction>
<protocol>tcp</protocol>
<porttype>dst</porttype>
<port>
<begin>62000</begin>
<end>65000</end>
</port>
</rule>
<enable>true</enable>
<required>false</required>
</service>

Browsing the datastore and accessing the files now works, but a backup is still not working.
Still the same error-message:

(Error: Cannot download ArchLinux.vmx (VMXLib.Logic.Browser.ESXiBrowser: File [iSCSI] ArchLinux/ArchLinux.vmx could not be downloaded))

 

 

 

 

 

//Add this to "OnDomLoad" event