Virtualization
cancel
Showing results for 
Search instead for 
Did you mean: 

Integrity Virtual Machines Manager on SMH

 
SOLVED
Go to solution
Highlighted
Harry_IV
Advisor

Integrity Virtual Machines Manager on SMH

Hello,
I try to use SMH to manage my VMs> (Tools -> Integrity Virtual Machines Management -> Integrity Virtual Machines Manager) and see error:
"Incorrect permissions.
An error occurred communicating with WBEM: CIM_ERR_ACCESS_DENIED CIM_ERR_ACCESS_DENIED: PGS05203: THE USER 'hpsmh' IS NOT AUTHORIZED TO RUN 'EnumerateInstances' IN THE NAMESPACE 'root/cimv2/hpvm'"
What does it mean?
OS - 11.31, VM 4.0
11 REPLIES 11
Highlighted
Steven E. Protter
Exalted Contributor

Re: Integrity Virtual Machines Manager on SMH

Shalom,

This kind of message usually means one of two things:
* An actuyal permissions problem in the configuration area of the VM 4.0 product.
* A patch is needed.

I'd check both out.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Highlighted
Rita C Workman
Honored Contributor

Re: Integrity Virtual Machines Manager on SMH

What are you trying to "manage" on those hosts?

The error msg seems to say "hpvm" is not there. Managing and running the hpvm commands in done on the VMHost. So I'm thinking you need to run commands over there.

....but my view could be tainted, because I have little to no fondness for SMH.

Just a thought,
Rita
Highlighted
Shinji Teragaito_1
Respected Contributor

Re: Integrity Virtual Machines Manager on SMH

I'm not sure if the message indicates the failure for the VMMGR
configurations.

Can you describe how you configured the WBEM credentials ?
http://docs.hp.com/en/T8669-90041/ch02s05.html#set_webem_creds_smh

As for me, after installing VMMGR on a VM Host, I tried to
configure the valid user credentials for 2 VM guests respectively
at "Per-VM user name and password". After pressing the OK button,
I can access to the VM Manager view such as Figure 3-6.
http://docs.hp.com/en/T8669-90041/ch03s02.html
Highlighted
Harry_IV
Advisor

Re: Integrity Virtual Machines Manager on SMH

it VM host. VMM is working only in SIM
VMM is not working using SMH on VM host.
.....
WBEM credentials on VM host is ok:
checking for WBEM support on system.
This system has WBEM protocol support
This system has at least one SMI-S CIMOM installed
This system has a server CIMOM installed
Running WBEM rules based identification.
Got ComputerSystem WBEM/WMI data from the system
.....


Highlighted
Harry_IV
Advisor

Re: Integrity Virtual Machines Manager on SMH

The problem is solved if:
cimconfig -s \ enableNamespaceAuthorization=false -p

If enableNamespaceAuthorization=true
VMM is not working on SMH
Why?


Highlighted
Shinji Teragaito_1
Respected Contributor

Re: Integrity Virtual Machines Manager on SMH

Can you show the output for "cimconfig -l -p" ?

I guess enableSubscriptionsForNonprivilegedUsers is true in your
configuration.

The enableNamespaceAuthorization property is false as default. I
don't understand why your system had
enableNamespaceAuthorization=true. Anyway, The default, false,
means that users are authorized across all namespaces. If
enableNamespaceAuthorization is set to true, you must authorize
each user, namespace by namespace, with the cimauth command.

In your case, I guess you specified "hpsmh" user in the WBEM
credentials page I presented in my previous message.

As for me, I'm using the default configurations for cimconfig on
HPVM 4.1 host running on 11.31 0903.

# cimconfig -l -p
enableAuditLog=false
sslClientVerificationMode=disabled
idleConnectionTimeout=0
enableSubscriptionsForNonprivilegedUsers=false
shutdownTimeout=30
authorizedUserGroups=
enableRemotePrivilegedUserAccess=true
enableHttpsConnection=true
enableNamespaceAuthorization=false
enableHttpConnection=false
#

I specified "root" user in the WBEM credentials page for each VM
guests. I have never encountered your problem when accessing VM
Manager through HP SMH.
Highlighted
Harry_IV
Advisor

Re: Integrity Virtual Machines Manager on SMH

I am using "cimauth user" (login simuser)
1. First of all, I use cimauth commands:
cimauth -a -u simuser \
-n root/cimv2 -R -W
cimauth -a -u simuser \
-n root/PG_InterOp -R -W
cimauth -a -u simuser \
-n root/PG_Internal -R -W
2. second check rights for namespaces
cimauth -l
simuser, root/cimv2, "rw"
simuser, root/PG_InterOp, "rw"
simuser, root/PG_Internal, "rw"
3. I use user named simuser for WBEM credentials.
# cimconfig -l -p
enableAuditLog=false
sslClientVerificationMode=optional
idleConnectionTimeout=0
enableSubscriptionsForNonprivilegedUsers=true
shutdownTimeout=30
authorizedUserGroups=
enableRemotePrivilegedUserAccess=true
enableHttpsConnection=true
enableNamespaceAuthorization=true
enableHttpConnection=false

Highlighted
Shinji Teragaito_1
Respected Contributor

Re: Integrity Virtual Machines Manager on SMH

What happens if simuser is allowed to access the namespace "root/cimv2/hpvm" ?

# cimauth -a -u simuser -n root/cimv2/hpvm -R -W
# cimconfig -s enableNameSpaceAuthorization=true -p
Highlighted
Harry_IV
Advisor

Re: Integrity Virtual Machines Manager on SMH

Ok.I added rights to namespace "root/cimv2/hpvm" for user simuser. But why VMM try automaticaly to use user hpsmh?
Hot to change during logon from user hpsmh to simuser?