Volume Management
Showing results for 
Search instead for 
Did you mean: 

Hard Drive Installation Problem

Charles Clowes
Occasional Visitor

Hard Drive Installation Problem

I have an HP 928LX with MPE/IX 5.5 that I use as a test system. I've been trying to add an ST19171N - 9 GB drive but it doesn't show up when I do a DSTAT ALL.
I don't think that the drive is bad. It shows up in the ODE/MAPPER, and I have set it up in SYSGEN/IO. The system boots fine when it's attached and there are no SCSI conflicts with any other devices.
I'm thinking that it may be a problem with the low level formating, or maybe there is a jumper setting, other than the SCSI address, that is misconfigured, and I'm not seeing it.
I do have another ST19171N - 9 GB drive that I do think is bad, because it gives me an FLT DEAD error when I boot up the machine while it's attached.
My question is, is there an offline utility on the HP3000 or that I can install from tape, that I can use to change the low level formatting?
Also, from what I've described here, is there another issue that I'm missing that may be causing the problem?
Kwan Fong, Emile
Honored Contributor

Re: Hard Drive Installation Problem

Hello Charles,

A couple of things to check:

1) 9 GB Single-Ended Disc ST19171N requires 5.5 Powerpatch #3 or later.

2) Verify if "ST191171N" is listed in the IODFAULT.PUB.SYS file. If it is not, then the driver for that type of disc is not installed.

3) In the ODE/Mapper list, verify that the drive ST19171N has HP firmware; firmware rev. should start with "HP". STxxxxx drives are manufactured by SeaGate; they can be used in platform other than HP.

4) LowLevel formatting tool is included in ODE; it is password-protected and reserved for HP personel use only. Also, the ODE (Offline Diagnostic Environment) must have the correct patch to support the new 9GB discs.
King is the customer!
Charles Clowes
Occasional Visitor

Re: Hard Drive Installation Problem

Upon further investigation I came up with some additional information and errors.
When I run Mapper, it says that the firmware for the ST19171N is DD02.
I ran the DISKEXPT and it asked for the password, so I ran the DISKUTIL instead. It came up with the following error:
From BLK 6246400 to 6250496
SenseKey: Recovered Error
Recovered Data with error Correction & Retries Applied

Also, when I boot Mount All Volumes reports:
AVR Failure on LDEV2, (which is the ST19171N), Status=FFFC0071, #4 (AVR6).

Am I looking at a bad drive? Is there anything else I can try to get this drive online?
Stan Sieler
Respected Contributor

Re: Hard Drive Installation Problem

Probably looking at a bad drive.

Since you've configured it as LDEV 2,
when MPE is up you should be able to
look at it via:

dsec 2.0, 80, b

which should show you the first sector
of the disk (in both hex and ASCII).

BTW, if you're on PowerPatch 5 of MPE/iX 5.5,
it supports 18 GB disks. The easiest way to
tell the max disk size on a given system is
to look at IODFAULT.PUB.SYS for disk descriptions with "GB". On my 5.5 PP5
system, IODFAULT mentions supporting
a 36 GB drive ... twice as large as the
Communicator said was supported.