WAN Routing

3G Modem on MSR 900 not working.

 
mparrad
Occasional Contributor

3G Modem on MSR 900 not working.

Hi everyone,

 

I need some help from you guys,

 

I have a H3C MSR 900 Router in which I have to set up a USB 3G Modem from Telus (Canada) the model of the USB stick is HUAWEI HSPA+ E182E, and the Router has the latest firmware: CMW520-R2207.

 

The problem is that the router doesn't recognize the Modem, when I insert the modem, the CLI says: "3G module is initializing, waiting please..." but it doesn't do anything else...

 

I've tried to configure it, following this steps: 

 

[RTA]user-interface tty 33

[RTA-ui-tty33]modem both

[RTA-ui-tty33]quit

<RTA>system-view

System View: return to User View with Ctrl+Z.

[RTA]dns resolve

[RTA]dns proxy enable

[RTA]dns server 8.8.4.4

[RTA]acl number 3000

[RTA-acl-adv-3000]rule 0 permit ip

[RTA-acl-adv-3000]quit

[RTA]dialer-rule 1 ip permit

[RTA]ip route-static 0.0.0.0 0.0.0.0 Cellular 0/0

[RTA]interface Cellular 0/0

[RTA-Cellular0/0]nat outbound 3000

[RTA-Cellular0/0]ppp ipcp dns request

[RTA-Cellular2/0]ip address ppp-negotiate

[RTA-Cellular2/0]dialer enable-circular

[RTA-Cellular2/0]dialer-group 1

[RTA-Cellular2/0]dialer timer idle 60

[RTA-Cellular2/0]profile create 1 isp.telus.com authentication-mode none

 

When I try to create the profile, the router says: "Erorr: Modem not present".

I've tried to find the networks (operators) manually by entering the commmand: plmn search and plmn select manual, but it says the same: "Error, Modem not present"

 

The USB Led at the front of the router doesn't light either...

 

I called HP tech support and they have scaled the case to level 2... But I would like to know if some of you have any idea of what is going on here? Is the router USB Module bad? broken? damaged? Should I change it?

 

Oh, I have also tried with another USB stick and happens the same...

 

Thanks in advance...

 

mparrad.

4 REPLIES 4
vidalmvc
New Member

Re: 3G Modem on MSR 900 not working.

Hi mparrad

 

I'm having the same problem with a USB 3G Modem from Movistar (Spain) Huawei Mobile Connect E169. H3C MSR 900, Sofware version CMW520-R2104P02, Firmware v1.13. Same symptoms, router doesn't recognize the modem and the front USB led doesn't blink. The USB modem is working perfectly on a PC.

 

Anyone have similar setup working?? It's possible that H3C doesn't support this setup until future firmware revisions??

 

Any help will be appreciated.

 

Thanks

Pedro_Chambel
New Member

Re: 3G Modem on MSR 900 not working.

Hi,

 

Same thing, here in Portugal, with a 3G Vodafone Mobile Connect (Huawei E272) and same router (MSR 900) and USB LED status (off ! not lit!).

 

Wonder if this has to do with router's Comware ver. ?

 

Anyone else with this same prob.?

 

Did HP/H3C said something else in the meanwhile?

 

Good ideas welcomed !

 

Cheers for you all

 

 

AlexGrigorescu
Occasional Advisor

Re: 3G Modem on MSR 900 not working.

Hi guys!

 

I haven't got a chance to test the USB modem on my router. But I will give it a try the second I get back to work (I have 6 different modems and 3 different HP routers to play with).

But here are my recomandations:

 

1. Upgrade the firmware to the latest version (R2209) because in each version there are new drivers for modems, including some you are having problems with.

 

2. Use the info on how to get this working (and the configuration examples) from the H3C configuration manual (wich you can get from here: http://www.h3c.com/portal/download.do?id=1223747) - Section 02 - 02 - 3G Modem.

 

Hope it helps.

 

Regards,

Alex

Farzan
Occasional Visitor

Re: 3G Modem on MSR 900 not working.

Hi guys,

 

I had the same issue after I upgrade the software to MSR9XX.SI_5.20.R2315L02.RU it's stated to work. So enjoy now J

 

Thanks

 

Farzan.


@AlexGrigorescu wrote:

Hi guys!

 

I haven't got a chance to test the USB modem on my router. But I will give it a try the second I get back to work (I have 6 different modems and 3 different HP routers to play with).

But here are my recomandations:

 

1. Upgrade the firmware to the latest version (R2209) because in each version there are new drivers for modems, including some you are having problems with.

 

2. Use the info on how to get this working (and the configuration examples) from the H3C configuration manual (wich you can get from here: http://www.h3c.com/portal/download.do?id=1223747) - Section 02 - 02 - 3G Modem.

 

Hope it helps.

 

Regards,

Alex