HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

1800-8g and tagged vlan

 
SOLVED
Go to solution
Jur van der Burg
Respected Contributor

1800-8g and tagged vlan

I've got 2 1800-8g switches and want them to connect 2 different subnets from one place to another, with just one cable between them.

 

switch 1:

port 1 vlan aware, no ingress filtering, packet type tagged, pvid none

port 2 vlan aware, no ingress filtering, packet type all, pvid 13

port 3 vlan aware, no ingress filtering, packet type all, pvid 14

 

switch 2:

port 1 vlan aware, no ingress filtering, packet type tagged, pvid none

port 2 vlan aware, no ingress filtering, packet type all, pvid 13

port 3 vlan aware, no ingress filtering, packet type all, pvid 14

 

The switches are connected to each other on port 1. Computers are connected on the  other ports (no vlan).

The intention is to connect 2 different subnets over just one cable.

 

I cannot seem to get traffic between the switches. Also, mirroring port 1 to for example port 8

and connecting another computer on that port will not show vlan tagged traffic between the switches.

 

What am I doing wrong?

 

 

P.S. This thread has been moved from ProCurve / ProVision-Based to Web and Unmanaged. -HP Forum Moderator

 

 

7 REPLIES
Vince-Whirlwind
Honored Contributor

Re: 1800-8g and tagged vlan

Just to clarify:

you want a PC on Switch1 Port2 to be able to talk to a PC on switch 2 Port2?

And a PC on Switch1 Port3 to be able to talk to a PC on switch 2 Port3?

 

Your config should work. Basic questions first:

1/ Do you have link lights on Port1 on both switches?

2/ What does your LLDP Neighbour Table say?

3/ Have you created VLANs 13 & 14 on both switches on the VLAN setup page?

Jur van der Burg
Respected Contributor

Re: 1800-8g and tagged vlan

>you want a PC on Switch1 Port2 to be able to talk to a PC on switch 2 Port2?

>And a PC on Switch1 Port3 to be able to talk to a PC on switch 2 Port3?

 

Correct.


>Your config should work. Basic questions first:

>1/ Do you have link lights on Port1 on both switches?

 

Yes

 

>2/ What does your LLDP Neighbour Table say?

 

The switches can see each other:

 

Local Port    Chassis ID    Remote Port ID    System Name    Port Description    System Capabilities    Management Address
1    00-1f-28-5c-6e-30 (MAC-address) 1 (local) hpsw5  Port #1 Bridge(+) 192.168.13.79 (IPv4)

Local Port    Chassis ID    Remote Port ID    System Name    Port Description    System Capabilities    Management Address
1    00-23-47-23-71-f0 (MAC-address) 1 (local) hpsw4  Port #1 Bridge(+) 192.168.13.78 (IPv4)

>3/ Have you created VLANs 13 & 14 on both switches on the VLAN setup page?

 

Yes

 

VLAN Per Port Configuration
Port/
Trunk    VLAN aware Enabled    Ingress Filtering Enabled    Packet Type    PVID
Port 1         x                                            Tagged Only  None
Port 2         x                                            All          13
Port 3         x                                            All          14
Port 4         x                                            All          1
Port 5         x                                            All          1
Port 6         x                                            All          1
Port 7         x                                            All          1
Port 8         x                                            All          1

Vince-Whirlwind
Honored Contributor

Re: 1800-8g and tagged vlan

I'm not sure off the top of my head that you should make ports 2 & 3 "VLAN Aware". Pretty sure you don't, but not sure if it makes a difference, because your PVID is correct.

 

Next step is the PCs - what are their IP addresses & subnet masks?

PC 1 VLAN13?

PC2 VLAN13?

PC1 VLAN14?

PC2 VLAN14?

Jur van der Burg
Respected Contributor

Re: 1800-8g and tagged vlan

>I'm not sure off the top of my head that you should make ports 2 & 3 "VLAN Aware". Pretty sure you don't, but not sure if it makes a difference, because your PVID is correct.

 

Enabling or disabling this on either the vlan ports or port 1 (on both switches) does not make a difference.

 

>Next step is the PCs - what are their IP addresses & subnet masks?

>PC 1 VLAN13?

>PC2 VLAN13?

>PC1 VLAN14?

>PC2 VLAN14?

 

I just tested with 1 vlan (14) and in that case pc1 is at 192.168.20.1 and pc2 is at 192.168.20.2. They are both directly connected to the different switches. That subnet is nowhere else in use.

 

If I connect both systems to port 4 (which has the default config) and the cable between the switches to port 5 it works, so the ip address setup of both pc's is correct.

 

 

Vince-Whirlwind
Honored Contributor

Re: 1800-8g and tagged vlan

You definitely need VLAN aware on port1.

 

What about if you have your PCs in Port4 with the link still in port 1? 

And then change port 1 PVID to 1 and test again.

 

 

Jur van der Burg
Respected Contributor

Re: 1800-8g and tagged vlan

>You definitely need VLAN aware on port1.

 

Ok it's set.

 

>What about if you have your PCs in Port4 with the link still in port 1? 

>And then change port 1 PVID to 1 and test again.

 

With pvid 1 i get no traffic. with pvid none they see each other.

 

I mirrored port 1 to another port and traced that. In the original setup with vlan enabled the only thing I see on that port is lldp packets from both switches:

 

13:41:24.370680 00:23:47:23:71:f0 (oui Unknown) > 01:80:c2:00:00:0e (oui Unknown), ethertype Unknown (0x88cc), length 97:
        0x0000:  0180 c200 000e 0023 4723 71f0 88cc 0207
        0x0010:  0400 2347 2371 f004 0207 3106 0200 7808
        0x0020:  0750 6f72 7420 2331 0a05 6870 7377 340c
        0x0030:  1a50 524f 4355 5256 4520 4a39 3032 3941
        0x0040:  202d 2050 412e 3033 2e31 300e 0400 0400
        0x0050:  0410 0c05 01c0 a802 0a02 0000 000e 0000
13:41:26.099502 00:1f:28:5c:6e:30 (oui Unknown) > 01:80:c2:00:00:0e (oui Unknown), ethertype Unknown (0x88cc), length 97:
        0x0000:  0180 c200 000e 001f 285c 6e30 88cc 0207
        0x0010:  0400 1f28 5c6e 3004 0207 3106 0200 7808
        0x0020:  0750 6f72 7420 2331 0a05 6870 7377 350c
        0x0030:  1a50 524f 4355 5256 4520 4a39 3032 3941
        0x0040:  202d 2050 412e 3033 2e31 300e 0400 0400
        0x0050:  0410 0c05 01c0 a802 0a02 0000 000e 0000

If I plug the pc's in port 4 I can see the traffic between the pc's (wihtout tag obviously since that port was setup without tagging)

 

So it looks like the switch will not forward a packet from a vlan-enabled port to port 1 at all.

Notice that this was tried with vlan-aware enabled and disabled on port 2 and 3 which made no difference.

 

Jur van der Burg
Respected Contributor
Solution

Re: 1800-8g and tagged vlan

Ok i fixed it.

 

The problem was that on the vlan setup page I had to include port 1 besides port 2 on vlan 13 and port 3 on vlan 14. After doing that it works as expected.

 

Thanks for the hints.