HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

1910 switch, IPv4 routing working, IPv6 routing not working

 
ChristophErdle
Occasional Visitor

1910 switch, IPv4 routing working, IPv6 routing not working

Hi,

i have one of the 1910s (JE006A - 1910-24G) at my place and I'm trying to configure IPv6 routing between the locally connected VLANs on this switch. Routing for IPv4 works as expected, but whenever I try to do routing on IPv6 from one of the connected systems traceroute hangs after reaching the switch. The switch itself can ping to the internet through the router in front of it, and also can ping all directly connected endpoints (e.g. a client on the client VLAN, and another switch on the management VLAN).

The data sheet of the switch says it's capable of doing IPv6 routing ( https://www.hpe.com/h20195/v2/getpdf.aspx/4aa1-7808enw.pdf )

Is there anything special to have configured on the 1910 to enable inter-vlan routing and packet forwarding via IPv6? Thanks all for your help, any insight is highly appreciated.

Following is the currently deployed config on the switch:

<HPE>display current-configuration
#
version 5.20, Release 1518P01
#
sysname HPE
#
clock timezone Amsterdam add 01:00:00
#
dhcp relay server-group 0 ip 172.18.253.254
#
domain default enable system
#
ip ttl-expires enable
#
lldp enable
lldp compliance cdp
#
password-recovery enable
#
vlan 1
#
vlan 2
description Management
#
vlan 3
description Server
#
vlan 4
description Client LAN
#
vlan 5
description Client WLAN
#
vlan 200
description Gast
#
vlan 253
description Transfer
#
vlan 2000
description Upstream
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
#
local-user admin
authorization-attribute level 3
service-type ssh telnet terminal
service-type web
#
stp mode rstp
stp enable
#
interface Bridge-Aggregation1
port link-type hybrid
port hybrid vlan 2 to 5 200 253 2000 tagged
port hybrid vlan 1 untagged
link-aggregation mode dynamic
#
interface Bridge-Aggregation2
port link-type hybrid
port hybrid vlan 1 to 5 tagged
link-aggregation mode dynamic
#
interface Bridge-Aggregation3
link-aggregation mode dynamic
#
interface NULL0
#
interface Vlan-interface1
ip address 192.168.2.254 255.255.255.0
dhcp select relay
dhcp relay server-select 0
#
interface Vlan-interface2
ipv6 address FD56:DD58:947C:2::1/64
ip address 172.18.2.254 255.255.255.0
dhcp select relay
dhcp relay server-select 0
#
interface Vlan-interface3
ipv6 address FD56:DD58:947C:3::1/64
ip address 172.18.3.254 255.255.255.0
dhcp select relay
dhcp relay server-select 0
#
interface Vlan-interface4
ipv6 address FD56:DD58:947C:4::1/64
ip address 172.18.4.254 255.255.255.0
dhcp select relay
dhcp relay server-select 0
#
interface Vlan-interface5
ipv6 address FD56:DD58:947C:5::1/64
ip address 172.18.5.254 255.255.255.0
dhcp select relay
dhcp relay server-select 0
#
interface Vlan-interface253
ipv6 address FD56:DD58:947C::2/64
ip address 172.18.253.253 255.255.255.0
#
interface GigabitEthernet1/0/1
port link-type hybrid
port hybrid vlan 2 to 5 200 253 2000 tagged
port hybrid vlan 1 untagged
stp edged-port enable
port link-aggregation group 1
#
interface GigabitEthernet1/0/2
port link-type hybrid
port hybrid vlan 2 to 5 200 253 2000 tagged
port hybrid vlan 1 untagged
stp edged-port enable
port link-aggregation group 1
#
interface GigabitEthernet1/0/3
port link-type hybrid
port hybrid vlan 1 to 5 tagged
stp edged-port enable
port link-aggregation group 2
#
interface GigabitEthernet1/0/4
port link-type hybrid
port hybrid vlan 1 to 5 tagged
stp edged-port enable
port link-aggregation group 2
#
interface GigabitEthernet1/0/5
stp edged-port enable
port link-aggregation group 3
#
interface GigabitEthernet1/0/6
stp edged-port enable
port link-aggregation group 3
#
interface GigabitEthernet1/0/7
stp edged-port enable
#
interface GigabitEthernet1/0/8
stp edged-port enable
#
interface GigabitEthernet1/0/9
port link-type hybrid
port hybrid vlan 1 tagged
stp edged-port enable
#
interface GigabitEthernet1/0/10
port link-type hybrid
port hybrid vlan 1 tagged
stp edged-port enable
#
interface GigabitEthernet1/0/11
port link-type hybrid
port hybrid vlan 2 to 5 200 tagged
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/12
stp edged-port enable
#
interface GigabitEthernet1/0/13
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 2 to 4 200 tagged
port hybrid vlan 5 untagged
port hybrid pvid vlan 5
stp edged-port enable
#
interface GigabitEthernet1/0/14
port access vlan 253
stp edged-port enable
#
interface GigabitEthernet1/0/15
port access vlan 2
stp edged-port enable
#
interface GigabitEthernet1/0/16
port access vlan 5
stp edged-port enable
#
interface GigabitEthernet1/0/17
port access vlan 2000
stp edged-port enable
#
interface GigabitEthernet1/0/18
port access vlan 2000
stp edged-port enable
#
interface GigabitEthernet1/0/19
stp edged-port enable
#
interface GigabitEthernet1/0/20
stp edged-port enable
#
interface GigabitEthernet1/0/21
stp edged-port enable
#
interface GigabitEthernet1/0/22
stp edged-port enable
#
interface GigabitEthernet1/0/23
stp edged-port enable
#
interface GigabitEthernet1/0/24
stp edged-port enable
#
interface GigabitEthernet1/0/25
stp edged-port enable
#
interface GigabitEthernet1/0/26
stp edged-port enable
#
interface GigabitEthernet1/0/27
stp edged-port enable
#
interface GigabitEthernet1/0/28
stp edged-port enable
#
ip route-static 0.0.0.0 0.0.0.0 172.18.253.254
#
ipv6 route-static :: 0 FD56:DD58:947C::1
#
dhcp enable
#
ntp-service source-interface Vlan-interface253
ntp-service unicast-server 172.18.253.254
#
ssh server enable
#
ip https enable
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 15
authentication-mode scheme
#
return

1 REPLY
16again
Respected Contributor

Re: 1910 switch, IPv4 routing working, IPv6 routing not working

Do you have static routes on the attached clients?

afaik, default the 1910   (at least its succesor , the 1920)  doesn't send out Router Advertisements.
On 1920, I had to enable them from CLI: 
interface Vlan-interface331
 undo ipv6 nd ra halt

Beware when using these devices as routers.  Their ARP/ND table is very limited.   On IPv6 this even hurts more, since devices have multiples addresses.  (Link Local , Global , Privacy extensions)