Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

1920 Switch and QoS - Voice

SOLVED
Go to solution
ukonstantin
Occasional Advisor

1920 Switch and QoS - Voice

Hello,

Anyone know what is the best practices to configure Voice VLAN on 1920 Switch with version 5.20.99. 

First of all I define two vlans:

Data (10) and Voice (20) 

What are the differences for the following port configs:
interface GigabitEthernet1/0/1
port link-type hybrid
port hybrid vlan 20 tagged
port hybrid vlan 1 untagged
undo voice vlan mode auto
voice vlan 20 enable
port auto-power-down
poe enable
stp edged-port enable
lldp compliance admin-status cdp txrx
lldp voice-vlan 20

and 

interface GigabitEthernet1/0/24
port link-type trunk
port trunk permit vlan 1 20
undo voice vlan mode auto
port auto-power-down
poe enable
lldp compliance admin-status cdp txrx
lldp voice-vlan 20

and 

interface GigabitEthernet1/0/25
port link-type trunk
port trunk permit vlan 1 20
port auto-power-down
lldp compliance admin-status cdp txrx
lldp voice-vlan 20

I think all the different configuration will carry voice traffic. 

So my questions are:

- How can I make sure all Voice Traffic should be trusted? (Assume the IP Phone mark voice bearer traffic with dscp ef and control traffic with cs3

- How can I remark voice as well data traffic in the configurations below with other DSCP values

- On a normal port with untagged vlan I assume all DSCP values will be set to 0?!

- In hybrid mode what happens with VOICE VLAN? Is the voice bearer and control traffic trusted (within the VOICE VLAN) 

Thanks 

Udo

 

 

6 REPLIES
16again
Respected Contributor

Re: 1920 Switch and QoS - Voice

- How can I make sure all Voice Traffic should be trusted? (Assume the IP Phone mark voice bearer traffic with dscp ef and control traffic with cs3
Interface command " qos trust dscp"  will do the trick

- How can I remark voice as well data traffic in the configurations below with other DSCP values
Example below defines classifier (select VLAN 10 traffic) a behavior (set dhcp=0),  a policy using both the classifier and the behavior. And the policy is applied to interface
traffic classifier CL_VL10 operator and
   if-match customer-vlan-id 10
traffic behavior MarkDSCP0
     remark dscp default
qos policy POL_MarkDSCP0
     classifier CL_VL10 behavior MarkDSCP0
* afaik, only one action can be added to policy!!
interface GigabitEthernet1/0/7
    qos apply policy POL_MarkDSCP0 inbound

- On a normal port with untagged vlan I assume all DSCP values will be set to 0?
Without config, DSCP value will not be altered......but DSCP is also untrusted, so all packets end up in lowest prio queue

- In hybrid mode what happens with VOICE VLAN? Is the voice bearer and control traffic trusted (within the VOICE VLAN) 
If a port trusts DSCP value, the DSCP value of all traffic entering the port is used.
If a port trusts Dot1P QoS value, the QoS value in VLAN tag of incoming packets is used.  Untagged packets don't have this tag and will end up in lowest prio queue
note: Reading the manual, I have no clue why I would ever need a hybrid port.  

ukonstantin
Occasional Advisor

Re: 1920 Switch and QoS - Voice

Thanks a lot for the detailed answers. 

What do you mean with:

- On a normal port with untagged vlan I assume all DSCP values will be set to 0?
Without config, DSCP value will not be altered......but DSCP is also untrusted, so all packets end up in lowest prio queue

I mean if a IP phone tag it's DSCP value to EF then the packet will be placed into the high priority queue?! 

Regarding the manual:

I search command oder configurations references about this switch and the QoS behaviour on the ports. But I doesn't found anything. Only a Web Configuration guide...

 

16again
Respected Contributor

Re: 1920 Switch and QoS - Voice

"Without config, DSCP value will not be altered......"
Packets leaving the switch will have the same DSCP value as packets entering the switch.

"I mean if a IP phone tag it's DSCP value to EF then the packet will be placed into the high priority queue?! "
For packets to enter high priority queue, the switch must be configured to trust incoming DSCP value on that port.
Without this trust , all packets end up treated equally in the best effort queue

"Regarding the manual"
QoS concepts explanation in manual is almost decent, but more suited as refresher than teaching a newbie.
The QoS example in manual is absurd. It abuses QoS policy framework to block traffic.  So it's useless to understand how to put together the QoS building blocks (marking, shaping rate limiting, trust...)

 

ukonstantin
Occasional Advisor

Re: 1920 Switch and QoS - Voice

Hi,

thanks again for explaining that. Regarding QoS I have knowledge from Cisco Devices. But for the 1920 I didn't found useful informations. 

Lastly I need to know if all ports on the switches have the same behaviour regarding DSCP? I mean what about the Uplink Ports. Are they also untrust? 

Thanks 

16again
Respected Contributor
Solution

Re: 1920 Switch and QoS - Voice

In web GUI,  from navigation menu on left, QoS , option port priority.
Here trust is shown for all ports, default no trust is defined for any port

ukonstantin
Occasional Advisor

Re: 1920 Switch and QoS - Voice

Great thanks...this helps a lot.