Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't set IP on tagged VLAN

PiEiEs
Occasional Advisor

Can't set IP on tagged VLAN

Hi all.....

I have a probelm with setting IP for my same tagged port in VLANs. I wat to make some wifis with different SSID and subnet. Here are list of my devices :

- 1 Switch HP 1820 - 24G 79980A as my device to configure VLAN and connect router and UAP.

- 1 UAP ( Ubiquiti Access Point ) as my access point. In this access point I already setup 3 SSIDs with different VLANID ( according to VLANIDs in switch ).

- 1 Linksys E1200. This device I configure as a router. I already setup this device to receive internet access from switch.

What I want to do is make some wifi access use UAP as my access point, whoever who connect with one of the wifis will receieve internet access and IP. Each SSID have different subnet with one and another. Because I use UAP just for AP, so I guess I need set IP for each SSID in Switch. In switch I managed to make VLAN and VLANID, here my VLAN configuration in switch :

- VLAN " VAM" VLANID 22 , Tagged port 3

- VLAN "VGZ" VLANID 33, Tagged port 3

- VLAN "VAG" VLANID 44, Tagged port 3

Can I set an IP in tagged port, because I try several times to set IP in tagged port but I just got loading icon which constantly loading until the web page back to login page configure switch and when I login, the setting that I did before not saved. And Why if I configure static IP for port in VLAN default and in the next login I have to plug my nerwork cable in port that I just configured and use the IP in that in web address and so on everytime I set new static IP in VLAN default's port.

 

And also, I want to ask which design configure the best for the my goal :

1. Should I connect the UAP in port that VLAN not configured and I connect the router in port that VLAN configured ( port 3 ) ? or .............

2. Should I connect the UAP in port that VLAN configured ( port 3 ) and I connect the router in port that VLAN not configured.

Should I make a trunk port ? If yes, please explain for what the trunk port needed.

Thank for reading my problem and kindly to let me know what you think and your suggest..

 

8 REPLIES
Skribbla
Visitor

Re: Can't set IP on tagged VLAN

If i understad you correctly you are trying to apply an IP address for each vlan to the port? I do not think that is possible.

What you can do is set an IP address to the VLAN e.g. interface vlan 22 ip address x.x.x.x x.x.x.x

Which device is providing DHCP for the vlans will it be the switch

And where do you intend to NAT traffic from the different VLANS going out to the internet?

It will be much easier to assist if you provide more details and possibly upload a diagram.

 

 

PiEiEs
Occasional Advisor

Re: Can't set IP on tagged VLAN

config.pngthe configuration

Thanks for your reply. picture above is the configuration that I want set up. 

I use HP 1820 24-G as my swicth, UAP ( same in the picture ) as my access point and linksys e1200 as my router to connect to internet.

Base on picture above, I already make VLANs in switch and tag same port for each VLANs. It's possible to add IP in tag port and trunk port ? If it's possible, in reality I can't add IP for my tag port .

Or I have another configuration that I don't know It will work or not. The cofiguration is, I make VLANs in switch and tag same port for each VLANs, and then I use that tag port to connect ( direct cable ) with my UAP which in my UAP I already make VLANs with same VLANIDs like in switch and I use another port in Switch to conncet with router. How about that configuration ?

peyrache
Respected Contributor

Re: Can't set IP on tagged VLAN

hello what is exaclty issue

can each vlan ip address ping gateway  ?

can you ping router from Wireless node ?

let me know

JY

PiEiEs
Occasional Advisor

Re: Can't set IP on tagged VLAN

Can't ping the gateway because I can' setup IP for the VLANs in my SWITCH. So my setup stuck in giving IP for each VLANs. everytime I want to change the VLAN ID for setup VLAN IP, the webpage always loading until logout by it self, and when I relogin, the VLANID for setup not change. Here is the picture of loading in my webpage config switch

loading 1820.png

PiEiEs
Occasional Advisor

Re: Can't set IP on tagged VLAN

because of my first problem which can't set IP for my VLANs, I updated the firmware and reset hardwre by pushed reset button. And after I reset to the factory fault, now I can't access the webgui.. I already set my IP in same segment with switch IP ( not work, in first time I configure my switch this way work ), I already disable my firewall and antivirus ( not work ), I reinstall my chrome ( not work ), I reset again the switch ( not work ).. so what shoul I do to access my webgui ?? The IP default in my manual book is 192.168.1.1

Skribbla
Visitor

Re: Can't set IP on tagged VLAN

Have you tried using different browsers? IE, Mozilla etc or connecting with a different PC? Running updates etc

Initially i thought you were having a logiccal configuration issue instead of a web gui issue :(

You really should be more specfic next time mate

PiEiEs
Occasional Advisor

Re: Can't set IP on tagged VLAN

how can I know if my logical configuration wrong, if I can't give IP to my VLANs ?

PiEiEs
Occasional Advisor

Re: Can't set IP on tagged VLAN

so what's wrong with my webgui, I can't change my VLAN MANAGEMENT ID to my VLAN ID...... Is this step not important to setup VLAN ?