HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 1820 vlan configuration

 
danturn
Occasional Visitor

HP 1820 vlan configuration

Hi all, 

I'm looking for a bit of help getting started with my 1820.

I have a ubiquiti edgerouter lite, ac-lite access point and the 1820

I have configured a router on a stick setup with the ubiquiti so the eth 1 port is set up like this:

 eth1:    10.1.0.1/16
 eth1.10: 10.10.0.1/16
 eth1.20: 10.20.0.1/16

so i have the native vlan 1, a vlan 10 for lan and vlan 20 for wireless.

i have dhcp scopes for 10.10.x.x and 10.20.x.x

On the 1820 i have port 24 configured as tagged in 1, 10 and 20 (i believe this is the equivalent of a cisco trunk port?)

i am having problems managing the 1820. i have given it an ip in the vlan 1 subnet (10.1.0.10) and if i give my laptop the ip 10.1.0.50 and connect to it i can manage it. but if i connect and use dhcp to get an ip in the 10.10 or 10.20 range i cant access the switch at all. although i can access the routers ip in vlan 1 (10.1.0.1).

Is there any way i can easily manage the switch from a machine in vlan 10 without having to change its ip etc.? and is it sensible to have all the routing/switching gear in a vlan seperate from the "data" vlans?

Dan

4 REPLIES
16again
Respected Contributor

Re: HP 1820 vlan configuration

On 1820, set 10.1.0.1 as the default gateway , so 1820 knows how to reach the other VLANs.
On the Ubiquiti router, make sure that web management traffic is allowed to pass.

danturn
Occasional Visitor

Re: HP 1820 vlan configuration

i have the switch gateway as 10.1.0.1, no joy. i can only manage the switch if my laptop is in the same subnet and im patched into port 1 on the switch....

the management vlanid is 1 and the management port is "none".

port 1 is tagged for vlan 1, 10 and 20

the other ports are excluded from vlan 1 and untagged for vlan 10

16again
Respected Contributor

Re: HP 1820 vlan configuration

Doublecheck Ubiquiti firewall rules, and make sure 1820 IP address subnet setting is set to correct mask ( incorrect /8 setting instead of /16 will result in the error you're reporting)

danturn
Occasional Visitor

Re: HP 1820 vlan configuration

baaaa. worked it out. on the router i hadnt defined a subinterface for vlan 1... i just had the vlan 1 address on eth1 instead of 1.1

adding vlan 1 and moving the address solved all of my problems.

thanks so much for your suggestions. turns out it was me being stupid.

dan