Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 1910-8G InterVlan routing not working

MrJoe
Occasional Visitor

HP 1910-8G InterVlan routing not working

Hi.
 
I have an HP 1910-8G switch (JG348A) that I'm trying to setup for intervlan routing
 
I have a very simple connection. 
I have 2 vlans and 2 vlan interfaces setup on my switch. 
 
VLAN2 - Internet Gateway (PVID 2, Access Link type, Untagged, 192.168.69.254/24, Port3)
VLAN3 - Connect Devices (PVID 3, Access Link type, Untagged, 172.16.69.254/24,   Port5)
 
All vlans are in separate subnets.
 
I have a Netgear Wifi router with IP address (192.168.69.1/24) connected to my switch on Port 3 (VLAN2).
I want to use this router as my default gateway to the internet for all VLANS.
 
I have a Trendnet Wifi router with IP address (172.16.69.1/24) connected to my switch on Port 5 (VLAN3).
This router's default gateway is 172.16.69.254, which is my switch VLAN3 interface IP Address.
 
My PC (172.16.69.2) which is connected to my Trendnet router has its default gateway set to (172.16.69.1), which is the router’s IP. Now my PC which is connected to my Trendnet router on VLAN3 cannot ping my Netgear router on VLAN2 … so therefore cannot access the internet. I can however use the same PC to ping VLAN interface IP addresses on the switch e.g (172.16.69.254, 192.168.69.254)
 
I have already setup a static route on the switch to this
Dest IP    Mask    Preference    NextHop 
0.0.0.0    0.0.0.0        60              192.168.69.1
 
Please help me any way you can with this problem.
According to the manuals and much google search. It should work without effort.
 
 
Thanks in advance