HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 1920-48G JG928A Link Aggregation bug

 
dmonty
Visitor

HP 1920-48G JG928A Link Aggregation bug

Using latest firmware as of Oct 2015: 5.20.99 Release 1108

 

When creating a Link Aggregation Dynamic LACP from the station connected to the soon-to-be created Aggregated ports (trunk).  The new aggregated interface does not receive a "port link-type" and thus fails.  You loose ability to continue configuring the switch through the web interface.   Also may want to set a static IP on the switch if the dhcp server is behind the soon-to-be-created Aggrigation link.

 

 

Two ways to get around this issue are either:

a) configure the bridge from on a non-bridged port from another workstation.  And then go to Port Management=>Setup=>Link Type=>[choose one]=>Apply

 

b) download the config file, edit it, upload it, reboot.

 

The config file should with working Aggregation looks like this:

 

=== snip ===

stp enable
#
interface Bridge-Aggregation1
port link-type access
link-aggregation mode dynamic
#
interface NULL0

=== ...fold... ===

#
interface GigabitEthernet1/0/47
port link-type hybrid
port hybrid vlan 1 untagged
port auto-power-down
poe enable
stp edged-port enable
port link-aggregation group 1
#
interface GigabitEthernet1/0/48
port link-type hybrid
port hybrid vlan 1 untagged
port auto-power-down
poe enable
stp edged-port enable
port link-aggregation group 1
#

=== /snip ===

 

 

 

 

 

A config file with a broken Aggregation looks like this and contains no "port link-type ..." entry:

=== snip ===

stp mode rstp
stp enable
#
interface Bridge-Aggregation1
link-aggregation mode dynamic
#
interface NULL0

=== /snip ===

 

HP needs to patch the switch so that it defaults to some form of "port link-type" when Aggregation is first enabled.

6 REPLIES
16again
Respected Contributor

Re: HP 1920-48G JG928A Link Aggregation bug

Is this a bug, or is it just bad practice to reconfigure the port(s) on which you're connected with the web gui?

dmonty
Visitor

Re: HP 1920-48G JG928A Link Aggregation bug

Sorry I should have clarified.   I work for a school district with about 50 sites and around 500 ProCurve switches.  Eash site has a centralized server with a bonded trunk for diskless clients.   For many years we have been able to log into the HP switches and create/configure LACP Trunks without having the link completely go offline..   Electritians plug the switch in and call us to configure it off site.   We could do this from the server or a diskless client that runs off the server.

Topology: 

   Internet <=> server/firewall <=> ProCurve Switchs <=> diskless clients

With these new 1920 switches when we created a bond on the server all the diskless clients stoped working plus we lost access from the server to the Procurve Switch so we have no way to configure a bond off-site without taking a long road-trip out of town.  Unless we download the config, edit it by hand, upload it to the switch and reboot the switch.

It would be nice if HP could modify the Link Aggregation behaviour to inherit the link-type that the ports had before they were created as a bond.  Instead of having no link-type and completely loosing access to the switch.   By default the Port view for a new Aggregated port says "Access" but when I download the config it is blank.   New aggrigated port may also want to inherit the port's other settings like vlans etc.

Thanks for you time.

16again
Respected Contributor

Re: HP 1920-48G JG928A Link Aggregation bug

The default link-type is access, and is simply not shown in config file.
Why are you using hybrid port mode to begin with?  Reading the manual, this mode seems pretty useless to me, especially in BAG.
Maybe manually specifying linktype of BAG in config, overrules Gi1/0/47 -  48 hybrid type settings

dmonty
Visitor

Re: HP 1920-48G JG928A Link Aggregation bug

Why are you using hybrid port mode to begin with?

Because I had VLANS on the ports before the initial post and I had removed the vlans while trying to figure out the issue.

Maybe manually specifying linktype of BAG in config, overrules Gi1/0/47 -  48 hybrid type settings

Setting link type to the ports before I create to Aggregated Ports makes no difference.  As newly created Aggregated Ports do not inherit the link-type.   In troubleshooting I tried Access, Hybrid, and Trunk before creating the Aggregated Port.  Tried with and without VLANS.   I even tried resetting the switch to factory default before creating the Aggregated Port.  But as soon as I create an aggregatted port it's default setting for link-type is blank and the port is usless untill I log in from a non-aggregated port and set the link type on BAG to any of the options & Apply.

The current solutions are in the 1st post:

a) use a non-aggregated port to configure the bonded ports.

b) download config, edit, upload, reboot.

 

16again (ADVISOR) :-

  1. Should I just close this posting as there are 2 work-arounds?
  2. Is there another page on the HP site to report bugs so the developers can issue a firmware patch?  It would be nice for future enterprise clients to not waste time trying to hunt-down why their 1920 went offline after creating a bond.

Thank you for your time.

 

Re: HP 1920-48G JG928A Link Aggregation bug

 

>Is there another page on the HPE site to report bugs so the developers can issue a firmware patch?


Have you tried contacting the HPESC?
http://h20565.www2.hpe.com/portal/site/hpsc

16again
Respected Contributor

Re: HP 1920-48G JG928A Link Aggregation bug

Just for fun, I tried recreating your problem , by making a BAG of a single ethernet port.  Port config before:
[HP1920G]display current-configuration interface gi1/0/5
#
interface GigabitEthernet1/0/5
 description Laptop
 port access vlan 331
 port auto-power-down
 stp edged-port enable
 port link-aggregation group 2
#
Indeed I do loose connectivity  when creating BAG in web GUI (on PC no incoming packets in wireshark, not even STP BPDUs).
BAG  config / settings afterwards:

[HP1920G]display current-configuration interface Bridge-Aggregation 2
#
interface Bridge-Aggregation2
#

[HP1920G]display interface Bridge-Aggregation 2
 Bridge-Aggregation2 current state: DOWN
 IP Packet Frame Type: PKTFMT_ETHNT_2, Hardware Address: 5c8a-389f-0998
 Description: Bridge-Aggregation2 Interface
 Unknown-speed mode, unknown-duplex mode
 Link speed type is autonegotiation, link duplex type is autonegotiation
 PVID: 1
 Port link-type: access
  Tagged   VLAN ID : none
  Untagged VLAN ID : 1

Note BAG is DOWN , and it didn't inherit settings from ethernet members.  Port-link type is OK but access VLAN is wrong  (1 instead of 331).
Following command completes BAG config, and restores connectivity.
[HP1920G] interface Bridge-Aggregation 2
[HP1920G-Bridge-Aggregation2]port access vlan 331