Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 1920-8G Switch - System Booting Porblem.

 
mrnetwork
Occasional Visitor

HP 1920-8G Switch - System Booting Porblem.

Hi,

When my switch boots up in some point it shows the following output on the screen.

rv_InternalSetStpPort: call Hal_GetStpPortState fail! Drv_Port_SetMstpStateByInstance: call Drv_InternalSetStpPort(8,25)fail! Drv_Set_MstpPortState: call Drv_Port_SetMstpStateByInstance(7,25,1)fail! Drv_InternalSetStpPort: call Hal_GetStpPortState fail! Drv_Port_SetMstpStateByInstance: call Drv_InternalSetStpPort(8,26)fail! Drv_Set_MstpPortState: call Drv_Port_SetMstpStateByInstance(7,26,1)fail! Drv_InternalSetStpPort: call Hal_GetStpPortState fail! Drv_Port_SetMstpStateByInstance: call Drv_InternalSetStpPort(8,27)fail! Drv_Set_MstpPortState: call Drv_Port_SetMstpStateByInstance(7,27,1)fail! Drv_InternalSetStpPort: call Hal_GetStpPortState fail! Drv_Port_SetMstpStateByInstance: call Drv_InternalSetStpPort(9,0)fail! Drv_Set_MstpPortState: call Drv_Port_SetMstpStateByInstance(8,0,1)fail! Drv_InternalSetStpPort: call Hal_GetStpPortState fail! Drv_Port_SetMstpStateByInstance: call Drv_InternalSetStpPort(9,1)fail! Drv_Set_MstpPortState: call Drv_Port_SetMstpStateByInstance(8,1,1)fail! Drv_InternalSetStpPort: call Hal_GetStpPortState fail! Drv_Port_SetMstpStateByInstance: call Drv_InternalSetStpPort(9,2)fail! Drv_Set_MstpPortState: call Drv_Port_SetMstpStateByInstance(8,2,1)fail! Drv_InternalSetStpPort: call Hal_GetStpPortState fail! Drv_Port_SetMstpStateByInstance: call Drv_InternalSetStpPort(9,3)fail! Drv_Set_MstpPortState: call Drv_Port_SetMstpStateByInstance(8,3,1)fail! Drv_InternalSetStpPort: call Hal_GetStpPortState fail! Drv_Port_SetMstpStateByInstance: call Drv_InternalSetStpPort(9,4)fail! Drv_Set_MstpPortState: call Drv_Port_SetMstpStateByInstance(8,4,1)fail! Drv_InternalSetStpPort: call Hal_GetStpPortState fail! Drv_Port_SetMstpStateByInstance: call Drv_InternalSetStpPort(9,5)fail! Drv_Set_MstpPortState: call Drv_Port_SetMstpStateByInstance(8,5,1)fail! Drv_InternalSetStpPort: call Hal_GetStpPortState fail! Drv_Port_SetMstpStateByInstance: call Drv_InternalSetStpPort(9,6)fail! Drv_Set_MstpPortState: call Drv_Port_SetMstpStateByInstance(8,6,1)fail! Drv_InternalSetStpPort: call Hal_GetStpPortState fail! Drv_Port_SetMstpStateByInstance: call Drv_InternalSetStpPort(9,7)fail! Drv_Set_MstpPortState: call Drv_Port_SetMstpStateByInstance(8,7,1)fail! Drv_InternalSetStpPort: call Hal_GetStpPortState fail! Drv_Port_SetMstpStateByInstance: call Drv_InternalSetStpPort(9,16)fail! Drv_Set_MstpPortState: call Drv_Port_SetMstpStateByInstance(8,16,1)fail! Drv_

I'd like to know which could be the reason for this out put and what could i do about it.

Tks...

6 REPLIES
parnassus
Honored Contributor

Re: HP 1920-8G Switch - System Booting Porblem.

Is your HPE OfficeConnect 1920 Switch (JG920A) able to run correctly or not? it's not clear if those messages are boot warnings only or a signal that something worst happened...do you have access to it via Console? do you reach its Boot Menù? what do you see exactly since you power it on? are you able to manage it through its Web GUI or what? which firmware version was/is it running on?

mrnetwork
Occasional Visitor

Re: HP 1920-8G Switch - System Booting Porblem.

Hi Parnassus,

Answer your first question, not it isn't able to boot correctly. Yes, I can access to it via console cable and i'm able to access to the boot menu. At the begining i thought it was some kind of issue related with the firmware and i tried changing it for other versions (older and later) but i had no good result. 

Bellow you can see the full output i got. 

I hope you could help me.

Press Ctrl+D to access BASIC-BOOTWARE MENU
Booting Normal Extend BootWare
The Extend BootWare is self-decompressing..........................Done!

****************************************************************************
* *
* HPE 1920-24G Switch JG924A BootWare, Version 1.22 *
* *
****************************************************************************
Copyright (c) 2010-2017 Hewlett Packard Enterprise Development LP

Compiled Date : Apr 14 2017 15:05:19
CPU Type : MIPS4kec
CPU L1 Cache : 16KB
CPU Clock Speed : 500MHz
Memory Type : DDR3 SDRAM
Memory Size : 128MB
Memory Speed : 300MHz
BootWare Size : 3MB
Flash Size : 32MB


BootWare Validating...
Press Ctrl+B to enter extended boot menu...
Starting to get the main application file--flash:/JG924A-CMW520-R1107.bin!.
...........................................................................
.................
The main application file is self-decompressing.............................
............................................................................
............................................................................
............................................................................
............................................................................
............................................................................
..................................Done!
System application is starting...
System application is starting...RTK API error = 3, file hal/switch/realtek/rtk_drv_acl_839x.c, line = 3934
Hal_SetAclInit failed rv = 193!
RTK API error = 3, file hal/switch/realtek/rtk_drv_mac.c, line = 561
Hal_SetMacInit failed rv = 193!
Hal_SetIPMCInit failed rv = 193!
RTK API error = 3, file hal/switch/realtek/rtk_drv_vlan.c, line = 146
Hal_SetVlanInit failed rv = 386!
Hal_Dot1xInit failed rv = 386!
RTK API error = 3, file hal/switch/realtek/rtk_drv_ratelimit.c, line = 177
Hal_SetRatelimitInit failed rv = 579!
RTK API error = 3, file hal/switch/realtek/rtk_drv_qos.c, line = 155
Hal_SetQosInit failed rv = 772!
Hal_StpInit failed rv = 772!
Hal_I2cFiberInit failed rv = 772!
Hal_GetBoardIdByGpio failed rv = 772!
Hal_PhyRegInit failed rv = 772!
Hal_StormCtl_Init failed rv = 772!
Hal_SetTrapInit failed rv = 772!
Hal_AggrInit failed rv = 772!
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1918
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 396
) fail!
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651

RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_stp.c, line = 662
Drv_InternalSetStpPort: call Hal_GetStpPortState fail!
Drv_Port_SetMstpStateByInstance: call Drv_InternalSetStpPort(1,5)fail!
Drv_Set_MstpPortState: call Drv_Port_SetMstpStateByInstance(0,5,3)fail!RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_vlan.c, line = 691
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_stp.c, line = 662
Drv_InternalSetStpPort: call Hal_GetStpPortState fail!
Drv_PortSetStpStateInAllInstances: call Drv_InternalSetStpPort(1,5,0) fail!
Drv_STP_BlockPort: call Drv_PortSetStpStateInAllInstances fail!
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1702
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1702
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1702
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1702
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1702
System is starting...
Press Ctrl+D to access BASIC-BOOTWARE MENU
Booting Normal Extend BootWare
The Extend BootWare is self-decompressing..........................Done!

 

Thanks..!

mrnetwork
Occasional Visitor

Re: HP 1920-8G Switch - System Booting Porblem.

Hi Parnassus,

Answer your first question, not it isn't able to boot correctly. Yes, I can access to it via console cable and i'm able to access to the boot menu. At the begining i thought it was some kind of issue related with the firmware and i tried changing it for other versions (older and later) but i had no good result. 

Bellow you can see the full output i got. 

I hope you could help me.

Press Ctrl+D to access BASIC-BOOTWARE MENU
Booting Normal Extend BootWare
The Extend BootWare is self-decompressing..........................Done!

****************************************************************************
* *
* HPE 1920-24G Switch JG924A BootWare, Version 1.22 *
* *
****************************************************************************
Copyright (c) 2010-2017 Hewlett Packard Enterprise Development LP

Compiled Date : Apr 14 2017 15:05:19
CPU Type : MIPS4kec
CPU L1 Cache : 16KB
CPU Clock Speed : 500MHz
Memory Type : DDR3 SDRAM
Memory Size : 128MB
Memory Speed : 300MHz
BootWare Size : 3MB
Flash Size : 32MB


BootWare Validating...
Press Ctrl+B to enter extended boot menu...
Starting to get the main application file--flash:/JG924A-CMW520-R1107.bin!.
...........................................................................
.................
The main application file is self-decompressing.............................
............................................................................
............................................................................
............................................................................
............................................................................
............................................................................
..................................Done!
System application is starting...
System application is starting...RTK API error = 3, file hal/switch/realtek/rtk_drv_acl_839x.c, line = 3934
Hal_SetAclInit failed rv = 193!
RTK API error = 3, file hal/switch/realtek/rtk_drv_mac.c, line = 561
Hal_SetMacInit failed rv = 193!
Hal_SetIPMCInit failed rv = 193!
RTK API error = 3, file hal/switch/realtek/rtk_drv_vlan.c, line = 146
Hal_SetVlanInit failed rv = 386!
Hal_Dot1xInit failed rv = 386!
RTK API error = 3, file hal/switch/realtek/rtk_drv_ratelimit.c, line = 177
Hal_SetRatelimitInit failed rv = 579!
RTK API error = 3, file hal/switch/realtek/rtk_drv_qos.c, line = 155
Hal_SetQosInit failed rv = 772!
Hal_StpInit failed rv = 772!
Hal_I2cFiberInit failed rv = 772!
Hal_GetBoardIdByGpio failed rv = 772!
Hal_PhyRegInit failed rv = 772!
Hal_StormCtl_Init failed rv = 772!
Hal_SetTrapInit failed rv = 772!
Hal_AggrInit failed rv = 772!
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1918
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 396
) fail!
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651

RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_stp.c, line = 662
Drv_InternalSetStpPort: call Hal_GetStpPortState fail!
Drv_Port_SetMstpStateByInstance: call Drv_InternalSetStpPort(1,5)fail!
Drv_Set_MstpPortState: call Drv_Port_SetMstpStateByInstance(0,5,3)fail!RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_vlan.c, line = 691
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1651
RTK API error = 3, file hal/switch/realtek/rtk_drv_stp.c, line = 662
Drv_InternalSetStpPort: call Hal_GetStpPortState fail!
Drv_PortSetStpStateInAllInstances: call Drv_InternalSetStpPort(1,5,0) fail!
Drv_STP_BlockPort: call Drv_PortSetStpStateInAllInstances fail!
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1702
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1702
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1702
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1702
RTK API error = 3, file hal/switch/realtek/rtk_drv_port.c, line = 1702
System is starting...
Press Ctrl+D to access BASIC-BOOTWARE MENU
Booting Normal Extend BootWare
The Extend BootWare is self-decompressing..........................Done!

 

Thanks..!

parnassus
Honored Contributor

Re: HP 1920-8G Switch - System Booting Porblem.

Initially you wrote about 1920-8G...then booting log reports 1920-24G...so is it an 8 or 24 ports HPE OfficeConnect 1920 Switch?
Are you sure you loaded the correct Firmware for the correct Switch SKU (latest release has name R1119)?
Sofyane
Occasional Visitor

Re: HP 1920-8G Switch - System Booting Porblem.

Hello,

i am facing the same issue   ; my switch HP 1920-48G is not able to start correctly . a loop of errors  like :

RTK API error = 3, file hal/switch/realtek/rtk_drv_acl_839x.c, line = 3934

Before installing the lastest fireware 1119 the switch was not able to start and set up the ip for vlan1 to manage it.

So i installed the lasted fireware But after instalation of the lastest fireware 1119 i m still getting the same message errors but after a few messages .i can access to the CLI and setup the ip for vlan 1 but i can not ping this IP from my switch .

any help please

 

Best regards.

Sofyane
Occasional Visitor

Re: HP 1920-8G Switch - System Booting Porblem.

Hello,

After starting the Switch ; i would like to setup the IP ipsetup and manage it from the web.  the command is correct but i m not able to ping the ip and connect to the webinterface .

 

pleqse help