HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 1950-24G (JG960A) Switch - Setting Trunks

 
cgsplus
Frequent Visitor

HP 1950-24G (JG960A) Switch - Setting Trunks

Hi,

I have HP 1950-24G (JG960A) Switch and trying to setup a trunk (Trk3) to match the setup on my core switch.

There is very little on this setup/info.

 

How do I go about doing this?

I like all trunk traffic from core switch to go through an SFT (gibic connection) and onto the 1950 switch on another SFP/gibic connection.  have several VLANs on core I want to trunk throught o my edge switch (1950)

Your advise much appreciate...

Thanks

10 REPLIES
parnassus
Honored Contributor

Re: HP 1950-24G (JG960A) Switch - Setting Trunks

Port Trunking (with the use of LACP or Static) is nothing fancy and nothing was hidden or misterious (there are plenty of posts and very good documentation about it and also about what you want to achieve...which is basically "creating one or more Port Trunks using Copper/SFP+ ports and permitting some/all VLAN to traverse it")...just start reading the HPE OfficeConnect 1950 Switch Series User Guide.

Read the "Network services features" chapter, "Link aggregation" paragraph starting from page 27 and if you need some configuration examples look for "Port Trunking" or "LACP Trunks" here.

As example (maybe not the best and for sure not the only one you will find but, at least, one where I personally did some port trunking practice between HPE OfficeConnect 1920 Switches, very similar to the 1950) can be found here.

cgsplus
Frequent Visitor

Re: HP 1950-24G (JG960A) Switch - Setting Trunks

Thanks parnassus for the advise.
Did you leave a link where you mention port truniking as I cant get to it.

Ive tried a variety of configurations and even exporting cfg and editing in notepad to include the extra trunk commands, but still cant get the SFT/gibics conenctor communiting back to our core switch.

Is anyone able to advise where I am going wrong from the config i pasted below.

thanks

#
version 7.1.045, Release 313P03
#
sysname HP-1950-24G
#
telnet server enable
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
irf member 1 priority 1
#
transceiver phony-alarm-disable
password-recovery enable
#
vlan 1
#
vlan 13
description Servers
#
vlan 14
description PC
#
vlan 15
description Printers
#
interface Bridge-Aggregation1
#
interface Vlan-interface13
ip address 192.168.13.5 255.255.255.0
ip gateway 192.168.13.10
#
interface GigabitEthernet1/0/1
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/2
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/3
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/4
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/5
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/6
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/7
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/8
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/9
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/10
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/11
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/12
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/13
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/14
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/15
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/16
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/17
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/18
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/19
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/20
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/21
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/22
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/23
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface GigabitEthernet1/0/24
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface Ten-GigabitEthernet1/0/25
port link-type trunk
port trunk permit vlan 1
port link-aggregation group 1
#
interface Ten-GigabitEthernet1/0/26
port link-type trunk
port trunk permit vlan 1
port link-aggregation group 1
#
interface Ten-GigabitEthernet1/0/27
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
interface Ten-GigabitEthernet1/0/28
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 13 untagged
port hybrid pvid vlan 13
#
scheduler logfile size 16
#
line class aux
authentication-mode scheme
user-role network-admin
#
line class vty
authentication-mode scheme
user-role network-operator
#
line aux 0
user-role network-admin
#
line vty 0 63
user-role network-operator
#
snmp-agent
snmp-agent local-engineid 800063A2802C233AD411FA00000001
snmp-agent community write private
snmp-agent community read public
snmp-agent sys-info version all
#
domain system
#
domain default enable system
#
role name level-0
description Predefined level-0 role
#
role name level-1
description Predefined level-1 role
#
role name level-2
description Predefined level-2 role
#
role name level-3
description Predefined level-3 role
#
role name level-4
description Predefined level-4 role
#
role name level-5
description Predefined level-5 role
#
role name level-6
description Predefined level-6 role
#
role name level-7
description Predefined level-7 role
#
role name level-8
description Predefined level-8 role
#
role name level-9
description Predefined level-9 role
#
role name level-10
description Predefined level-10 role
#
role name level-11
description Predefined level-11 role
#
role name level-12
description Predefined level-12 role
#
role name level-13
description Predefined level-13 role
#
role name level-14
description Predefined level-14 role
#
user-group system
#
local-user admin class manage
service-type telnet terminal http https
authorization-attribute user-role network-admin
authorization-attribute user-role network-operator
#
ip http enable
ip https enable
#
return




parnassus
Honored Contributor

Re: HP 1950-24G (JG960A) Switch - Setting Trunks

Mmm...your interface Bridge-Aggregation 1 section lacks of some settings (keep in mind that permitted VLANs IDs should be declared on the line port trunk permit vlan). Below I used dynamic (so LACP)...it depends on what is configured on your Core...

#
interface Bridge-Aggregation1
 port link-type trunk
 port trunk permit vlan 1 <add here VLANs IDs you want to permit>
 link-aggregation mode dynamic
#

Then on physical interfaces (Ten Gigabit Ethernet port 1/0/25 and 1/0/26, via SFP+ 10G Transceivers) you want to be binded to the logical interface Bridge-Aggregation1 (group 1) you need:

#
interface Ten-GigabitEthernet1/0/25
 port link-type trunk
 port trunk permit vlan 1 <add here the same VLANs IDs declared above>
 port link-aggregation group 1
#
interface Ten-GigabitEthernet1/0/26
 port link-type trunk
 port trunk permit vlan 1 <add here the same VLANs IDs declared above>
 port link-aggregation group 1
#

But it's really important that you understand and follow the right sequence of commands (especially on Comware based Switches) to deploy the correct configuration: try to read any Comware 7 based Switch manual about Layer 2 (as example, pick up the manual HPE FlexFabric 5700 Switch Series - Layer 2 LAN Switching Configuration Guide), there you will find an entire chapter "Configuring Ethernet link aggregation" with examples on how to correctly configure Link Aggregation on Comware 7,  just follow the sequence.

cgsplus
Frequent Visitor

Re: HP 1950-24G (JG960A) Switch - Setting Trunks

Once again parnassus, thanks for helping with the command structure for 1950 switch.
What I am noticing is the switch does not accept the commands and even if i hard code these itno a startup.cfg file and import into the switch the "interface Bridge-Aggregation1" setup is lost/stripped out.
I lose  the below commmands

port link-type trunk
port trunk permit vlan 1 <add here VLANs IDs you want to permit>
link-aggregation mode dynamic
cgsplus
Frequent Visitor

Re: HP 1950-24G (JG960A) Switch - Setting Trunks

Switch summary:

S/N: CN5BGQ*****
Device type: JG960A

HPE Comware Platform Software
HPE Comware Software, Version 7.1.045, Release 3113P03
Copyright (c) 2010-2016 Hewlett Packard Enterprise Development LP
HPE OfficeConnect 1950-24G-2SFP+-2XGT uptime is 0 weeks, 0 days, 0 hours, 18 minutes
Slot 1:
Uptime is 0 weeks,0 days,0 hours,18 minutes
HPE OfficeConnect 1950-24G-2SFP+-2XGT JG960A with 1 Processor
BOARD TYPE: 1950-24G-2SFP+-2XGT
DRAM: 1024M bytes
FLASH: 512M bytes
PCB 1 Version: VER.D
Bootrom Version: 143
CPLD 1 Version: 001
Release Version: HPE OfficeConnect 1950-24G-2SFP+-2XGT JG960A-3113P03
Patch Version : None
Reboot Cause : UserReboot
[SubSlot 0] 24GE+2SFP-Plus+2XGT
<HP-1950-24G>

parnassus
Honored Contributor

Re: HP 1950-24G (JG960A) Switch - Setting Trunks

What do you mean with "the switch does not accept the commands"?

You shouldn't necessarily operate directly on the configuration file with a text editor!

You should instead start with a "clean" (not borked) Switch configuration (if you can, if it is still clean) and then, via CLI or via Web GUI perform the necessary configuration steps.

I think that Web GUI could be easy enough...but if you like CLI go with the CLI providing that you know how to interact with it (see Appendix A "Managing the device from the CLI" of the PDF manual I linked above).

Note that some commands depend on the user role: if you are in "user view" some commands aren't available...to quote the manual "However, the commands you can use depend on the user roles you have. By default, a command is available for the predefined user roles. You can use the RBAC feature to assign a command to additional user roles from the Web interface." so you first need to verify which role was used to issue those (unaccepted) commands...and then act to use the right user role for the tasks you want to achieve (see page 20 of that manual for RBAC concepts and settings configurable via Web GUI).

cgsplus
Frequent Visitor

Re: HP 1950-24G (JG960A) Switch - Setting Trunks

doing "system-view" after entering #xtd-cli-mode# done the trick on the HP-1950 (JG960A)

parnassus
Honored Contributor

Re: HP 1950-24G (JG960A) Switch - Setting Trunks

Glad you found the magic command that unlocked the door!

P.S. it's valid on every Comware based Switch (Comware 5 and 7).

Mikies
Occasional Contributor

Re: HP 1950-24G (JG960A) Switch - Setting Trunks

How did U enter the xtd-cli-mode ? What was the password ?

 

Mikies

Dunky
Regular Advisor

Re: HP 1950-24G (JG960A) Switch - Setting Trunks

I have 1920's, but I assume its the same if its Comware....

Login via the CLI and proceed as below.

******************************************************************************
* Copyright (c) 2010-2015 Hewlett-Packard Development Company, L.P. *
* Without the owner's prior written consent, *
* no decompiling or reverse-engineering shall be allowed. *
******************************************************************************


Login authentication

 

Username:admin
Password:
<SWITCH-01>_cmdline-mode on
All commands can be displayed and executed. Continue? [Y/N]y
Please input password:**********************         (password is Jinhua1920unauthorized)
Warning: Now you enter an all-command mode for developer's testing, some commands may affect operation by wrong use, please carefully use it with our engineer's direction.
<SWITCH-01>sys
System View: return to User View with Ctrl+Z.
[SWITCH-01]

 

you should now have access to all configuration commands