Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 1950 Switch firmware question

SOLVED
Go to solution
HSO
Visitor

HP 1950 Switch firmware question

We recently purchased two HP 1950 switches.  One of them works fine as expected, but the rest one does not work.

As the switch's ports would not link up, I tried serial console and got strange version notice like this

<boot>display versions

H3C Comware Software

Copyright (c) 2004-2015 Hangzhou H3C Tech. Co, Ltd.  All rights reserved.

H3C S5130 Series Switch uptime is 0 weeks, 0 days, 0 hour, 37 minutes

Boot Image:

Boot image version: 7.1.045

 I also tried another switch which worked fine and this time got HP's CLI messages.  So I think something wrong had happend during the production of our switch but passed HP's QC.

How should I do?  I tried to call support more than 2 hours but they were always busy.

8 REPLIES
parnassus
Honored Contributor

Re: HP 1950 Switch firmware question

Pretty strange if that Switch is really a brand new HPE OfficeConnect 1950 Switch...the H3C S5130 you have is basically the H3C equivalent of the actual HPE OfficeConnect 1950.

SO...on the H3C branded one try this command first:

display brand

then - I hope (just as example read this post, Switch discussed there were differents but I hope the S5130-EI/HI can be rebranded too even if it wasn't listed in the document I linked on that post) - you should be able to change (it's a product rebrand) your Switch branding from the actual H3C brand to the HP brand (then rebranded as HPE since the R3109P14 software version release) with the command:

brand hp

and then issue a Switch reboot command.

After that, once the display brand command finally shows you HP brand, you should then be able to upgrade the Switch's software version to the latest available for the HPE OfficeConnect 1950 Switch series (HPE 1950-CMW710-R3113P05).

HSO
Visitor
Solution

Re: HP 1950 Switch firmware question

The problem is solved.  Our switch was shipped without valid system image in its flash memory.  It is brand new one for I broke the seal by myself.

Is this a defect of flash memory?   Should I ask HPE sales to exchange the switch?

 

While I was watching boot log,  I noticed these messages.  It seemed that our switch could not start for it had invalid system image.  So I downloaded latest firmware image from HPE site to update the firmware.

After loading and writing 1950-cmw710-system-r3113p03.bin, the switch started working as the other one.

 

 

Press Ctrl+B to access EXTENDED BOOT MENU ...

Loading the main image files ...

Loading file flash:/1950-cmw710-system-r3109p05.bin.......................Done.

Image file flash:/1950-cmw710-system-r3109p05.bin is invalid!

Loading the backup image files ...

The image does not exist!

Loading images fails.

 

Michal Doležal
Frequent Advisor

Re: HP 1950 Switch firmware question

Boot-rom with boot-loader files must normally match with switch type.

I think that in factory they possibly/probably made mistake and they preload boot-rom from 5130.

What shows the switch in Boot-rom menu after you succesfully applied 1950 image? Still S5130 boot rom image?

If the image is working now, probably only in factory had some problem and the boot-loader image was not transferred properly.

Michal Dolezal, DiS.
System engineer
AVE BOHEMIA, s.r.o.
Michal Doležal
Frequent Advisor

Re: HP 1950 Switch firmware question

parnassus: he is in boot menu, not in boot-loader image (this is missing)

Factory probably made a mistake and load bad boot-rom image.

brand command is available in userview of Comware switches and normally on Comware 5, but this is 7. And on some devices can cause big problem (routers for example).

But yes, sometimes this can help. I had problem with 5120-24G SI preloaded with H3C brand and from some version was this brand unsupported.

Michal Dolezal, DiS.
System engineer
AVE BOHEMIA, s.r.o.
AdaoT
Occasional Visitor

Re: HP 1950 Switch firmware question

Hello, can you help me, i have the same problem.

How to load and write new Image to the switch (from de console port)?

AdaoT.

HSO
Visitor

Re: HP 1950 Switch firmware question

Yes.  I used XMODEM protocol on serial console line to transfer the image.    I used "Tera Term"  console emulator on Windows which can transfer a file using XMODEM protocol over serial line.

Notice: If you are not familier to XMODEM protocol, you have to aware that the XMODEM over serial console line is  *VERY* slow.  I think it better to start transfer the image when you have enough time to wait.

 

 

Longcrook
Occasional Visitor

Re: HP 1950 Switch firmware question

Hi  

We have had 12 1950s installed at a site for over two years.  Recently there was a major power outage and 5 of the switches are displaying the same image missing error listed by another user in this post

 

Press Ctrl+B to access EXTENDED BOOT MENU ...

Loading the main image files ...

Loading file flash:/1950-cmw710-system-r3109p05.bin.......................Done.

Image file flash:/1950-cmw710-system-r3109p05.bin is invalid!

Loading the backup image files ...

The image does not exist!

Loading images fails.

 

I have tried to upload an .ipe file I downloaded from the HP support page using TeraTerm at 115200 baud but at the end of 3 hours of CCCCCCCCCCCCCCCCCC... the screen just sits there.  Have tried typing wr mem ata that point on 115200, tried changing to 38400 (which switch seemed to defualt to at start) but no response from either.

Anybody know where I am going wrong ?

Regards 

Jimbo33
Occasional Visitor

Re: HP 1950 Switch firmware question

We had the same issue. HOw did you end up sorting it out?