Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

HP V1910-16G doesn't let magic (wake on lan) packets through

mateusz_n
Occasional Visitor

HP V1910-16G doesn't let magic (wake on lan) packets through

Hello,

 

I have HP V1910-16G and I need the WOL functionality. The thing is that this switch doesn't let magic packets through by default. I know that my setup works because I've tested it on different switch and it worked. Since I have to use HP V1910-16G I kindly ask you for assistance as to what settings should I change to let magic packets through this switch.

 

Best Regards

MN

 

 

 

 

P.S.From  Switching > ProCurve / ProVision-Based to Web and Unmanaged. -HP forum moderator

6 REPLIES
Vince_Whirlwind
Trusted Contributor

Re: HP V1910-16G doesn't let magic (wake on lan) packets through

If you are not using the switch as a layer3 switch, disable IP routing.

Alternatively, enable ip directed-broadcast.

 

Let us know how you go.

mateusz_n
Occasional Visitor

Re: HP V1910-16G doesn't let magic (wake on lan) packets through

Hello,

first - thanks for the clue. Unfortunately I cannot check it myself since now I'm few thousand kilometers away from the system in question. What I can do is tell someone on-site to check this for me. This would however require me to give him detailed instructions what to click/select/unselect. I've tried to determine this using the device's manual (http://bizsupport2.austin.hp.com/bc/docs/support/SupportManual/c02965327/c02965327.pdf) but failed miserably. Maybe I wish too much by expecting a simple checkbox "become a simple stupid switch that doesn't do anything fancy". In the "Configuring IPv4 and IPv6 routing" section I can find all there is about setting up the routes but no mention about disabling the routing altogether. And same goes for the second option.

So if - by any chance - you knew how to actually disable the IP routing on that switch I could tell the person onsite to check it in the matter of days. Otherwise I would have to figure it out when I'm there which will be in 2-3 months.

Best regards

MN

mateusz_n
Occasional Visitor

Re: HP V1910-16G doesn't let magic (wake on lan) packets through

Hello again,

 

I've managed to solve this problem after all. Since it may be of interest to others here's what I did:

 

To make sure that WOL packets go through the switch you have to set up static ARP Table. This way switch will know which port has what MAC connected and as a result it will forward WOL packets to that port even if there is no working machine on the other end. I have tested this on brand new switch and proven that it works.

 

Regards

MN

Marko_MSI
Advisor

Re: HP V1910-16G doesn't let magic (wake on lan) packets through

Hello.

Is there any other way to direct broadcast to specified port ?  ARP Management does not work at me.

Regards,

Marko

 

16again
Respected Contributor

Re: HP V1910-16G doesn't let magic (wake on lan) packets through

imho, if a switch does not have a MAC address in its table, it should sent out the packet for that MAC address to all its ports  (except the port it was received on)

Moreover, the sample packet https://wiki.wireshark.org/SampleCaptures?action=AttachFile&do=get&target=wol.pcap  from https://wiki.wireshark.org/SampleCaptures is sent to the broadcast address of ff:ff:ff:ff:ff:ff , not to the  MAC address it's trying to wake up.

Network-Error
Occasional Visitor

Re: HP V1910-16G doesn't let magic (wake on lan) packets through

Use the CLI to enable 'ip forward-broadcast'

Telnet/ssh to the switch and log in. 

Type command '_cmdline-mode on'. Press 'y' to continue, the password is '512900'.

Type command 'system-view'.

Type command 'ip forward-broadcast'.

Type comand 'save'.