HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

HP1920 24G Error: Not enough Hardware Resource when applying QOS

 
farbschmelz
Occasional Collector

HP1920 24G Error: Not enough Hardware Resource when applying QOS

Hi,

maybe someone can help me with this error (or my configuration). This is my VLAN configuration on my Switch at the moment:

ID1 (default)
ID101    data              192.168.1.x
ID102    phone          192.168.2.x
ID103   quest-wlan   192.168.3.x
ID104   byod-wlan    192.168.4.x

I do have a DHCP-Server in VLAN101 with 4 Scopes for the 4 different Subnets. The Switch is working as the DHCP Relay and everything was fine so far. Because I wanted to prevent the switch to route between the Subnets (only DHCP-relay) I tried to manage this with ACLs (which is sort of a pain on this switch ...). But, after creating 1 ACL+Classifier+.... and assigning it to only one port for testing purposes (which worked) the switch cant assign the rule to more ports (Not Enough Hardware Resource ...). 

Maybe a misconfiguration on my side? Thanks in advance!

This is the configuration file:

#
 version 5.20.99, Release 1114
#
 sysname HP_1920GPoE_Switch
#
 clock timezone Amsterdam add 01:00:00 
#
 dhcp relay server-group 1 ip 192.168.1.11
#
 domain default enable system 
#
 ipv6
#
 loopback-detection enable
#
 password-recovery enable
#
 time-range Forever from 00:00 1/1/1970 to 24:00 12/31/2100 
#
acl number 3000
 rule 0 deny ip source 192.168.2.0 0.0.0.255 destination 192.168.1.0 0.0.0.255 time-range Forever 
 rule 5 deny ip source 192.168.2.0 0.0.0.255 destination 192.168.3.0 0.0.0.255 time-range Forever 
 rule 10 deny ip source 192.168.2.0 0.0.0.255 destination 192.168.4.0 0.0.0.255 time-range Forever 
#
vlan 1
 description default
#
vlan 101
 description data
#
vlan 102
 description phone
#
vlan 103
 description guest-wlan
#
vlan 104
 description byod-wlan
#
vlan 105
 description wantransit
#
domain system 
 access-limit disable 
 state active 
 idle-cut disable 
 self-service-url disable 
#
traffic classifier IP102 operator and
 if-match customer-vlan-id 102 
 if-match acl 3000
#
traffic behavior Deny
 filter deny
#
qos policy IP102
 classifier IP102 behavior Deny
#
user-group system
 group-attribute allow-guest
#
local-user admin
 password cipher XXXX
 authorization-attribute level 3
 authorization-attribute vlan 1
 service-type telnet terminal
 service-type web
#
 stp mode rstp
 stp enable
#
interface Bridge-Aggregation1
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 101
#
interface Bridge-Aggregation2
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 101
#
interface Bridge-Aggregation3
 port access vlan 101
 link-aggregation mode dynamic
 dhcp-snooping trust
 dhcp-snooping information enable
#
interface NULL0
#
interface Vlan-interface1
 ip address 192.168.100.11 255.255.255.0 
#
interface Vlan-interface101
 ip address 192.168.1.1 255.255.255.0 
 dhcp select relay
 dhcp relay server-select 1
#
interface Vlan-interface102
 ip address 192.168.2.1 255.255.255.0 
 dhcp select relay
 dhcp relay server-select 1
#
interface Vlan-interface103
 ip address 192.168.3.1 255.255.255.0 
 dhcp select relay
 dhcp relay server-select 1
#
interface Vlan-interface104
 ip address 192.168.4.1 255.255.255.0 
 dhcp select relay
 dhcp relay server-select 1
#
interface Vlan-interface105
 ip address 192.168.5.11 255.255.255.0 
 dhcp select relay
 dhcp relay server-select 1
#
interface GigabitEthernet1/0/1
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 101
 port auto-power-down
 stp edged-port enable
 port link-aggregation group 1
#
interface GigabitEthernet1/0/2
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 101
 port auto-power-down
 stp edged-port enable
 port link-aggregation group 1
#
interface GigabitEthernet1/0/3
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 101
 port auto-power-down
 stp edged-port enable
 port link-aggregation group 2
#
interface GigabitEthernet1/0/4
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 101
 port auto-power-down
 stp edged-port enable
 port link-aggregation group 2
#
interface GigabitEthernet1/0/5
 port access vlan 105
 port auto-power-down
 stp edged-port enable
#
interface GigabitEthernet1/0/6
 port link-type hybrid
 undo port hybrid vlan 1
 port hybrid vlan 101 103 to 104 tagged
 port hybrid pvid vlan 101
 port auto-power-down
 poe enable
 stp edged-port enable
#
interface GigabitEthernet1/0/7
 port access vlan 102
 port auto-power-down
 stp edged-port enable
#
interface GigabitEthernet1/0/8
 port link-type hybrid
 undo port hybrid vlan 1
 port hybrid vlan 101 103 to 104 tagged
 port hybrid pvid vlan 101
 port auto-power-down
 poe enable
 stp edged-port enable
#
interface GigabitEthernet1/0/9
 port access vlan 102
 port auto-power-down
 poe enable
 stp edged-port enable
#
interface GigabitEthernet1/0/10
 port access vlan 102
 port auto-power-down
 poe enable
 stp edged-port enable
#
interface GigabitEthernet1/0/11
 port access vlan 102
 port auto-power-down
 poe enable
 stp edged-port enable
#
interface GigabitEthernet1/0/12
 port access vlan 102
 port auto-power-down
 poe enable
 stp edged-port enable
#
interface GigabitEthernet1/0/13
 port access vlan 102
 port auto-power-down
 poe enable
 stp edged-port enable
#
interface GigabitEthernet1/0/14
 port access vlan 102
 port auto-power-down
 poe enable
 stp edged-port enable
#
interface GigabitEthernet1/0/15
 port access vlan 102
 port auto-power-down
 poe enable
 stp edged-port enable
#
interface GigabitEthernet1/0/16
 port access vlan 102
 port auto-power-down
 poe enable
 stp edged-port enable
#
interface GigabitEthernet1/0/17
 port access vlan 102
 port auto-power-down
 poe enable
 stp edged-port enable
 qos apply policy IP102 inbound
 qos apply policy IP102 outbound
#
interface GigabitEthernet1/0/18
 port access vlan 102
 port auto-power-down
 poe enable
 stp edged-port enable
#
interface GigabitEthernet1/0/19
 port access vlan 102
 port auto-power-down
 poe enable
 stp edged-port enable
#
interface GigabitEthernet1/0/20
 port access vlan 102
 port auto-power-down
 poe enable
 stp edged-port enable
#
interface GigabitEthernet1/0/21
 port access vlan 101
 port auto-power-down
 stp edged-port enable
 port link-aggregation group 3
 dhcp-snooping trust
 dhcp-snooping information enable
#
interface GigabitEthernet1/0/22
 port access vlan 101
 port auto-power-down
 stp edged-port enable
 port link-aggregation group 3
 dhcp-snooping trust
 dhcp-snooping information enable
#
interface GigabitEthernet1/0/23
 port access vlan 101
 port auto-power-down
 poe enable
 stp edged-port enable
#
interface GigabitEthernet1/0/24
 port auto-power-down
 stp edged-port enable
#
interface GigabitEthernet1/0/25
 stp edged-port enable
#
interface GigabitEthernet1/0/26
 stp edged-port enable
#
interface GigabitEthernet1/0/27
 stp edged-port enable
#
interface GigabitEthernet1/0/28
 stp edged-port enable
#
 ip route-static 0.0.0.0 0.0.0.0 192.168.5.1 preference 10
#
 snmp-agent
 snmp-agent local-engineid 383030303633413236353133424345414641324431434531
 snmp-agent sys-info contact Matthias
 snmp-agent sys-info location OG
 snmp-agent sys-info version v3
#
 dhcp enable 
#
 ntp-service unicast-server 216.239.35.0
 ntp-service unicast-server 216.239.35.4
#
 load xml-configuration 
#
user-interface aux 0
 authentication-mode scheme
user-interface vty 0 15
 authentication-mode scheme
#
return
3 REPLIES
Vince-Whirlwind
Honored Contributor

Re: HP1920 24G Error: Not enough Hardware Resource when applying QOS

Take it off the port and assign it to the VLAN interface instead?

farbschmelz
Occasional Collector

Re: HP1920 24G Error: Not enough Hardware Resource when applying QOS

Hi Vince,

as much as I know (have searched the manual) it istn possible to assign QOS to a VLAN interface on this Switch :(  Or do I miss something?

LG
Farbschmelz

farbschmelz
Occasional Collector

Re: HP1920 24G Error: Not enough Hardware Resource when applying QOS

Small info for others facing the same problem: using the port policy inbound instead of outbound solves the problem.