Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

HPE 1920s-24 Firmware 2.06 bug

 
deadpanda
Occasional Advisor

HPE 1920s-24 Firmware 2.06 bug

Hi everyone! 

It looks like I found a bug in new firmware for the switch JL381A. 

When I enable https admin mode and disable http, I`m loosing management connect to the switch. Probably the problem depends to the cookie "secure" attribute.

Please take a look. 

Firmware PD.02.06.stk

Thanks in advance! 

 

PS certificate self-signed. 

 

The cookies:

Set-Cookie: RID=***replaced***; Path=/; HttpOnly; max-age=30 

are missing the "secure" attribute.

 

9 REPLIES 9
network_king
HPE Pro

Re: HPE 1920s-24 Firmware 2.06 bug

can let us know the steps followed by you along with a screenshots

I am an HPE Employee

Accept or Kudo

deadpanda
Occasional Advisor

Re: HPE 1920s-24 Firmware 2.06 bug

Hi! 

 

Yes, sure. 

1) Enable HTTPS

https://drive.google.com/file/d/1ovvXCvm5Z124wdLHnmmqSvr-j_jRMPft

2) Disable HTTP

https://drive.google.com/open?id=1y66piHp6W8JDJVzgUhZqwJnd2j5e71d9

3) The webface is innaccessible via https = lost the management. 

https://drive.google.com/open?id=18E9O87IddjcKfsh1RaaxNYKm8DRUYx8q

 

Please write me back if it`s not clear. 

Regards

 

shaavik
Occasional Visitor

Re: HPE 1920s-24 Firmware 2.06 bug

I came here to report the same thing. On a fresh switch straight out of the box. Upgraded to 2.05. Everything works fine. Upgrade to 2.06 and HTTPS breaks as soon as you disable HTTP. Unfortunately, I have 5 switches at other branches that I can't configure now (although SNMP still works). I'm hoping someone will post a way to roll back to the backup firmware without wiping the config.

deadpanda
Occasional Advisor

Re: HPE 1920s-24 Firmware 2.06 bug

Hi @network_king! :) what can you say? Do you succeed to reproduce this bug?

BTW I`ve tried to update 1820-48g with same version of the firmware with http disabled in configuration and after update I`ve lost the management to the switch, so I had to do factory reset.... When the version 2.07 will be released?

Regards

deadpanda
Occasional Advisor

Re: HPE 1920s-24 Firmware 2.06 bug

up

deadpanda
Occasional Advisor

Re: HPE 1920s-24 Firmware 2.06 bug

up

deadpanda
Occasional Advisor

Re: HPE 1920s-24 Firmware 2.06 bug

UP

shaavik
Occasional Visitor

Re: HPE 1920s-24 Firmware 2.06 bug

It looks like PD.02.08 was released in December. I believe I've verified that it works, but I haven't had time to update our production switches yet. I don't know why it doesn't show on the office connect page (http://h17007.www1.hpe.com/OfficeConnect/?SKU=JL385A) but I was able to find it by doing a search by product number (https://h10145.www1.hpe.com/downloads/SoftwareReleases.aspx?ProductNumber=JL385A).

 

Newbs
Occasional Visitor

Re: HPE 1920s-24 Firmware 2.06 bug

I have run into this problem upgrading from 1.08 to 2.06. I have tried the newest 2.08 and it is not fixing the issue. I have tried to go back to 2.05 and still having the issue. If I switch to secondary backup image with 1.08 I am fine. Any additional info on this. Right now I cannot get any 2.xx version to work on https...