Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

Having trouble flashing 1810G-24 with latest firmware

Ryan Braun
Occasional Visitor

Having trouble flashing 1810G-24 with latest firmware

I'm kind of worried I might have bricked 2 of my 1810G switches.

I was having all sorts of browser issues trying to upload 1.17 to the switch. In the logs were some messages about the file may not exist and another cryptic one. I didn't have them sending the messages to my syslog server, so they weren't saved :( Also, during the upload, alot of the time while sending the firmware to the switch, it would just dump me back at the login screen with no errors or rebooting of the switch.

I've tried various browser combinations and had the same problems, firefox/chrome/konqueror on linux, ie6 on XP all had various issues when uploading the firmware. Sometimes the dialog box when clicking on upload wouldn't come up, sometimes it would.

I finally got it to flash when I took the switch off the network, found a windows xp laptop with ie8, and just had the laptop plugged into the switch. I was able to flash the last 6 of my switches this way, but 2 of them seem to be psuedo-bricked.

Now when I try to upgrade them (always to the backup image first) it will start uploading, then the switch will reboot about 6 seconds into the process.

I did notice on the dual image status page, that there is no version listed for image1. So I'm not sure how, but it seems like image1 is corrupted.

I've tried resetting back to factory defaults, on the switch status page, it happily reports running version 1.6, but still on the dual image status window, there is no version listed for image1 or 2.

The weird thing is I can configure and go through the menus without problem, so I'm not sure if the image is borked or not.

Anyone have any ideas?

 

 

P.S. This thread has been moved from Switches, Hubs, Modems (Legacy ITRC forum) to Web and Unmanaged. - Hp Forum Moderator

1 REPLY
Michael_Neuffer
Occasional Visitor

Re: Having trouble flashing 1810G-24 with latest firmware

My problem is very similar, only worse...

For neither image there is any information on the dual image status page.

Updates via http to both active and backup image fail

The update to the backup image never finishes and the one to the active image simply doesn't do anything.....

 

It was this way from the start when I bought the switch.

I tried with Firefox, Opera  and internet Explorer with Linux and Windows XP/Vista.

No combination worked.

 

Since the switch boots so far it wasn't a priority for me to get it fixed but maybe I should have returned it immediately.