HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

IP Phone not working on HP 1920 switch

 
Ali-Asim
Occasional Collector

IP Phone not working on HP 1920 switch

Hello

We have HP 1920 (JG924A) switch at remote location. Having only 1 VLAN (Default VLAN - 1). All ports are access ports. Switch HP 1920 is connected with another uplink switch HP E-3800 that too has only 1 VLAN (Default VLAN-1) all ports are untagged in VLAN 1. That switch HP e-3800 is uplink with Cisco router.

There are PC / workstations , printers, IP Phones. All of them working fine on HP-E3800.

But IP Phones are not working on HP-1920. Able to ping the IP phone but service is not working. When shifting IP Phone to HP E-3800 it works fine.

Help needed.

4 REPLIES
parnassus
Honored Contributor

Re: IP Phone not working on HP 1920 switch

Can you share port(s) configurations used at both ends (HPE OfficeConnect 1920 and HPE 3800) to form the uplink?

Ali-Asim
Occasional Collector

Re: IP Phone not working on HP 1920 switch

 

Switch HPE-3800

Running configuration:

; J9585A Configuration Editor; Created on release #KA.15.03.3015
; Ver #01:00:01

hostname "HP-E3800"
module 1 type J9585x
interface 25
name "Uplink_to_HP-1920"
exit
interface 26
name "UPLINK_TO_ROUTER"
exit
ip default-gateway x.x.x.x
vlan 1
name "DEFAULT_VLAN"
untagged 1-26
ip address x.x.x.x y.y.y.y
exit
telnet-server listen data
web-management listen data
ip ssh listen data
snmp-server community "abc123" operator
snmp-server listen data
spanning-tree
oobm
disable
no ip address
exit
tftp server listen data
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager
password operator

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
***************************************************************
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

Switch HP-1920


#
version 5.20.99, Release 1108
#
sysname HP1920
#
domain default enable system
#
ipv6
#
telnet server enable
#
password-recovery enable
#
vlan 1
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
group-attribute allow-guest
#
local-user abc123
password cipher 
authorization-attribute level 3
service-type ssh telnet terminal
service-type web
#
stp mode rstp
stp enable
#
interface NULL0
#
interface Vlan-interface1
ip address x.x.x.x y.y.y.y
#
interface GigabitEthernet1/0/1
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/2
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/3
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/4
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/5
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/6
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/7
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/8
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/9
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/10
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/11
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/12
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/13
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/14
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/15
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/16
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/17
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/18
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/19
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/20
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/21
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/22
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/23
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/24
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/25
stp edged-port enable
#
interface GigabitEthernet1/0/26
stp edged-port enable
#
interface GigabitEthernet1/0/27
stp edged-port enable
#
interface GigabitEthernet1/0/28
stp edged-port enable
#
ip route-static 0.0.0.0 0.0.0.0 x.x.x.x
#
undo info-center logfile enable
#
snmp-agent
snmp-agent local-engineid ?????
snmp-agent community read abc123
snmp-agent sys-info location
snmp-agent sys-info version v3
snmp-agent target-host trap address udp-domain x.x.x.x params securityname abc123 v2c
snmp-agent trap enable default-route
#
load xml-configuration
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 15
authentication-mode scheme
#
return

parnassus
Honored Contributor

Re: IP Phone not working on HP 1920 switch

Mmmm...from configuration file the HPE 3800-24G-2SFP+ Switch (J9585A) physical port 25 (it's the first 10GbE port of two, is it right?)  is used as uplink port to the HPE OfficeConnect 1920-24G switch...but on this latter one what port was used as uplink terminating port?

I ask because HPE OfficeConnect 1920 Switch Series hasn't 10GbE Ports (Ports and Slots are for 1GbE at maximum) so you were forced to use, on both ends, physical ports running at Gigabit Ethernet speed only at best (that's mandatory on the HPE 1920 side). Is that right?

Question: 10GbE Port 25 and 26 on HPE 3800 can go at 1GbE? in other terms do those ports admit 1GbE/10GbE operation or only 10GbE?

Have you set both uplink end ports with "Port Type" of type "Trunk" instead of type "Access" permitting VLAN Id 1 to pass? I ask because HPE 3800 Port 25 and HPE 1920 Port x are uplinked so Port Type should be set of type "Trunk" (at least this is the nomenclature and port settings that is recommended on HPE 1920 side, since it is a Comware 5.20 operating system based Switch).

On HPE 1920 consult User Guide to see how to set the port used as uplink to HPE 3800 of type "Trunk" permitting VLAN Id 1 (VLAN Id 1 is default untagged on all ports so it should be very simple as changing type "Access" to type "Trunk" for the "Port Type" on the port considered for the uplink).

The HPE 3800 is ProVision operating system based and uses another type of nomenclature to define an uplink port to another switch, generally it is sufficient to configure the VLAN Id 1 to be untagged on the physical port you will use to uplink to another switch (eventually specifiying other tagged VLAN Ids that uplink port would let to flow):

HPE3800(config)#vlan 1
HPE3800(config-vlan)#untagged 25

Then consider to update both Firmware images (R1108 of HPE 1920 is quite old, latest is R1117 or eventually R1116 | KA.15.03.3015 ...what? is that correct? looking here no KA.15.03.3015 was listed so, probably, it is older than the oldest liste which is KA.15.09.0009...by the way latest software release for 16.04 Software Branch of KA Product Line is actually the recent KA.16.04.0008...so, if I were you, I would pay a close attention to my Switch(es) firmware(es) before trying or doing other configurations).

You should configure your uplink between HPE 3800 and HPE 1920 as described here

Ali-Asim
Occasional Collector

Re: IP Phone not working on HP 1920 switch

Hi parnassus

Thanks for the detailed response, further to this issue i would like to add same issue observed at another location, same alcatel model ip phone working on HP E3800, but no working on HP 1920.

This time Cisco router ISR4000 series connected with 1 gbps port of HP E 3800 switch, from HP E 3800 1Gbps port connected with HP 1920 (No 10Gbps port used here).

On HP 3800 - only VLAN 1 - all ports untagged in VLAN 1

On HP 1920 - only VLAN 1 - all ports untagged in VLAN 1.

In the web gui of HP 1920 switch under network tab there is "Voice VLAN" option. What is that ?