Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

Remove port from default VLAN

KITS
Occasional Collector

Remove port from default VLAN

Hi there,

i have a Problem with VLAN-Config on a Switch 1950-48.

I will seperate some Port from the default VLAN but in the WEB-GUI it is not possible or i can´t found the config option.

1 have configured Port 1-4 as Untagged VLAN 4(192.168.34.0/24) and TAGGED VLAN 7(192.168.37.0/24)

In untagged VLAN 4 is a DHCP-Server running, also in DEFAULT VLAN 1. if i connect to a untagged Port with vlan4, sometimes the DHCP-Server from VLAN 1 is answering that is one reason why i want to remove port 1-4 from default vlan(or switch to tagged), but i dont know how.

Is there anybody who can give me an advice ?

regards to the hpworld
Thomas

3 REPLIES
Vince-Whirlwind
Honored Contributor

Re: Remove port from default VLAN

On the DHCP Service page, under Advanced Configuration, you can disable DHCP Relay.

If your DHCP server in VLAN1 is responding to DHCP requests in VLAN4, then,
either,
DHCP relay is enabled on VLAN4
or,
DHCP Server in VLAN1 is patched to a switchport that is untagged in VLAN1 and tagged in VLAN4

KITS
Occasional Collector

Re: Remove port from default VLAN

Halo Vince,

thanks for your reply.
The DHCP-Server of this device is disabled. Do you mean i have to enable it and configure as DHCP-Relay ?

I would prefer to leave DHCP disabled and remove this Port from VLAN, if it is possible...

Would remove from config-file work ?
    interface GigabitEthernet1/0/1
    port link-type hybrid
    port hybrid vlan 1 4 untagged (remove the 1,copy config to switch and reboot?)

 

Vince-Whirlwind
Honored Contributor

Re: Remove port from default VLAN

I have seen that 3COM switches allow multiple untagged VLANs on the same port - this makes no sense to me, and any other vendor would tell you you can't do it.

You should only ever have a maximum of 1 VLAN untagged on any switchport.

I'd get rid of the "hybrid" setting - that could be the cause of the confusion. Change it to trunk.