HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

Split 1910 in two switches using untagged VLANs

 
SOLVED
Go to solution

Split 1910 in two switches using untagged VLANs

Hi everybody.

 

I have a 1910-24 port switch.

 

I need to "split" ports using untagged vlans to use ports as they were in different switches.

(port 1-24 - port 25-48)

 

My idea was to assign ports to two different untagged vlans. So i created two vlans and assigned them to the relative ports.

 

But only one of the two vlan is working fine. The other "half" of the switch doesn't work (i cannot get IP connectivity on those ports...)

What am I missing?

 

Nick

 

 

P.S. This thread has been moved from Switches, Hubs, Modems (Legacy ITRC forum) to Web and Unmanaged. - Hp Forum Moderator

4 REPLIES
EricAtHP
Esteemed Contributor

Re: Split 1910 in two switches using untagged VLANs

When you seperate the swtich into two VLANs, you have created two logical switches that are not connected to each other. You need a router to be able to communicate between them. I assume that only one VLAN has a connection to your internet router. 

Re: Split 1910 in two switches using untagged VLANs

Thank you Eric for your answer. I think I must have written the question in a bad way (be patient for my english, I'm italian), because that's not my problem. I don't need to communicate beetween the two VLAN. Each of them has its own default gw.

 

Simply the second vlan I created seems to doesn't work.

(i can't ping neither hosts inside the same subnet...)

 

I'll try to draw my config using characters...

 

------------------------  --> untagged port 1 ------->    --------------- vlan 20
CORE SWITCH     |                                                | HP 1910   |
------------------------   --> untagged port 2 ------->  ----------------  vlan 10

- Links on the core switch are two untagged ports, that goes one to 1910 port 1, the other to 1910 port 24.

 

 

I need to configure 1910 ports as follows:

- port 1 to 12    as they were one logical switch (vlan 10 - hosts on subnet 192.168.10.0/24)

- port 13 to 24 as they were another logical switch (vlan 20 - hosts on subnet 192.168.20.0/24)

 

Everyone of the two networks has its dedicated link from the core switch, and its default gw.

 

At the moment, the 1910 is simply configured with 2 untagged vlans:

port 1 to 12: untagged vlan 10

port 13 to 24: untagged vlan 20

 

but I can't ping beetween hosts on vlan 20. It seems that the vlan port assignment is not working fine.

 

How can I configure 1910 to do that?

 

Thanks,

Nick

EricAtHP
Esteemed Contributor
Solution

Re: Split 1910 in two switches using untagged VLANs

Here are the steps that I followed on my 1920. They should be very similar if not exactly the same for your 1910.

  1. From factory defaults, access the web interface. These switches are only web managed except for initial setup. I used port 23 for management access.
  2. Go to Network - VLAN - Create tab and create VLANs 10 and 20.
  3. Go to Network - VLAN Interface - Create and create an interface for one or both VLANs. For my test, I created a DHCP interface for both VLANs. If you don't have access to your DHCP server, configure an appropriate IP address.
  4. Go to Network - VLAN - Select VLAN tab and click the Select button to display all VLANs (1,10,20).
  5. Go to the Modify VLAN tab, select VLAN 10 from the dropdown box, click the Untagged radio button, click on ports 1-12 on the picture, and click Apply. You should see a popup showing the configuration taking place.
  6. Move your management cable to VLAN 10 and access the switch management with its VLAN 10 ip address.
  7. Repeat steps 4 and 5 for VLAN 20.


I have attached a picture of what my VLAN - Select VLAN tab looks like after config.

 

Capture.PNG

This all assumes that the ports connecting to your core switch are untagged in the appropriate VLANs.

If this doesn't help, can you share the config of the core switch?

Re: Split 1910 in two switches using untagged VLANs

Thank you so much Eric!

Everything was correct, but I had to create one VLAN Interface for each VLAN

Before, I had only an Interface on VLAN 10, with a fixed IP, used to manage the switch.

I create also an interface on VLAN 20, with no IP address. (I don't want to reach sw management from that subnet)

 

... and now everything is working fine!

 

Thanks!

Nick