HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to download V1900_5.20.R1108

 
highpeaktech
Occasional Visitor

Unable to download V1900_5.20.R1108

Currently unable to download V1900_5.20.R1108 on HP Support site.....

 

An annoying message stating the Download Service is unavailable is driving me insane!

 

Does anyone have this or can anyone point me to a working download?

 

https://h10145.www1.hp.com/Downloads/SoftwareReleases.aspx?ProductNumber=JE005A&lang=en&cc=us&prodSeriesId=4218346 doesn't work :-(

2 REPLIES
WantFTPaccess
Occasional Visitor

Re: Unable to download V1900_5.20.R1108

Same problem here. I submitted a ticket with HP support last Friday but they said to just try again later. 4 days later it still doesn't work. They said they didn't have access either, which is kind of ridiculous if they think they're going to be a software rather than HW company. You should probably call in and create your own ticket on this too if you haven't.

ryan_e
Occasional Contributor

Re: Unable to download V1900_5.20.R1108

Looks like the link works now, were you able to get the file?