Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

V1910-48G - LACP on SFP ports not working

SOLVED
Go to solution
Motz
Occasional Contributor

V1910-48G - LACP on SFP ports not working

Hi guys,

 

I'm new here so please bare with me :o)

 

I just got 2 HP V1910 switches and I want to make a LAG (LACP) between them. I brought 4 HP X121 LC SX Transceivers and got som OM3 fiber panels mounted on each site. If I connect 1 cable and make a single connection between the switches everything works like a charm and the switches exchange data with each other.

 

I've have been trying to make a LACP (dynamic) configuration on the switches to boost the uplink between them but when I type in my last command the CLI just throws an error and I can't get the LAG/Trunk online.

SW1 already got a LACP dynamic trunk configured just using 2 ethernet ports and they are connected to a Synolygy DS-412+. This configuration works just fine and I have used the commands from the configuration to try and make a configuration on the SFP ports.

 

See my commands:

 

interface Bridge-Aggregation 2
description LACP_link_to_HPSKUNK
link-aggregation mode dynamic
quit

 

interface g1/0/49
port link-aggregation group 2
quit

 

interface g1/0/50
port link-aggregation group 2
quit

 

interface Bridge-Aggregation 2
port link-type trunk <--- This commands fails and just tells that the configuration couldn't complete (The specific error isn't available right now as the switches are run i production and when I play around with them the link goes down...)

 

So my questions are:
Can the V1910 do a LACP Dynamic on the SFP ports?
Can the V1910 do a LACP Static on the SFP ports?
Can I in some way make both switches use my 2 fiber connections to boost the uplink between them?

Should the type of my SFP ports be access instead?

 

I hope some of you guys can point me in the right direction regarding my issue with the switches.

 

I've 5 vlans: 1,10,20,30,40. They are working just fine, my networks can communicate with each other and travel across the switches without issues.

 

The config for both switches comes her:

 

###SW1###

#
version 5.20, Release 1513P85
#
sysname HP-V1910-Skunk
#
domain default enable system
#
telnet server enable
#
ip ttl-expires enable
#
password-recovery enable
#
vlan 1
description Management
#
vlan 10
description Server
#
vlan 20
description Client
#
vlan 30
description WIFI
#
vlan 40
description WIFI-GUEST
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
#
local-user admin
authorization-attribute level 3
service-type ssh telnet terminal
service-type web
#
stp mode rstp
stp enable
#
interface NULL0
#
interface Vlan-interface1
ip address 10.203.5.3 255.255.255.0
#
interface GigabitEthernet1/0/1
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/2
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/3
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/4
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/5
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/6
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/7
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/8
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 10 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/9
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/10
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/11
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/12
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/13
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/14
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 20 untagged
port hybrid pvid vlan 20
stp edged-port enable
#
interface GigabitEthernet1/0/15
stp edged-port enable
#
interface GigabitEthernet1/0/16
stp edged-port enable
#
interface GigabitEthernet1/0/17
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/18
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/19
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/20
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/21
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/22
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/23
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/24
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/25
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/26
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/27
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/28
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/29
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/30
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/31
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/32
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/33
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/34
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/35
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/36
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/37
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/38
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/39
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/40
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/41
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/42
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/43
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/44
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/45
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/46
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/47
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/48
port link-type hybrid
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/49
port link-type hybrid
port hybrid vlan 10 20 30 40 tagged
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/50
port link-type hybrid
port hybrid vlan 10 20 30 40 tagged
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/51
port link-type hybrid
port hybrid vlan 10 20 30 40 tagged
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/52
port link-type hybrid
port hybrid vlan 10 20 30 40 tagged
port hybrid vlan 1 untagged
stp edged-port enable
#
ip route-static 0.0.0.0 0.0.0.0 Vlan-interface1 10.203.5.2
#
snmp-agent
snmp-agent local-engineid 8000000B03CC3E5FE3F6F2
snmp-agent sys-info contact motz
snmp-agent sys-info location skunk
snmp-agent sys-info version v3
#
dhcp enable
#
ssh server enable
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 15
authentication-mode scheme
#
return


###SW2###

#
version 5.20, Release 1513P85
#
sysname HP
#
dhcp relay server-group 1 ip 10.203.10.11
#
domain default enable system
#
undo ipv6
#
telnet server enable
#
ip ttl-expires enable
#
password-recovery enable
#
acl number 3001
rule 0 deny ip source 10.203.40.0 0 destination 10.203.10.0 0
#
vlan 1
#
vlan 10
description Server
name VLAN_10
#
vlan 20
description Clients
name VLAN_20
#
vlan 30
description Clients_Wifi
name VLAN_30
#
vlan 40
description Clients_Wifi
name VLAN_40
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
traffic classifier vlan40_2_vlan10 operator and
if-match acl 3001
#
traffic behavior deny_stats_2
filter deny
#
qos policy vlan40_acl_vlan10
classifier vlan40_2_vlan10 behavior deny_stats_2
#
user-group system
#
local-user admin
authorization-attribute level 3
service-type ssh telnet terminal
service-type web
#
stp mode rstp
stp enable
#
interface Bridge-Aggregation1
description LACP_link_to_SYNOLOGY
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 10
port trunk pvid vlan 10
link-aggregation mode dynamic
#
interface NULL0
#
interface Vlan-interface1
ip address 10.203.5.2 255.255.255.0
#
interface Vlan-interface10
ip address 10.203.10.1 255.255.255.0
dhcp select relay
dhcp relay server-select 1
#
interface Vlan-interface20
ip address 10.203.20.1 255.255.255.0
dhcp select relay
dhcp relay server-select 1
#
interface Vlan-interface30
ip address 10.203.30.1 255.255.255.0
dhcp select relay
dhcp relay server-select 1
#
interface Vlan-interface40
ip address 10.203.40.1 255.255.255.0
dhcp select relay
dhcp relay server-select 1
#
interface GigabitEthernet1/0/1
stp edged-port enable
#
interface GigabitEthernet1/0/2
stp edged-port enable
#
interface GigabitEthernet1/0/3
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/4
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/5
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/6
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/7
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/8
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/9
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/10
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/11
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/12
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/13
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/14
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/15
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/16
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/17
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/18
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/19
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/20
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/21
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/22
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/23
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/24
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/25
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/26
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/27
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/28
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/29
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/30
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/31
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/32
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/33
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/34
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/35
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/36
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/37
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/38
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/39
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/40
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/41
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/42
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/43
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/44
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/45
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 10
port trunk pvid vlan 10
stp edged-port enable
link-aggregation port-priority 100
port link-aggregation group 1
#
interface GigabitEthernet1/0/46
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 10
port trunk pvid vlan 10
stp edged-port enable
link-aggregation port-priority 100
port link-aggregation group 1
#
interface GigabitEthernet1/0/47
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/48
port access vlan 10
stp edged-port enable
#
interface GigabitEthernet1/0/49
port link-type hybrid
port hybrid vlan 10 20 30 40 tagged
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/50
port link-type hybrid
port hybrid vlan 10 20 30 40 tagged
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/51
port link-type hybrid
port hybrid vlan 10 20 30 40 tagged
port hybrid vlan 1 untagged
stp edged-port enable
#
interface GigabitEthernet1/0/52
port link-type hybrid
port hybrid vlan 10 20 30 40 tagged
port hybrid vlan 1 untagged
stp edged-port enable
#
ip route-static 0.0.0.0 0.0.0.0 Vlan-interface1 10.203.5.1
#
snmp-agent
snmp-agent local-engineid 8000000B03CC3E5FE426FA
snmp-agent sys-info contact motz
snmp-agent sys-info location serverroom
snmp-agent sys-info version v3
#
dhcp enable
#
ssh server enable
#
qos vlan-policy vlan40_acl_vlan10 vlan 10 inbound
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 15
authentication-mode scheme
#
return

 

 

P.S. This thread has been moevd from Comware-Based to Web & Unmanaged. - Hp forum moderator

1 REPLY
Motz
Occasional Contributor
Solution

Re: V1910-48G - LACP on SFP ports not working

Hi guys,

 

I did solve my problems regarding LACP on the SFP ports. I found some insight from this post: Link

 

I found out that I already did assign the ports by them self to Hybrid but was trying to make the LACP as a Trunk. The ports and the LACP group has to be the same type if not the LACP group will not come up and the error doesn't give you any clues.

 

I used the following commands:

 

interface Bridge-Aggregation 2
description LACP_link_1
link-aggregation mode dynamic
quit

 

interface g1/0/49
port link-type access
port link-type hybrid
stp edged-port enable
link-aggregation port-priority 50
port link-aggregation group 2
quit

 

interface g1/0/50
port link-type access
port link-type hybrid
stp edged-port enable
link-aggregation port-priority 50
port link-aggregation group 2
quit


interface Bridge-Aggregation 2
port link-type hybrid
port hybrid vlan 1 untagged
port hybrid vlan 10 20 30 40 tagged
port hybrid pvid vlan 1

quit

 

Hope that this can help outers out there if they are facing the same problems as I was :o)