Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN Issues on ProCurve 1920

SOLVED
Go to solution
jlvirtra
Occasional Advisor

VLAN Issues on ProCurve 1920

Hello,

 

Hopefully I have this posted in the correct section. I'm having some issues getting multiple VLANs working on a ProCurve 1920 switch. The most puzzling part of this issue is that everything worked fine until I moved the switch to a different part of our building (but had it connected to the same trunk port on its neighbor switch, yes I saved the config before relocating the switch). 

 

So, here's the overall problem: The devices on my voice VLAN ports are unable to communicate with pretty much anything on the network (unable to obtain an IP address via DHCP, issue persists with static IP configured). Everything on the data VLAN works fine so far.

 

 Here are some details on my network's setup: 

 

We have two VLANS configured. One is for voice (100) and the other is for data (1). I started this job a couple of months ago and we were in the process of rolling out a new phone system. The previous phone system was on the data VLAN, so I'm assuming this was all one big flat network until just before I started this job. The data VLAN uses 172.16.0.xxx addresses while the voice VLAN uses 172.16.100.xxx addresses. I believe either a router or firewall handles DHCP for the voice VLAN. A domain controller handles DHCP for the data VLAN. Our desktops and phones directly connect to their own network drops. Our desktops do not connect to the PC ports on our phones. 

 

Our existing switches (ProCurve 2810, 2910) are working fine with this configuration: trunk ports (switch to switch links) are set to be tagged members on both VLAN 1 and 100, access ports are set to be untagged members of either VLAN 1 or 100 (depending on the device connected). When I initially set up the 1920 (after assigning it an IP address for remote access), I set ports 1-16 to be untagged members of VLAN 1 (ports for desktops and such only), ports 17-23 to be untagged members of VLAN 100 only (ports for phones only), and port 24 to be tagged on both VLAN 1 and 100. Port 24 on the 1920 connects to port 7 on our 2910 (set to be tagged on both VLAN 1 and 100). 

 

This configuration worked fine on the 1920 until I relocated it to a different part of our building. It is connected to a different network drop, but I have this drop connected to the same port 7 on the 2910 that worked perfectly fine during my testing. Since then, I have been pulling my hair out with all sorts of configuration changes, but I have made no progress. The issue persists on VLAN 100, but VLAN 1 works perfectly fine.

 

Any ideas on what to try or change to get this up and running? I've looked through the manual, set PVIDs, set static routes, made an interface for VLAN 100 (all of these were reverted since), but nothing has resolved the issue. I've got a copy of the manual and have been studying it since then. I am unable to un-deploy the switch and bring it back to a testing environment as we don't have a temporary replacement ready. 

 

Thanks

10 REPLIES
16again
Respected Contributor

Re: VLAN Issues on ProCurve 1920

Post your configs.

 

Vince-Whirlwind
Honored Contributor

Re: VLAN Issues on ProCurve 1920

"I've looked through the manual, set PVIDs,..."

The PVID opn the 1920 switchport 24 should be neither VLAN1 nor VLAN100

jlvirtra
Occasional Advisor

Re: VLAN Issues on ProCurve 1920

The PVID on port 24 on the 1920 is set to 89, which is a non-existent VLAN. 

Configs are below

 

Thanks

 


#
version 5.20.99, Release 1114
#
sysname 1920 Switch
#
clock timezone Arizona minus 07:00:00
#
domain default enable system
#
ipv6
#
ssl version ssl3.0 disable
#
web idle-timeout 999
#
password-recovery enable
#
vlan 1
description Data
#
vlan 100
description Voice
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
group-attribute allow-guest
#
local-user admin
password cipher redacted
authorization-attribute level 3
service-type lan-access
service-type ssh telnet terminal
service-type ftp
service-type web
#
stp mode rstp
stp enable
#
interface NULL0
#
interface Vlan-interface1
ip address 172.16.2.140 255.255.252.0
#
interface GigabitEthernet1/0/1
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/2
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/3
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/4
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/5
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/6
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/7
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/8
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/9
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/10
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/11
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/12
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/13
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/14
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/15
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/16
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/17
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/18
port access vlan 100
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/19
port access vlan 100
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/20
port access vlan 100
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/21
port access vlan 100
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/22
port access vlan 100
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/23
port access vlan 100
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/24
description Link to ProCurve5 Port 7
port link-type trunk
port trunk permit vlan 1 100
port auto-power-down
stp edged-port enable
#
interface GigabitEthernet1/0/25
stp edged-port enable
#
interface GigabitEthernet1/0/26
stp edged-port enable
#
interface GigabitEthernet1/0/27
stp edged-port enable
#
interface GigabitEthernet1/0/28
stp edged-port enable
#
undo info-center logfile enable
#
ntp-service source-interface Vlan-interface1
ntp-service unicast-server 172.16.0.46
ntp-service unicast-server 172.16.0.56
#
ssh server enable
sftp server enable
#
load xml-configuration
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 15
authentication-mode scheme
#
return

 

; J9145A Configuration Editor; Created on release #W.14.49

hostname "Switch 5"
module 1 type J9145A
interface 7
name "1920 Switch"
exit
trunk 7 Trk1 Trunk
vlan 1
name "DEFAULT_VLAN"
untagged 1,3-4,12,14,17-21,24,Trk1
ip address 172.16.0.25 255.255.252.0
no untagged 2,5-6,8-11,13,15-16,22-23
ip igmp
exit
vlan 100
name "Voice"
untagged 2,8-11,13,15-16,22-23
tagged 5-6
no ip address
exit
snmp-server community "public" unrestricted
snmp-server host 172.16.0.83 community "public"
snmp-server contact ""
spanning-tree Trk1 priority 4
no autorun
password manager
password operator

 

 

Vince-Whirlwind
Honored Contributor

Re: VLAN Issues on ProCurve 1920

The first config shows a trunked port24 which has VLANs 1 & 100 tagged on it.

The second config shows a switchport 7 which has been configured as Trk1 which has VLAN1 configured on it as untagged and no VLAN100 on it.

Or did I miss something?

jlvirtra
Occasional Advisor

Re: VLAN Issues on ProCurve 1920

You are correct. Originally, port 7 on the 2910 was not set up as a trunk, only as a port that was tagged on both VLANs. When I changed it over to a trunk after doing some testing, I forgot to check its VLAN setup. Trk1 is now set to tagged on both VLANs, but the issue persists.

Thanks

Vince-Whirlwind
Honored Contributor

Re: VLAN Issues on ProCurve 1920

We'll need to see the configs.

jlvirtra
Occasional Advisor

Re: VLAN Issues on ProCurve 1920

Is there a way to upload the config files or do I just copy/paste their contents on here? I tried to attach files last time, but it looks like the site only accepts certain photo formats.

 

Thanks

16again
Respected Contributor

Re: VLAN Issues on ProCurve 1920

Why do you setup procurve port 7 as trunk?
afaik, on procurve trunk means link aggregation, whereas on  comware it means a port has multiple VLANs on it

jlvirtra
Occasional Advisor

Re: VLAN Issues on ProCurve 1920

I had port 7 set up as a normal port before, and it still did not work right after I physically relocated the switch. I thought I would try that just in case it made a difference. Should I change port 7 back from a trunk to a regular port with both VLANs tagged on it then?

jlvirtra
Occasional Advisor
Solution

Re: VLAN Issues on ProCurve 1920

Problem has been solved. I accidentally created a switching loop (had two switch to switch connections). I removed the offending connection and everything worked fine. Lesson learned: always trace cables before plugging them in.

 

Thanks