Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN/Trunk HPE 1950 <> 2530

 
SOLVED
Go to solution
Tom-2019
Frequent Visitor

VLAN/Trunk HPE 1950 <> 2530

Hello !

We have a HPE 1950 with 2 VLANs:
VLAN ID = 1, for LAN
VLAN ID = 20, for VoIP

Port 34 is a Trunk:
Link type = Trunk
PVID = 1
Permit VLAN List = 1,20

----

On the other side is a HP Aruba 2530:
VLAN ID = 1, for LAN
VLAN ID = 20, for VoIP

Port 1 is a Trunk (connected to port 34 HPE 1950)
Group = Trk1
Typ = Trunk

Port 2-10 are a VoIP Devices, VLAN Port Assignment:
VLAN 0010 = no
VLAN 0020 = Untagged

These devices are working fine.

Problem:
Port 11-15 should be LAN Devices (VLAN 1), , VLAN Port Assignment:
VLAN 0010 = Untagged
VLAN 0020 = no

I got no connection to the lan. Sometimes for a few seconds.

Is the PVID=1 and VLAN-ID=1 a problem?
Thank you !

Tom

6 REPLIES 6
parnassus
Honored Contributor
Solution

Re: VLAN/Trunk HPE 1950 <> 2530


@Tom-2019 wrote:

On the other side is a HP Aruba 2530:
VLAN ID = 1, for LAN
VLAN ID = 20, for VoIP

Port 1 is a Trunk (connected to port 34 HPE 1950)
Group = Trk1
Typ = Trunk

The problem is you used an aggregated links logical interface "Trk1" (which member ports?)...that's wrong...you misunderstood the term "trunk" used on ArubaOS-Switch based Switch series (which doesn't mean a port carrying multiple VLAN Ids like on Comware based Switches like the HPE OfficeConnect 1950...).

Retry by using a single physical interface and tag it that way:

config

interface ethernet X untagged vlan 1

interface ethernet X tagged vlan 20

vlan 20

voice

exit

write memory

and...


@Tom-2019 wrote:


Port 2-10 are a VoIP Devices, VLAN Port Assignment:
VLAN 0010 = no
VLAN 0020 = Untagged

These devices are working fine.


generally VoIP devices (VoIP Phones) are connected to ports which are tagged member of Voice VLAN...so

config

vlan 20

tagged 2-15

exit

and

vlan 1

untagged 2-15

exit

write memory

 

Tom-2019
Frequent Visitor

Re: VLAN/Trunk HPE 1950 <> 2530

Hello Parnassus,

thank you very much! You‘re right, I misunderstood the term "trunk" used on ArubaOS-Switch based Switch series.

Only interface 1 (uplink) is member of trk1 on the 2530. I’m connect to the 1950. If I delete trk1 now, I will lose connection to the switch.

Topology:
HP2530-Interface-34 => UPLINK => Interface-1-HP1950

The vlan config on the 1950 is:

interface GigabitEthernet1/0/1
port access vlan 20
poe enable
#

interface GigabitEthernet1/0/2
poe enable
#

interface GigabitEthernet1/0/3
port access vlan 20
poe enable
#

interface GigabitEthernet1/0/4
poe enable
#

interface GigabitEthernet1/0/5
port access vlan 20
poe enable
#

interface GigabitEthernet1/0/6
poe enable
#
...

interface GigabitEthernet1/0/34
port link-type trunk
port trunk permit vlan 1 20
poe enable
#

I think this means tagged ports for the vlan20 (voice) on interface 1/0/1; 1/0/3; 1/0/5.

 

The current vlan config on the 2530 is:

trunk 1 trk1 trunk

vlan 1
   name "VLAN 0001"
   no untagged 2-4,6-28
   untagged 5
   tagged Trk1
   no ip address
   exit

vlan 20
   name "VLAN 0020 VOIP"
   untagged 2-4,6-28
   tagged Trk1
   ip address 10.1.1.2 255.255.255.0
   exit

spanning-tree Trk1 priority 4

interface 1 (current trk1) uplink.
interface 5 => vlan001.
interface 2-4,6-28 vlan0020 

Does the config match to the 1950? I think uplink interface 1 should be tagged in both vlans.

Thank you again
Tom

 

 

 

parnassus
Honored Contributor

Re: VLAN/Trunk HPE 1950 <> 2530


@Tom-2019 wrote: Only interface 1 (uplink) is member of trk1 on the 2530.

Hi Tom.

That's the reason I wrote you that...if you're going to use ONLY one physical interface for inter-linking your two Switches then you must not use any Ports Aggregation with that interface on Aruba 2530 side...simply because there isn't a matching Ports Aggregation on the peer 1950. So one interface on HPE 1950 <-- uplink --> one interface on Aruba 2530. Very simple (as is and as you already wired). Different is if you PLAN to have a Ports Aggregation but you actually just connect both peers with one cable (but you plan to add another one - or more ones - at later time)...but I thing that wasn't your purpose.


@Tom-2019 wrote: If I delete trk1 now, I will lose connection to the switch.

That's absolutely normal...you're deleting a logical interface with its physical member interface (port 34 of Aruba 2530)...IMHO you should connect directly to Aruba 2530 and do the change: remove Trk1 and change tagging of port 34 (which returns to be untagged in VLAN id 1) to match what is on interface 1 on HPE 1950.


@Tom-2019 wrote:

 

The vlan config on the 1950 is:

interface GigabitEthernet1/0/1
port access vlan 20
poe enable
#

interface GigabitEthernet1/0/2
poe enable
#

interface GigabitEthernet1/0/3
port access vlan 20
poe enable
#

interface GigabitEthernet1/0/4
poe enable
#

interface GigabitEthernet1/0/5
port access vlan 20
poe enable
#

interface GigabitEthernet1/0/6
poe enable
#
...

interface GigabitEthernet1/0/34
port link-type trunk
port trunk permit vlan 1 20
poe enable
#

I think this means tagged ports for the vlan20 (voice) on interface 1/0/1; 1/0/3; 1/0/5.

No...on HPE OfficeConnect 1950 an interface with port access set to a particular VLAN id means that that interface is untagged on that particular VLAN id...which is 20 (and when it is not specified...default wins...so the interface is Untagged member of VLAN id 1)...so 1/0/1, 1/0/3 and 1/0/5 are Untagged member of VLAN id 20, defaulted interface are instead Untagged member of VLAN id 1. Uplink interface 1/0/34 is Untagged member of VLAN id 1 and Tagged member of VLAN id 20...and, if this is your desired config, the port on Aruba 2530 should match that.


@Tom-2019 wrote:

 

The current vlan config on the 2530 is:

trunk 1 trk1 trunk

vlan 1
   name "VLAN 0001"
   no untagged 2-4,6-28
   untagged 5
   tagged Trk1
   no ip address
   exit

vlan 20
   name "VLAN 0020 VOIP"
   untagged 2-4,6-28
   tagged Trk1
   ip address 10.1.1.2 255.255.255.0
   exit

spanning-tree Trk1 priority 4

interface 1 (current trk1) uplink.
interface 5 => vlan001.
interface 2-4,6-28 vlan0020 

Does the config match to the 1950? I think uplink interface 1 should be tagged in both vlans.


Considering that Aruba 2530 shows this:

trunk 1 trk1 trunk
vlan 1
   name "VLAN 0001"
   no untagged 2-4,6-28
   untagged 5
   tagged Trk1
   no ip address
   exit
vlan 20
   name "VLAN 0020 VOIP"
   untagged 2-4,6-28
   tagged Trk1
   ip address 10.1.1.2 255.255.255.0
   exit
spanning-tree Trk1 priority 4

 

You should start by deleting trk1 logical interface (you must be on the Aruba 2530 to do that without losing connection) and then set that port 1 is an Untagged member of VLAN id 1 and concurrently a Tagged member of VLAN id 20, do that with these two commands:

interface ethernet 1 untagged vlan 1
interface ethernet 1 tagged vlan 20

 

Check result with show vlan port 1 detail command.

From what you reported ports' ranges 2-4 and 6-28 are ONLY tagged member (no untagged on VLAN 1) Untagged members of VLAN id 20...I don't know if this is wanted...generally, as written, ports are Tagged members of a Voice VLAN and Untagged members of a User dedicated VLAN id when the scenario is PC <---> VoIP Terminal <---> Switch Port scenario (but here it seems you have PC <---> Switch Port and VoIP Terminal <---> Switch Port...) in any case if I were you I will reconfigure to use Voice VLAN tagged other than Untagged on access ports...and do the same on HPE OfficeConnect 1950 (in this case access ports will become of type trunk because they will carry a VLAN id - the Voice one - tagged).

Port 5 is the only one port which is currently Untagged member of VLAN id 1 and hasn't other tagging.

Tom-2019
Frequent Visitor

Re: VLAN/Trunk HPE 1950 <> 2530

Hello Parnassus,

thank you very much for your extensive answer. I’ll configure your suggestions next week and give you a feedback.

Regards,
Tom

Thomas-DP
Occasional Visitor

Re: VLAN/Trunk HPE 1950 <> 2530

Hello Parnassus,

Thanks again for your support ! All VLANs are working fine now

Regards,
Tom

 

parnassus
Honored Contributor

Re: VLAN/Trunk HPE 1950 <> 2530

I'm glad you solved. If so...please give Kudos and mark the post that solved "Accept as solution". Thanks.