HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Web and Unmanaged
cancel
Showing results for 
Search instead for 
Did you mean: 

v1910 vlan not routing.

 
MichaelRicardo
Frequent Advisor

v1910 vlan not routing.

Hello,

I am unable to route between vlan - 21 & 22 to rest of the network. 

Any help appreciated.

-------

 

VLANS

Port Untagged Membership Tagged Membership Link Type PVID

GE1/0/1 2 21-22 Hybrid 2
GE1/0/3 2 21-22 Hybrid 2
GE1/0/5 2 21-22 Hybrid 2
GE1/0/7 2 21-22 Hybrid 2
GE1/0/9 2 22 Hybrid 2
GE1/0/11 21 22 Hybrid 2
GE1/0/13 2 Hybrid 2
GE1/0/15 2 Hybrid 2
GE1/0/17 2 Access 2
GE1/0/19 21 Access 21
GE1/0/21 2 Hybrid 2
GE1/0/23 2 Hybrid 2
GE1/0/2 2 21-22 Hybrid 2
GE1/0/4 2 21-22 Hybrid 2
GE1/0/6 2 21-22 Hybrid 2
GE1/0/8 2 21-22 Hybrid 2
GE1/0/10 2 Hybrid 2
GE1/0/12 21 22 Hybrid 2
GE1/0/14 2 Hybrid 2
GE1/0/16 2 Hybrid 2
GE1/0/18 1 Access 1
GE1/0/20 21 Access 21
GE1/0/22 22 Access 22
GE1/0/24 1-2 21-22 Hybrid 2
GE1/0/25 1 Access 1
GE1/0/26 1 Access 1
GE1/0/27 1 Access 1
GE1/0/28 1 Access 1

------

Port Untagged Membership Tagged Membership Link Type PVID

GE1/0/18 1 Access 1
GE1/0/19 21 Access 21
GE1/0/20 21 Access 21
GE1/0/21 2 Hybrid 2
GE1/0/22 22 Access 22
GE1/0/23 2 Hybrid 2
GE1/0/24 1-2 21-22 Hybrid 2


ROUTING

Active route table

Destination IP Address Mask Protocol Preference Next Hop Interface

0.0.0.0 0.0.0.0 Static 10 172.31.2.1 Vlan-interface2
127.0.0.0 255.0.0.0 Direct 0 127.0.0.1 InLoopBack0
127.0.0.1 255.255.255.255 Direct 0 127.0.0.1 InLoopBack0
172.31.2.0 255.255.255.0 Direct 0 172.31.2.18 Vlan-interface2
172.31.2.18 255.255.255.255 Direct 0 127.0.0.1 InLoopBack0
172.31.21.0 255.255.255.0 Direct 0 172.31.21.3 Vlan-interface21
172.31.21.3 255.255.255.255 Direct 0 127.0.0.1 InLoopBack0
172.31.22.0 255.255.255.0 Direct 0 172.31.22.3 Vlan-interface22
172.31.22.3 255.255.255.255 Direct 0 127.0.0.1 InLoopBack0

 

 

--------
#
version 5.20, Release 1513P99
#
sysname har-wfi-sw-01
#
clock timezone UTC add 00:00:00
#
super password level 3 cipher $c$3$S5qJ++iUrcWItWPoqyCASKz8otlwpoyzozs=
#
dhcp relay server-group 0 ip 172.31.4.50
#
domain default enable system
#
ip ttl-expires enable
#
lldp enable
lldp compliance cdp
#
password-recovery enable
#
acl number 3001 name DENY-GUEST
rule 0 deny ip source 192.168.0.0 0.0.255.255 destination 172.31.70.0 0.0.1.255
rule 5 permit ip
#
vlan 1
description DEFAULT
#
vlan 2
description VLAN 2
#
vlan 21
description VLAN 21
#
vlan 22
description VLAN 22
#
radius scheme system
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
stp mode rstp
stp enable
#
interface NULL0
#
interface Vlan-interface1
ip address 192.168.2.2 255.255.255.0
dhcp relay server-select 0
#
interface Vlan-interface2
ip address 172.31.2.18 255.255.255.0
dhcp select relay
dhcp relay server-select 0
#
interface Vlan-interface21
ip address 172.31.21.3 255.255.255.0
dhcp select relay
dhcp relay server-select 0
#
interface Vlan-interface22
ip address 172.31.22.3 255.255.255.0
#
interface GigabitEthernet1/0/1
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 21 to 22 tagged
port hybrid vlan 2 untagged
port hybrid pvid vlan 2
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/2
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 21 to 22 tagged
port hybrid vlan 2 untagged
port hybrid pvid vlan 2
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/3
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 21 to 22 tagged
port hybrid vlan 2 untagged
port hybrid pvid vlan 2
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/4
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 21 to 22 tagged
port hybrid vlan 2 untagged
port hybrid pvid vlan 2
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/5
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 21 to 22 tagged
port hybrid vlan 2 untagged
port hybrid pvid vlan 2
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/6
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 21 to 22 tagged
port hybrid vlan 2 untagged
port hybrid pvid vlan 2
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/7
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 21 to 22 tagged
port hybrid vlan 2 untagged
port hybrid pvid vlan 2
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/8
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 21 to 22 tagged
port hybrid vlan 2 untagged
port hybrid pvid vlan 2
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/9
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 22 tagged
port hybrid vlan 2 untagged
port hybrid pvid vlan 2
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/10
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 2 untagged
port hybrid pvid vlan 2
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/11
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 22 tagged
port hybrid vlan 21 untagged
port hybrid pvid vlan 2
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/12
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 22 tagged
port hybrid vlan 21 untagged
port hybrid pvid vlan 2
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/13
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 2 untagged
port hybrid pvid vlan 2
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/14
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 2 untagged
port hybrid pvid vlan 2
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/15
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 2 untagged
port hybrid pvid vlan 2
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/16
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 2 untagged
port hybrid pvid vlan 2
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/17
port access vlan 2
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/18
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/19
port access vlan 21
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/20
port access vlan 21
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/21
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 2 untagged
port hybrid pvid vlan 2
poe enable
packet-filter 3001 inbound
stp edged-port enable
#
interface GigabitEthernet1/0/22
port access vlan 22
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/23
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 2 untagged
port hybrid pvid vlan 2
poe enable
packet-filter 3001 inbound
stp edged-port enable
#
interface GigabitEthernet1/0/24
port link-type hybrid
port hybrid vlan 21 to 22 tagged
port hybrid vlan 1 to 2 untagged
port hybrid pvid vlan 2
poe enable
stp edged-port enable
#
interface GigabitEthernet1/0/25
stp edged-port enable
#
interface GigabitEthernet1/0/26
stp edged-port enable
#
interface GigabitEthernet1/0/27
stp edged-port enable
#
interface GigabitEthernet1/0/28
stp edged-port enable
#
ip route-static 0.0.0.0 0.0.0.0 192.168.2.1
ip route-static 0.0.0.0 0.0.0.0 Vlan-interface2 172.31.2.1 preference 10
ip route-static 0.0.0.0 0.0.0.0 Vlan-interface21 172.31.21.1
ip route-static 0.0.0.0 0.0.0.0 Vlan-interface22 172.31.22.1
#
dhcp enable
#
ntp-service authentication enable
ntp-service authentication-keyid 1 authentication-mode md5 cipher $c$3$GlnrEkrpjgBmiIsXh8yMMam0ZSq3HLU=
ntp-service reliable authentication-keyid 1
ntp-service unicast-server 69.50.219.51 authentication-keyid 1
ntp-service unicast-server 172.31.70.10 authentication-keyid 1
#
ssh server enable
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 15
authentication-mode scheme
#
return

 

 

2 REPLIES
johnk3r
Respected Contributor

Re: v1910 vlan not routing.

Hi.

1 - You posted your problem in the wrong section.


2 - Why is configured static routes below? If the switch is L3 these routes are not necessary.
ip route-static 0.0.0.0 0.0.0.0 VLAN-interface2 172.31.2.1 preference 10
ip route-static 0.0.0.0 0.0.0.0 VLAN-Interface21 172.31.21.1
ip route-static 0.0.0.0 0.0.0.0 VLAN-interface22 172.31.22.1

3 - The gateway of the machine is the switch?

4 - Not found information that 1910 is an L3 switch ....

 

 

**************************************
ATP FLEXNETWORK V3 | ACSA
MichaelRicardo
Frequent Advisor

Re: v1910 vlan not routing.

I know posted on the worng form - cause i was looing at msm 760 stuff - I also found the caused of the prolem. uplink port was moved to another on a core switch and its wasnt tagged with vlans in question.

yes - other routing are ignore - only one matter. 

Destination IP Address Mask Protocol Preference Next Hop Interface
0.0.0.0 0.0.0.0 Static 10 172.31.2.1 Vlan-interface2
127.0.0.0 255.0.0.0 Direct 0 127.0.0.1 InLoopBack0
127.0.0.1 255.255.255.255 Direct 0 127.0.0.1 InLoopBack0
172.31.2.0 255.255.255.0 Direct 0 172.31.2.18 Vlan-interface2
172.31.2.18 255.255.255.255 Direct 0 127.0.0.1 InLoopBack0
172.31.21.0 255.255.255.0 Direct 0 172.31.21.3 Vlan-interface21
172.31.21.3 255.255.255.255 Direct 0 127.0.0.1 InLoopBack0
172.31.22.0 255.255.255.0 Direct 0 172.31.22.3 Vlan-interface22
172.31.22.3 255.255.255.255 Direct 0 127.0.0.1 InLoopBack0
192.168.2.0 255.255.255.0 Direct 0 192.168.2.2 Vlan-interface1
192.168.2.2 255.255.255.255 Direct 0 127.0.0.1 InLoopBack0